Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 38

Thread: Enable Wireless - unchecked and greyed out

  1. #21
    Join Date
    Sep 2010
    Location
    USA, North Carolina
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Enable Wireless - unchecked and greyed out

    First-timer asking for help. ^^'

    I have a strange problem with the wireless too, where the Enable Wireless option is unchecked and grayed out. (Dell Inspiron n5010)

    When I run 'rfkill list' and 'sudo lshw -C network' one way I get this:

    --
    0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    1: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    --
    *-network DISABLED
    description: Wireless interface
    product: WiMAX/WiFi Link 6050 Series
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:12:00.0
    logical name: wlan0
    version: 57
    serial: 00:23:15:1d:3b:d0
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=iwlagn driverversion=2.6.32-24-generic firmware=9.201.4.1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
    resources: irq:34 memory:fbc00000-fbc01fff
    *-network
    description: Ethernet interface
    product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:13:00.0
    logical name: eth0
    version: 02
    serial: a4:ba:db:c8:66:be
    size: 100MB/s
    capacity: 100MB/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=75.191.248.135 latency=0 link=yes multicast=yes port=MII speed=100MB/s
    resources: irq:33 ioport:e000(size=256) memory:d0b10000-d0b10fff(prefetchable) memory:d0b00000-d0b0ffff(prefetchable) memory:fb200000-fb21ffff(prefetchable)
    --

    However, when I press the wireless key and run the two again, it changes to this:

    --
    0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    1: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: yes
    2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    --
    *-network
    description: Wireless interface
    product: WiMAX/WiFi Link 6050 Series
    vendor: Intel Corporation
    physical id: 0
    bus info: pci@0000:12:00.0
    logical name: wlan0
    version: 57
    serial: 00:23:15:1d:3b:d0
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
    configuration: broadcast=yes driver=iwlagn driverversion=2.6.32-24-generic firmware=9.201.4.1 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
    resources: irq:34 memory:fbc00000-fbc01fff
    *-network
    description: Ethernet interface
    product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
    vendor: Realtek Semiconductor Co., Ltd.
    physical id: 0
    bus info: pci@0000:13:00.0
    logical name: eth0
    version: 02
    serial: a4:ba:db:c8:66:be
    size: 100MB/s
    capacity: 100MB/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=75.191.248.135 latency=0 link=yes multicast=yes port=MII speed=100MB/s
    resources: irq:33 ioport:e000(size=256) memory:d0b10000-d0b10fff(prefetchable) memory:d0b00000-d0b0ffff(prefetchable) memory:fb200000-fb21ffff(prefetchable)
    --

    ... and that goes back and forth.

    Any advice?

  2. #22
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,233
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enable Wireless - unchecked and greyed out

    Please run:
    Code:
    sudo rmmod -f dell-laptop
    Repeat the tests. If the wireless is working now, do:
    Code:
    sudo su
    echo "blacklist dell-laptop" >> /etc/modprobe.d/blacklist.conf
    exit
    Then the errant module will be permanently blacklisted.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #23
    Join Date
    Sep 2010
    Location
    USA, North Carolina
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Enable Wireless - unchecked and greyed out

    I followed your instructions and it worked, my wireless is fine.
    But can you, by any chance, tell me what 'sudo rmmod -f dell-laptop' does, and why it needed to be handled as it did ('echo "blacklist dell-laptop" >> /etc/modprobe.d/blacklist.conf')?

    I'm trying to learn some stuff here at the same time, and hopefully, this will help me help others. ^^

  4. #24
    Join Date
    Aug 2009
    Location
    127.0.0.1
    Beans
    103
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Enable Wireless - unchecked and greyed out

    Ive got the same problem on an Acer Aspire One but neither the 'rfkill unblock all' nor the 'sudo rmmod -f sn-netbook' have any effect.

    Am I missing something here? Whats the correct name of the module for Acer Aspire Ones?

  5. #25
    Join Date
    Apr 2009
    Beans
    2,601

    Re: Enable Wireless - unchecked and greyed out

    Quote Originally Posted by iharacomix View Post
    I followed your instructions and it worked, my wireless is fine.
    But can you, by any chance, tell me what 'sudo rmmod -f dell-laptop' does, and why it needed to be handled as it did ('echo "blacklist dell-laptop" >> /etc/modprobe.d/blacklist.conf')?

    I'm trying to learn some stuff here at the same time, and hopefully, this will help me help others. ^^

    The first command temporarily removed the dell-laptop module. It would have returned at the next boot. The second made it permanent by not allowing it to load at boot-time (blacklisted it).

    From an earlier Dr Chili post (must be coffee-ing!)

    Code:
    February 24th, 2010, 09:41 AM
    dell-laptop is supposed to enable some functions that are unique to Dell. As you can see, it doesn't work well. I suspect that it conflicts with another similar module, dell-wmi. If you notice that other functions now don't work correctly, obviously reverse the removal.
    .
    .
    .
    
    dell-laptop is now blacklisted and will not reload on boot, unless, of course, you edit /etc/modprobe.d/blacklist.conf to remove the blacklist line.

  6. #26
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,233
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enable Wireless - unchecked and greyed out

    Quote Originally Posted by hockeytux View Post
    Ive got the same problem on an Acer Aspire One but neither the 'rfkill unblock all' nor the 'sudo rmmod -f sn-netbook' have any effect.

    Am I missing something here? Whats the correct name of the module for Acer Aspire Ones?
    Would you please start a new thread and PM me if I don't catch it right away?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #27
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,233
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enable Wireless - unchecked and greyed out

    The first command temporarily removed the dell-laptop module. It would have returned at the next boot. The second made it permanent by not allowing it to load at boot-time (blacklisted it).
    Exactly correct!
    From an earlier Dr Chili post (must be coffee-ing!)
    Also exactly correct!
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #28
    Join Date
    Sep 2010
    Location
    USA, North Carolina
    Beans
    4
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Enable Wireless - unchecked and greyed out

    Thanks, (Dr?) Chili and bkratz, for the help/information! ^^

  9. #29
    Join Date
    Sep 2010
    Beans
    1

    Re: Enable Wireless - unchecked and greyed out

    Quote Originally Posted by chili555 View Post
    Please run:
    Code:
    sudo rmmod -f dell-laptop
    Repeat the tests. If the wireless is working now, do:
    Code:
    sudo su
    echo "blacklist dell-laptop" >> /etc/modprobe.d/blacklist.conf
    exit
    Then the errant module will be permanently blacklisted.
    This thing should be a sticky !!

    It was a life saver for me.

    Any idea why this happened ? Is there an issue with 10.4 or was there a later update that I took ?

    But - thanks a lot for all who contributed to this simple 2 step solution.. saved me lot of grief.

    I've created an account on the forum to just thank you guys !

  10. #30
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,233
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Enable Wireless - unchecked and greyed out

    Any idea why this happened ? Is there an issue with 10.4 or was there a later update that I took ?
    I think dell-laptop, the module that translates key presses to kernel activity, has been flaky for some time, not just in 10.04. It is ironic that the fix is to just remove it.

    See, for instance, posts #3 and 4 here: http://ubuntuforums.org/showthread.php?t=1414946
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •