Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38

Thread: Enable Wireless - unchecked and greyed out

  1. #11
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,399
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Enable Wireless - unchecked and greyed out

    Quote Originally Posted by spawnywhippet View Post
    HP 6910p
    There is a module that usually gets loaded called hp-wmi.
    $ modinfo hp-wmi
    filename: /lib/modules/2.6.32-22-generic/kernel/drivers/platform/x86/hp-wmi.ko
    alias: wmi:5FB7F034-2C63-45e9-BE91-3D44E2C707E4
    alias: wmi:95F24279-4D7B-4334-9387-ACCDC67EF61C
    license: GPL
    description: HP laptop WMI hotkeys driver
    You can verify if it's loaded with:
    Code:
    lsmod | grep wmi
    Perhaps it is not working correctly. Please try:
    Code:
    sudo rmmod -f hp-wmi
    Now manipulate the wireless switch and run:
    Code:
    rfkill list
    See if any switch presses coax the wireless to life. The LED may or may not be a reliable indicator.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #12
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,399
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Enable Wireless - unchecked and greyed out

    I also noticed this: http://mandriva.598463.n5.nabble.com...-td618377.html

    Especially comment #6:
    Code:
    The hardware killswitch and the software killswitch has ended up out of sync,
    so when you disable the hw switch, the sw switch gets enabled, and when you
    enable the hw switch, the sw switch gets disabled.
    
    In both cases either the hw or the sw switch blocks the wireless from working.
    
    There is a bug, either in the hardware, firmware or in the linux code that does
    not protect theese from getting out of sync. I'll check upstream if something
    like this is fixed...
    
    The rfkill utility is helpful in getting them in sync again. you really only
    need the "rfkill unblock all" to get it back in sync
    You might try booting with the wireless switch off and then turn it on and see if the wireless is working. You might also try:
    Code:
    sudo rfkill unblock all
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #13
    Join Date
    Apr 2008
    Location
    Singapore
    Beans
    31
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Enable Wireless - unchecked and greyed out

    Quote Originally Posted by chili555 View Post
    There is a module that usually gets loaded called hp-wmi.You can verify if it's loaded with:
    Code:
    lsmod | grep wmi
    I have no clue what this means, but I guess its not good :
    Code:
    ubuntu-laptop:~$ lsmod | grep wmi
    snd_rawmidi            23420  1 snd_seq_midi
    snd_seq_device          6888  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    snd                    71106  16 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    Quote Originally Posted by chili555 View Post
    Perhaps it is not working correctly. Please try:
    Code:
    sudo rmmod -f hp-wmi
    Seems not to be loaded, how do I install this?:
    Code:
    ubuntu-laptop:~$ sudo rmmod -f hp-wmi
    [sudo] password for andy: 
    ERROR: Removing 'hp_wmi': No such file or directory
    Quote Originally Posted by chili555 View Post
    Now manipulate the wireless switch and run:
    Code:
    rfkill list
    See if any switch presses coax the wireless to life. The LED may or may not be a reliable indicator.
    I guess this will have no chance of working if the WMI isn't even loaded?
    Windows Poweruser since 1996 but now a Vista refugee to Ubuntu 10.04

  4. #14
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,399
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Enable Wireless - unchecked and greyed out

    I believe it's included in the kernel. Please try:
    Code:
    sudo modprobe hp-wmi
    Post any errors or warnings.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #15
    Join Date
    Apr 2008
    Location
    Singapore
    Beans
    31
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Enable Wireless - unchecked and greyed out

    Quote Originally Posted by chili555 View Post
    I believe it's included in the kernel. Please try:
    Code:
    sudo modprobe hp-wmi
    Post any errors or warnings.
    OK, 'sudo modprobe hp-wmi' didn't seem to do anything, so I added it to /etc/modules and rebooted.

    Code:
    ubuntu-laptop:~$ lsmod | grep wmi
    snd_rawmidi            23420  1 snd_seq_midi
    snd_seq_device          6888  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
    hp_wmi                  5321  0 
    snd                    71106  16 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
    But now it gets weirder. Toggling the Wireless switch enables the bluetooth now, but doesn't seem to want to know the WiFi card.
    Code:
    andy@ubuntu-laptop:~$ rfkill unblock all
    andy@ubuntu-laptop:~$ rfkill list
    0: hp-wifi: Wireless LAN
    	Soft blocked: yes
    	Hard blocked: no
    1: hp-bluetooth: Bluetooth
    	Soft blocked: no
    	Hard blocked: no
    2: hp-wwan: Wireless WAN
    	Soft blocked: no
    	Hard blocked: no
    3: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: yes
    4: hci0: Bluetooth
    	Soft blocked: no
    	Hard blocked: no
    Still cannot enable Wireless, its all greyed out....
    Code:
      *-network DISABLED
           description: Wireless interface
           product: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
           vendor: Intel Corporation
           physical id: 0
           bus info: pci@0000:10:00.0
           logical name: wlan0
           version: 61
           serial: 00:1d:e0:67:7b:03
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=iwlagn latency=0 multicast=yes wireless=IEEE 802.11abgn
           resources: irq:31 memory:d8000000-d8001fff
    Last edited by spawnywhippet; September 1st, 2010 at 04:18 PM.
    Windows Poweruser since 1996 but now a Vista refugee to Ubuntu 10.04

  6. #16
    Join Date
    Sep 2010
    Beans
    6

    Re: Enable Wireless - unchecked and greyed out

    I have been running Ubuntu 8.04 for a while on my Dell Vostro 1520 laptop, and recently switched to 10.04. However, the only way I can get a wireless connection is if I turn the computer on with the wifi switch in the off position, and then turning it on once I have logged in. Otherwise, my network manager has the option of enabling wireless networks greyed out and unchecked. Is there something I can do about this whole switching off thing, or do I just have to buckle down and remember to turn wifi off before I boot up?

  7. #17
    Join Date
    Jan 2007
    Location
    Ciudad Juarez
    Beans
    47
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Enable Wireless - unchecked and greyed out

    Quote Originally Posted by ISIRC10 View Post
    I have been running Ubuntu 8.04 for a while on my Dell Vostro 1520 laptop, and recently switched to 10.04. However, the only way I can get a wireless connection is if I turn the computer on with the wifi switch in the off position, and then turning it on once I have logged in. Otherwise, my network manager has the option of enabling wireless networks greyed out and unchecked. Is there something I can do about this whole switching off thing, or do I just have to buckle down and remember to turn wifi off before I boot up?
    You can do as I did on my Dell Inspiron, in terminal run "sudo rmmod -f dell-laptop". That did it for me.
    "Yo no soy cobarde, Padre, yo soy pacifista, que no es lo mismo. Odio el derramamiento de sangre inutil, y tambien el util. Por eso yo odio la guerra. La guerra fria, la guerra caliente y la guerra fria." -- Tin Tan

  8. #18
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,399
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Enable Wireless - unchecked and greyed out

    If that works for you, then do:
    Code:
    sudo su
    echo dell-laptop >> /etc/modprobe.d/blacklist.conf
    exit
    The module will then be blacklisted permanently.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  9. #19
    Join Date
    Apr 2008
    Location
    Singapore
    Beans
    31
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Enable Wireless - unchecked and greyed out

    I have now solved my WLAN card issue. I ended up physically removing the wireless card from the laptop, booting into Ubuntu, then shutting down and refitting the card.

    I then booted into Ubuntu with the wireless switch in the 'On' position and Ubuntu immediately detected a wireless network.

    The WiFi toggle switch now correctly operates also.
    Windows Poweruser since 1996 but now a Vista refugee to Ubuntu 10.04

  10. #20
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,399
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Enable Wireless - unchecked and greyed out

    Glad it's working now.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 2 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •