Results 1 to 4 of 4

Thread: Client on LAN can't be pinged by other clients

  1. #1
    Join Date
    Jan 2007
    Beans
    552

    Client on LAN can't be pinged by other clients. WiFi card sleeping?

    I have two computers, a desktop and a laptop, both running Kubuntu 9.04 64 bit, both connecting over wifi.

    Computer A: The Desktop has a RaLink RT2561/RT61 PCI card
    Computer B: The Laptop is a MacBook Pro (5,1)
    The Router is a WRT54G.

    both computers can connect to the internet without problems. The difficulty is in trying to use (A) as a print and file server - I can get that working for a little while, but after a little while (A) disappears and (B) can't connect to it anymore. At first I tried different configurations with Avahi, CUPS, my ftp server, and using static or dynamic addresses; connecting from (B) using zeroconf, or connecting from (B) using the explicit IP address of (A). All methods stop working after a little while, and I've now discovered that (B) also cannot Ping (A), so naturally nothing else will work.

    A is 10.0.0.105
    B is 10.0.0.104
    Router is 10.0.0.1

    I can ping B from A, but can't ping A from B. I can get to Router from both, and to the internet from both. I have not done any firewall configuration.

    I can connect to A for a little while, but then it stops. If I go back to A and do some network activity there, like some web browsing, I can now connect to A from B. Then after a while it stops working again. Is there a setting on the RaLink driver that makes it go to sleep when it's inactive?
    Last edited by skullmunky; August 31st, 2009 at 02:01 AM.

  2. #2
    Join Date
    Aug 2009
    Location
    Montevideo, Uruguay
    Beans
    259
    Distro
    Ubuntu

    Re: Client on LAN can't be pinged by other clients. WiFi card sleeping?

    Are you using default installations? I know for a fact you can configure it to ignore ping requests.

  3. #3
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Client on LAN can't be pinged by other clients. WiFi card sleeping?

    Quote Originally Posted by skullmunky View Post
    Is there a setting on the RaLink driver that makes it go to sleep when it's inactive?
    Dunno about the driver, but BIOS and Power Management might be worth checking.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  4. #4
    Join Date
    Feb 2009
    Location
    Riga, Latvia
    Beans
    22
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Client on LAN can't be pinged by other clients

    I have the same problem too.
    Maybe it can be solved in iwconfig (power):
    Code:
    power  Used to manipulate power management scheme parameters and mode.
                  To  set  the  period between wake ups, enter period `value'.  To
                  set the timeout  before  going  back  to  sleep,  enter  timeout
                  `value'.  To set the generic level of power saving, enter saving
                  `value'.  You can  also  add  the  min  and  max  modifiers.  By
                  default,  those  values are in seconds, append the suffix m or u
                  to specify values in milliseconds  or  microseconds.  Sometimes,
                  those values are without units (number of beacon periods, dwell,
                  percentage or similar).
                  off and on disable and reenable power management.  Finally,  you
                  may  set the power management mode to all (receive all packets),
                  unicast (receive unicast packets  only,  discard  multicast  and
                  broadcast)  and multicast (receive multicast and broadcast only,
                  discard unicast packets).
                  Examples :
                       iwconfig eth0 power period 2
                       iwconfig eth0 power 500m unicast
                       iwconfig eth0 power timeout 300u all
                       iwconfig eth0 power saving 3
                       iwconfig eth0 power off
                       iwconfig eth0 power min period 2 power max period 4
    But what's the difference between "off" and "all"?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •