Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: can't ssh into server unless a user is logged in

  1. #11
    Join Date
    Oct 2008
    Beans
    6

    Re: can't ssh into server unless a user is logged in

    FWIW, I just found this thread on a search and wanted to say I'm having the same issue.

    Attempting to log in to my Ubuntu 9.04 Server box from a 9.10 Desktop installation. I can't log in unless I've actually logged in on the server first. If it's on the login screen, I get the Permission denied (publickey).

  2. #12
    Join Date
    Jul 2006
    Location
    Rotterdam, Netherlands
    Beans
    163
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: can't ssh into server unless a user is logged in

    Is your home directory encrypted?
    If it is, ~/.ssh/authorized_keys is not available until you log in on the server.

  3. #13
    Join Date
    Oct 2008
    Beans
    6

    Re: can't ssh into server unless a user is logged in

    Holy cow. (headslap)
    That must be it! I've been pulling my hair out with file permissions and it's gotta be the encrypted home directory!

  4. #14
    Join Date
    Jul 2006
    Location
    Rotterdam, Netherlands
    Beans
    163
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: can't ssh into server unless a user is logged in

    In that case, this is a possible solution:
    https://help.ubuntu.com/community/SS...roubleshooting

  5. #15
    Join Date
    Oct 2008
    Beans
    6

    Re: can't ssh into server unless a user is logged in

    Sheer genius. Thank you so much!

  6. #16
    Join Date
    Jan 2007
    Beans
    18

    Re: can't ssh into server unless a user is logged in

    So what's the verdict? Has anyone successfully gotten this to work? I'd like to have access without ssh keys.

  7. #17
    Join Date
    Jan 2008
    Beans
    31

    Re: can't ssh into server unless a user is logged in

    I believe the following simple solution works.


    Open the 'System Setting' dialog which can be found in the same drop down menu that has 'Log Out...' in it.

    Then choose the 'Network' settings and then 'Wired' and then hit the 'Configure' button. Make sure the 'Avaialable to all users' check box is checked and save it. That works for me.

    Good luck.

  8. #18
    Join Date
    Oct 2011
    Beans
    2

    Re: can't ssh into server unless a user is logged in

    Thanks msrk
    That does indeed work!

  9. #19
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    14,820
    Distro
    Ubuntu 12.04 Precise Pangolin

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •