Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 47

Thread: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

  1. #21
    Join Date
    Nov 2005
    Location
    Scandinavia
    Beans
    939

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    I've got a Vaio CW1 with a 230m, and i cant get it to work. The screen backlight just goes out on me when i try to echo a value to it. I have to switch back and forth between a VT to see something again.
    I have got the latest nvidia_bl from the mactel ppa (0.16.10~lucid), and there is thus no need to add my 230m. I have checked the sources, but the .min value doesn't exist any more so i can't copy what some of you guys suggested verbatim.
    - "though It seems that I know that I know, what I would like to see Is the I that sees me, when I know that I know that I know" / Alan Watts

  2. #22
    Join Date
    Jun 2010
    Beans
    4

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    Thank you Anton and everyone.
    It worked out quite well.

    Vaio CW - 310M

  3. #23
    Join Date
    Jul 2010
    Beans
    2

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    Quote Originally Posted by Anton9121 View Post

    Open /home/xx/nvidia_bl.c and find string 177 and 178
    Code:
        .min           = 50, //6628,   //50,
        .max           = 30000, //138090, //1024,
    and replaced:
    Code:
        
        .min           = 500, //6628,   //50,
        .max           = 80000, //138090, //1024,
    (
    This works on Ubuntu 10.04 (Lucid) with kernel 2.6 (x86x64) using nvidia_bl-0.16.10. Following your tutorial step-by-step and finally adding this code above in nvidia_bl.c it is perfectly functional in my VAIO VPCCW21FX - Geforce 310M.

    Thanks, Anton, my eyes really thanks you!

    ------

    Is how I set brigthness on 40% at startup? because it is starting with 100% and i just want use 100% of brigthness when I'm watching movies.

  4. #24
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    Can you attach your working nvidia_bl.c 0.16.10 ??

    Thanks in advance

    Regards

  5. #25
    Join Date
    Jul 2010
    Beans
    2

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    Quote Originally Posted by nuovodna View Post
    Can you attach your working nvidia_bl.c 0.16.10 ??

    Thanks in advance

    Regards
    I suggest that you follow the step by step tutorial, however, here is my nvidia_bl-0.16.10 folder.
    Attached Files Attached Files

  6. #26
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    This is the 0.52 version. It doesn't work on kernel >= 2.6.34

  7. #27
    Join Date
    Jan 2010
    Location
    Punjab
    Beans
    23

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    Thanks a lot this works for me, atleast for decreasing the brightness, though I can't find the correct settings for me, so when I decrease brightness, I can't it set full by increasing it.

    Anyways I work for ubuntu ooperation clean sweep, I guess if we can soenhow patch this workaround and put it in a patch..

  8. #28
    Join Date
    Feb 2008
    Beans
    3

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    Hi. I have the same problem with a Vaio VPCCW2S1E having a Geforce GT 330m card.

    How do I make this work and how do I find the PCI ID of my card, cause it wasn't in that document?

    I have no idea on what to do, am a completely new ubuntu user, and my eyes are burning very soon!

    I would really appreciate some fast help on this, and an easy guide on how to fix this

    Thanks

  9. #29
    Join Date
    Feb 2008
    Beans
    3

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    Is there no one, who has an easy fix for this?

  10. #30
    Join Date
    Sep 2010
    Beans
    2

    Re: Sony Vaio VPCCW1E1R Brightness control Ubuntu 9.10

    It's work on ubuntu 10.04 but not work on ubuntu 10.10. This output after excute command
    Code:
    sudo dkms add build install -m nvidia_bl -v 0.52
    Output
    Code:
    Creating symlink /var/lib/dkms/nvidia_bl/0.52/source ->
                     /usr/src/nvidia_bl-0.52
    
    DKMS: add Completed.
    
    Kernel preparation unnecessary for this kernel.  Skipping...
    
    Building module:
    cleaning build area....
    make KERNELRELEASE=2.6.35-22-generic-pae -C /lib/modules/2.6.35-22-generic-pae/build SUBDIRS=/var/lib/dkms/nvidia_bl/0.52/build modules.....(bad exit status: 2)
    
    Error! Bad return status for module build on kernel: 2.6.35-22-generic-pae (i686)
    Consult the make.log in the build directory
    /var/lib/dkms/nvidia_bl/0.52/build/ for more information.
    0
    0
    ERROR: binary package for nvidia_bl: 0.52 not found
    Please help me to resolve this problem. Thanks for all!

Page 3 of 5 FirstFirst 12345 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •