Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

  1. #1
    Join Date
    Jun 2009
    Location
    Philippines
    Beans
    11
    Distro
    Ubuntu

    Smile Tutorial on how to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    Smartbro on Ubuntu 9.10

    Device Needed:
    -Smartbro USB modem model: ZTE MF627

    Instructions:

    1. Plug in the usb device. Once it appears on your desktop, right click the smartbro icon and select eject
    2. The light will go out. Wait for a while until it goes back again. At this point, the usb is now switched from card reader to a modem.
    3. Right click network manager and select Edit Connections
    4. Select the Mobile Broadband tab and click the Add button
    5. A window would appear and by default, the ZTE Incorporated ... is selected. Click Forward
    6. Select Philippines as the provider's country and click Forward. A list of providers will be displayed. Choose Smart and click Forward
    7. On the billing plan, click the drop down menu (the one which says Default) and select My Plan is Not Listed. A blank text box will appear.
    Type smartbro as your access point name and click Forward then click Apply

    A new window will appear. There are many textboxes here but you only need to modify a few.

    8. Select the PPP Settings Tab and click the Configure Methods button
    9. Uncheck all methods except PAP. Click Ok. Optionally you may also click Connect Automatically then finally click Apply.
    10. After clicking apply, your modem will attempt to connect. You will notice that the green light from your modem will start to blink and a
    message saying Established Connection or something similar will appear. Open your browser and test if you are now able to browse the web. If
    not, give wait for about 30 sec and retry opening your browser again. If it still fails, remove your usb and repeat steps 1 & 2. Afterward, Left Click the Network Manger then click the smartbro (or something similar) to re establish connection.

    NOTES: On certain occasions, I have established conections but when I try to browse, the browser seems to be offline despite the connection established message from the network manager as well as the modem's blinking light indicating that I am connected. When this happens, what I do is I disconnect the connection (without unplugging the modem), then reconnect. After a few reconnection (usually 2 or 3 times), I would be able to browse by then. As for the credit charges imposed by Smart Philippines, I have observed that no credit was taken during those times that I have established connection but wasn't able to browse

    More Tips:

    -When finished surfing, left click the network manager icon and click disconnect.
    -When reconnecting, repeat step 1 & 2. And if you have checked Connect Automatically from step 8, your modem will automatically connect the moment it switches into modem mode.
    Last edited by lod2; March 5th, 2010 at 06:34 PM. Reason: i have to remove my real name from the post

  2. #2
    Join Date
    Apr 2010
    Beans
    3

    Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    thank you so much , this is a very big help for me, i have been trying to connect my smartbro ZTE MF627, thank you so much, if may ask how dd you figure it out this solution? i used a smart bro prepaid before, it worked fine by just setting apn to SMARTBRO..

  3. #3
    Join Date
    Apr 2005
    Location
    Muntinlupa City
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    Do you have any idea if the Mobile Internet providers in the Philippines change their respective APNs from time to time?

  4. #4
    Join Date
    May 2007
    Location
    Philippines
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    I'm using wicd instead of network-manager. Is there any way to get Smart Bro to work with wicd, or do I need to switch back?

  5. #5
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    Hi lod2


    from your post:


    NOTES: On certain occasions, I have established conections but when I try to browse, the browser seems to be offline despite the connection established message from the network manager as well as the modem's blinking light indicating that I am connected. When this happens, what I do is I disconnect the connection (without unplugging the modem), then reconnect. After a few reconnection (usually 2 or 3 times), I would be able to browse by then. As for the credit charges imposed by Smart Philippines, I have observed that no credit was taken during those times that I have established connection but wasn't able to browse






    Here I have change the IPCP configure-NAKs returned before starting , remove the # and set the number to 30 ( or any thing above the default value till there is a constant connection )

    Code:

    sudo gedit /etc/ppp/options

    # Set the maximum number of IPCP configure-NAKs returned before starting
    # to send configure-Rejects instead to <n> (default 10).
    ipcp-max-failure 30


    tip start at 30 and work down

    use NM IPv4 settings to Automatic (PPP) instead of Setting the NM to IPv4 settings to Automatic (PPP) address only and having to enter the numerical addresses in the DNS servers text box.

    Also

    Code:
    sudo gedit /etc/ppp/options
    Add this line and save:

    replacedefaultroute

    if this is done then replace the # in front of the

    replace the # in front of the " ipcp-max-failure 30 " do not use both methods and see which works best


    regards


    alexfish
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  6. #6
    Join Date
    Feb 2009
    Location
    Philippines
    Beans
    113
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    When I try to connect the first time, the light will turn blue, but then it will disconnect after a few seconds (GSM Network Disconnected).

    I have tried turning off the wifi hardware and restarting as mentioned in this article: http://knightlust.blogspot.com/2009/...tu-jaunty.html , but the same thing happens.

    Any ideas on this?
    Happy GNU/Linux user. Not so noob anymore!
    There are only 10 types of people in the world — those who understand binary, and those who don't.

  7. #7
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    Hi

    can you try this from the terminal and find and change lcp-echo values to 0

    Code:

    sudo gedit /etc/ppp/options

    lcp-echo-failure 0
    lcp-echo-interval 0

    save and exit

    does this help
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  8. #8
    Join Date
    Feb 2009
    Location
    Philippines
    Beans
    113
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    Quote Originally Posted by prvteprts View Post
    When I try to connect the first time, the light will turn blue, but then it will disconnect after a few seconds (GSM Network Disconnected).

    I have tried turning off the wifi hardware and restarting as mentioned in this article: http://knightlust.blogspot.com/2009/...tu-jaunty.html , but the same thing happens.

    Any ideas on this?
    I figured out the problem... it turns out the SIM card I used did not have enough credit lol. I loaded it up, and it connected fine. Now, even though it's out of credit, it still connects but the browser always redirects to m.smart.com.ph .
    Happy GNU/Linux user. Not so noob anymore!
    There are only 10 types of people in the world — those who understand binary, and those who don't.

  9. #9
    Join Date
    Jun 2009
    Location
    Philippines
    Beans
    11
    Distro
    Ubuntu

    Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    if you are using 10.04, check the thread below

    http://ubuntuforums.org/showthread.p...ight=zte+mf627

  10. #10
    Join Date
    May 2010
    Location
    Balite Calumpit Bulacan
    Beans
    11
    Distro
    Ubuntu 10.04 Lucid Lynx

    Thumbs up Re: How to make Smart Bro ZTE MF627 work on Ubuntu 9.10

    Quote Originally Posted by lod2 View Post
    if you are using 10.04, check the thread below

    http://ubuntuforums.org/showthread.p...ight=zte+mf627
    I would bet and curse, but this works for me, and I am in an hsdpa network.

    My wvdial.conf IS THIS, just change your login name and password, and maybe the phone no. if you are not using the SmartBro plus the modem no., ex /dev/ttyUSB0.


    [Dialer Defaults]
    Phone = *99#
    Username = your login name
    Password = your login password
    Stupid Mode = 1
    Dial Command = ATDT


    [Dialer hsdpa]
    Modem = /dev/ttyUSB2
    Baud = 115200
    Init2 = ATZ
    Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    ISDN = 0
    Modem Type = Analog Modem


    Then when you dial, run as a superuser the wvdial hsdpa. But first of all these, do install wvdial and usb-modeswitch using the same modem, note that you will be in GPRS network but wvdial and usb-modeswitch is just a tiny program that installing it will not take that long. Now take the modem into a windows system and switch it back to "3G only" in the Network settings so the light will turn from blue to green, then plug it to your linux and run the command, wvdial hsdpa. Wait a little and then rock on!
    Last edited by Arnold Martin; September 1st, 2010 at 01:38 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •