Results 1 to 6 of 6

Thread: Flash and Pulseaudio problem

  1. #1
    Join Date
    Dec 2009
    Location
    Cedar Rapids, IA
    Beans
    4
    Distro
    Ubuntu 9.10 Karmic Koala

    Flash and Pulseaudio problem

    I am having a problem when using Flash. Whenever I am listening to a Flash application (youtube primarily), I am unable to hear sound from any other applications (Rhythmbox, movie player, etc).

    The converse is also true, if I am using Rhythmbox, and then start youtube, the video plays...but with no sound.

    I have to manually kill the app and web browser (tried multiple...Firefox, Chrome, Swiftfox) to get sounds working correctly. Sometimes, I am forced to reboot to get sounds working in the appropriate app.

    I am my wits end with this problem, and have just putting up with it for several months now. I am pretty new to linux, so any advice would be appreciated.

    Here is the output of aplay -l

    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0

  2. #2
    Join Date
    Sep 2009
    Beans
    401
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Flash and Pulseaudio problem

    Let's run some tests to find out what's wrong. Open a terminal window and enter this command:
    Code:
    aplay -D default -t raw -c 2 -f S32_LE -r 48000 -d 1 -v /dev/zero
    This will play back one second of silence and print the PCM structure of the default ALSA audio device. The output will show whether the default device is configured to use dmix, PulseAudio, or no stream mixer at all. Please post the output here.

    Next, run Firefox and launch a YouTube video. While the video is playing (with sound), enter the following command into the terminal window:
    Code:
    lsof | grep dsp
    The output will tell us whether Flash uses ALSA or OSS. Post the output here, too.

  3. #3
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,459
    Distro
    Ubuntu Development Release

    Re: Flash and Pulseaudio problem

    Quote Originally Posted by martinezlc99 View Post
    I am having a problem when using Flash. Whenever I am listening to a Flash application (youtube primarily), I am unable to hear sound from any other applications (Rhythmbox, movie player, etc).

    The converse is also true, if I am using Rhythmbox, and then start youtube, the video plays...but with no sound.

    I have to manually kill the app and web browser (tried multiple...Firefox, Chrome, Swiftfox) to get sounds working correctly. Sometimes, I am forced to reboot to get sounds working in the appropriate app.

    I am my wits end with this problem, and have just putting up with it for several months now. I am pretty new to linux, so any advice would be appreciated.

    Here is the output of aplay -l

    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    Do what VertxPusher says and he will fix it for you. Stay away from other fixes.
    It will tell him what you are using so he can give you a fix.
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:
    http://www.ubuntupocketguide.com/index_main.html
    Main Page -

  4. #4
    Join Date
    Dec 2009
    Location
    Cedar Rapids, IA
    Beans
    4
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Flash and Pulseaudio problem

    Quote Originally Posted by VertexPusher View Post
    Let's run some tests to find out what's wrong. Open a terminal window and enter this command:
    Code:
    aplay -D default -t raw -c 2 -f S32_LE -r 48000 -d 1 -v /dev/zero
    This will play back one second of silence and print the PCM structure of the default ALSA audio device. The output will show whether the default device is configured to use dmix, PulseAudio, or no stream mixer at all. Please post the output here.

    Next, run Firefox and launch a YouTube video. While the video is playing (with sound), enter the following command into the terminal window:
    Code:
    lsof | grep dsp
    The output will tell us whether Flash uses ALSA or OSS. Post the output here, too.
    Thanks for the reply!

    Output of aplay -D default -t raw -c 2 -f S32_LE -r 48000 -d 1 -v /dev/zero is

    Code:
    Playing raw data '/dev/zero' : Signed 32 bit Little Endian, Rate 48000 Hz, Stereo
    Plug PCM: Soft volume PCM
    Control: PCM Playback Volume
    min_dB: -51
    max_dB: 0
    resolution: 256
    Its setup is:
      stream       : PLAYBACK
      access       : RW_INTERLEAVED
      format       : S32_LE
      subformat    : STD
      channels     : 2
      rate         : 48000
      exact rate   : 48000 (48000/1)
      msbits       : 32
      buffer_size  : 8192
      period_size  : 1024
      period_time  : 21333
      tstamp_mode  : NONE
      period_step  : 1
      avail_min    : 1024
      period_event : 0
      start_threshold  : 8192
      stop_threshold   : 8192
      silence_threshold: 0
      silence_size : 0
      boundary     : 4611686018427387904
    Slave: Direct Stream Mixing PCM
    Its setup is:
      stream       : PLAYBACK
      access       : MMAP_INTERLEAVED
      format       : S32_LE
      subformat    : STD
      channels     : 2
      rate         : 48000
      exact rate   : 48000 (48000/1)
      msbits       : 32
      buffer_size  : 8192
      period_size  : 1024
      period_time  : 21333
      tstamp_mode  : NONE
      period_step  : 1
      avail_min    : 1024
      period_event : 0
      start_threshold  : 8192
      stop_threshold   : 8192
      silence_threshold: 0
      silence_size : 0
      boundary     : 4611686018427387904
    Hardware PCM card 0 'HDA Intel' device 0 subdevice 0
    Its setup is:
      stream       : PLAYBACK
      access       : MMAP_INTERLEAVED
      format       : S32_LE
      subformat    : STD
      channels     : 2
      rate         : 48000
      exact rate   : 48000 (48000/1)
      msbits       : 32
      buffer_size  : 8192
      period_size  : 1024
      period_time  : 21333
      tstamp_mode  : ENABLE
      period_step  : 1
      avail_min    : 1024
      period_event : 0
      start_threshold  : 1
      stop_threshold   : 0
      silence_threshold: 0
      silence_size : 0
      boundary     : 4611686018427387904
      appl_ptr     : 0
      hw_ptr       : 8784309280
    Output of lsof | grep dsp is

    Code:
    pulseaudi  2152 martinezlc99  mem       REG                8,6     81496       5054 /usr/lib/libspeexdsp.so.1.5.0
    gconf-hel  2226 martinezlc99  mem       REG                8,6     81496       5054 /usr/lib/libspeexdsp.so.1.5.0
    Thanks for any help!

  5. #5
    Join Date
    Dec 2009
    Location
    Cedar Rapids, IA
    Beans
    4
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Flash and Pulseaudio problem

    Solved this problem by following the advice here: http://ubuntuforums.org/showthread.php?t=1412153

    Edited my /etc/asound.conf to include (it was blank):

    Code:
    pcm.pulse {
        type pulse
    }
    ctl.pulse {
        type pulse
    }
    pcm.!default {
        type pulse
    }
    ctl.!default {
        type pulse
    }
    No clue why this worked, but it did and I am happy.

  6. #6
    Join Date
    Sep 2009
    Beans
    401
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Flash and Pulseaudio problem

    Your default device was configured to use dmix despite the fact that PulseAudio was installed and running. PulseAudio occupies the hardware audio device so that dmix can't access it. That's why the audio applications blocked each other.

    The pulseaudio package comes with two files, /usr/share/alsa/pulse-alsa.conf and /usr/share/alsa/pulse.conf, which configure the pulse plugin. ALSA's main configuration file, /usr/share/alsa/alsa.conf, automatically links to those files if they are present.

    The conclusion is that either those two files are missing, or the link was removed from alsa.conf. Either way, your system is not in "factory default state". Adding /etc/asound.conf is a possible workaround, but the more elegant way would be to reinstall the packages libasound2 and pulseaudio to bring the original configuration files back.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •