Results 1 to 5 of 5

Thread: Epson printer argh!

  1. #1
    Join Date
    Oct 2009
    Location
    Niagara Falls Canada
    Beans
    129
    Distro
    Ubuntu 10.04 Lucid Lynx

    Epson printer argh!

    I've been trying to get my new Epson NX215 working for about three weeks now, and I'm ready to smash the thing.
    I got the scanner working using Image Scan!, but cannot get it to print anything. All it does is spit out blank pages till it is out of paper.
    I have downloaded the driver and have both Gutenprint and Cups.
    I can get it to print when using the printer in my windows virtual machine, but would prefer to not have to start up vmware every time I want to print something.
    I'm pretty sure this is a driver or postscript issue as I have used other printers, even an epson, with this exact same machine.
    Any ideas?

  2. #2
    Join Date
    Oct 2007
    Beans
    1,792

  3. #3
    Join Date
    Oct 2009
    Location
    Niagara Falls Canada
    Beans
    129
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Epson printer argh!

    Worked like charm, thanks a lot for pointing me in the right direction.
    one more question, should I use the generic eklite.ppd or the device specific ppd that was downloaded from avasys. I am sure I could just try them both but I am a lazy man.
    THANKS SO MUCH FOR YOUR HELP, AND ALL THE HELP FROM THIS FORUM.

  4. #4
    Join Date
    May 2007
    Beans
    12,759

    Re: Epson printer argh!

    Given the ease with which you can change PPDs (just reconfigure using CUPS and select a different PPD file), I would suggest you try each one.

    I have an Epson printer attached and tried several different PPDs until I settled on the latest one provided by CUPS as the one with the best set of features.
    Ubuntu 14.04, Mint 17; MS Win 8.1.
    Will not respond to PM requests for support -- use the forums.

  5. #5
    Join Date
    Mar 2010
    Beans
    1

    Re: Epson printer argh!

    I have had a similar problem with Epson NX215 and was able to resolve it by downloading the deb package from the website specified above Avasys(?) website.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •