Results 1 to 8 of 8

Thread: Alt + F2 dialog package

  1. #1
    Join Date
    Aug 2008
    Beans
    4

    Alt + F2 dialog package

    Which package is the Alt + F2 run dialog in? I have GNOME on Gentoo and the key combination doesn't work...using gnome-do in its place.

  2. #2
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Alt + F2 dialog package

    Quote Originally Posted by silent_n0va View Post
    Which package is the Alt + F2 run dialog in? I have GNOME on Gentoo and the key combination doesn't work...using gnome-do in its place.
    It's a feature provided by the gnome-panel. (I have no idea what's the actual package that includes the panel, though).

  3. #3
    Join Date
    Oct 2009
    Beans
    29

    Re: Alt + F2 dialog package

    It's a feature provided by the gnome-panel. (I have no idea what's the actual package that includes the panel, though).
    I'm quite sure that it's metacity. I'm running openbox with gnome-panel and I don't have ALT+F2

  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Alt + F2 dialog package

    Quote Originally Posted by zlatkart View Post
    I'm quite sure that it's metacity. I'm running openbox with gnome-panel and I don't have ALT+F2
    no, it definitely is Gnome-panel. If you replace Metacity in Gnome with anything else (for example with Compiz, like so many Ubuntu user's do) the Run dialog still works, but if you kill the panel the dialog stops working.

    The dialog used to be a separate program, started by running "gnome-run", but it was integrated into gnome-panel in Gnome 2.6.

    If the shortcut isn't working for you you are probably missing the Gnome component that handles keyboard shortcuts, or the relevant gconf key isn't set or something.

    edit: This will probably help you: http://openbox.org/wiki/Help:GNOME/Openbox
    Code:
    <keybind key="A-F2">
        <action name="execute"><execute>gnome-panel-control --run-dialog</execute></action>
    </keybind>
    Last edited by mcduck; February 25th, 2010 at 10:59 PM.

  5. #5
    Join Date
    Oct 2009
    Beans
    29

    Re: Alt + F2 dialog package

    Cool
    Thank you. But strange as I think that killing Metacity always killed ALT+F2 (as far as I remeber). Anyway...

  6. #6
    Join Date
    Aug 2008
    Beans
    4

    Re: Alt + F2 dialog package

    I have Metacity and gnome-panel both on Gentoo, though it's running Compiz currently. Strange that the run dialog wouldn't work with Compiz as it works brilliantly in Ubuntu, but I will check on my key bindings tonight.

  7. #7
    Join Date
    Mar 2008
    Location
    Birmingham, UK
    Beans
    Hidden!

    Re: Alt + F2 dialog package

    If Compiz is running, I believe there is a "Gnome Compatibility" plugin (or similar) which must be enabled to allow Alt+F2 and some other bits to work again. Having said that, if it wasn't working before Compiz was enabled, this may not be the case.
    Desktop: Phenom 955 BE | GA-MA790XT-UD4P | 8GB TG Elite 1600 | BFG GTX 275
    Conky Screenshots | Last.fm | New to Ubuntu?

  8. #8
    Join Date
    Aug 2008
    Beans
    4

    Re: Alt + F2 dialog package

    Gnome compatibility was turned off. Turned it on and now the dialog runs. ^_^

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •