Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Asus EEE PC 1005PE Brightness keys change dimming randomly

  1. #21
    Join Date
    Jun 2010
    Beans
    3

    Re: Asus EEE PC 1005PE Brightness keys change dimming randomly

    Quote Originally Posted by dpwegener@gmail.com View Post
    After making this change, the brightness still wasn't completely consistent and there was never a popup showing the brightness level on the screen. Adding "acpi_backlight=vendor" to grub solved the problem completely. Now, the brightness changes as expected and you see the brightness level popup.

    My GRUB_CMDLINE_LINUX_DEFAULT line now looks like this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor splash"
    Great,Solve my problem too. Thanks

  2. #22
    Join Date
    Jun 2006
    Location
    St Vincent (Caribbean)
    Beans
    33
    Distro
    Ubuntu Development Release

    Re: Asus EEE PC 1005PE Brightness keys change dimming randomly

    Quote Originally Posted by dpwegener@gmail.com View Post
    After making this change, the brightness still wasn't completely consistent and there was never a popup showing the brightness level on the screen. Adding "acpi_backlight=vendor" to grub solved the problem completely. Now, the brightness changes as expected and you see the brightness level popup.

    My GRUB_CMDLINE_LINUX_DEFAULT line now looks like this:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor splash"
    Has anyone found a way to add this permanently to grub rather than adding every time the notebook starts
    ?

  3. #23
    Join Date
    Jun 2009
    Location
    Earth
    Beans
    57
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Asus EEE PC 1005PE Brightness keys change dimming randomly

    I'm curious to know if anyone else tried upgrading the BIOS to fix this problem. (See my previous post.)

    It's possible that this will only work with 10.04. I haven't had any problems out of 10.04, so I can recommend both upgrades, especially together.

  4. #24
    Join Date
    Sep 2005
    Location
    Vermont
    Beans
    94
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Asus EEE PC 1005PE Brightness keys change dimming randomly

    Quote Originally Posted by drkages View Post
    Has anyone found a way to add this permanently to grub rather than adding every time the notebook starts
    ?
    Add it to /etc/default/grub, then "update-grub".

  5. #25
    Join Date
    Nov 2010
    Beans
    1

    Re: Asus EEE PC 1005PE Brightness keys change dimming randomly

    Quote Originally Posted by finnk View Post
    this will make the brightness keys work:
    sudo gedit /etc/default/grub

    Find the line GRUB_CMDLINE_LINUX_DEFAULT and add "acpi_osi=Linux" so it looks like this GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux". Save the file. Now run update-grub2.

    sudo update-grub2

    But gnome power manager still randomly changes the backlight. I disabled it from startup, and start it from the command line when i want to suspend on closing the lid.

    Thank you

  6. #26
    Join Date
    Jan 2011
    Beans
    1

    Re: Asus EEE PC 1005PE Brightness keys change dimming randomly

    Quote Originally Posted by fbicknel View Post
    I'm curious to know if anyone else tried upgrading the BIOS to fix this problem. (See my previous post.)

    It's possible that this will only work with 10.04. I haven't had any problems out of 10.04, so I can recommend both upgrades, especially together.
    Hi everyone! I'ne got 900AX, and the same problem
    I tryed both BIOS upgrade and grub configuration - none work for me(

  7. #27
    Join Date
    Jan 2011
    Location
    Manila, Philippines
    Beans
    8
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Asus EEE PC 1005PE Brightness keys change dimming randomly

    Hello finnk

    I am new and an novice in Linux/Ubuntu, having just migrated my desktop & 2 laptops from Win OS; having done so made me experience some difficult (for me) issues and one of that is this BRIGHTNESS thing.

    Thank you very much for your excellent solution!

    I'm starting to believe that Linux-people are geniuses - for how else can an ordinary mortal figure this things out?

    May your tribe multiply!

    regards from Manila,
    egay

    .e.

    PS: I am going to post this solution in my BLOG at http;//ezdapiton.wordpress.com/


    Quote Originally Posted by finnk View Post
    this will make the brightness keys work:
    sudo gedit /etc/default/grub

    Find the line GRUB_CMDLINE_LINUX_DEFAULT and add "acpi_osi=Linux" so it looks like this GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux". Save the file. Now run update-grub2.

    sudo update-grub2

    But gnome power manager still randomly changes the backlight. I disabled it from startup, and start it from the command line when i want to suspend on closing the lid.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •