Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: How to control DPI in Ubuntu, not working

  1. #1
    Join Date
    Feb 2010
    Beans
    20

    How to control DPI in Ubuntu, not working

    Hi all

    Searched the forum and google for a few days trying out various options, nothing working so far. Let's see if anyone here has a tip for me

    I'm running Ubuntu Netbook Remix 9.10 (latest) on Compaq Mini 702EA (1024x600). The text is very small in Firefox and the rest of the desktop due to the high DPI of the display panel (118dpi).

    Therefore I would like to increase the DPI setting, so that text,icons, web pages are rendered larger.

    I found this page covering a lot of ideas, none of which work for Ubuntu or firefox
    http://www.mozilla.org/unix/dpi.html

    In X the way to increase the DPI seems to be to configure a smaller display resolution in mm than is actually the case. However, this does not work either

    Section "Monitor"
    Identifier "Configured Monitor"
    DisplaySize 163 95 # 160dpi
    EndSection

    I did find a control in Ubuntu to make the Remix desktop larger.. however, now writing this I cannot find where it was. Anyone remember?

    The only other workaround is to configure Firefox's font size for each charset, Western etc to have a larger min size. This means text is larger, but images are still small, and so pages don't look quite right. Firefox does not allow configuration of the "zoom" at a fixed amount, 130% would probably be enough.

    Firefox layout.css.dpi seems mostly broken, it only changes anything if going beyond 192, after which the text is then too large!

    Any ideas?

  2. #2
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to control DPI in Ubuntu, not working

    System/Preferences/Appearance, Fonts-tab, click the Details-button.

    Seting the DPI in xorg.conf should work justa s well, but you really need to post the whole file here if you want help with that.
    Last edited by mcduck; February 21st, 2010 at 03:19 PM.

  3. #3
    Join Date
    Feb 2010
    Beans
    20

    Re: How to control DPI in Ubuntu, not working

    Quote Originally Posted by mcduck View Post
    System/Preferences/Appearance, Fonts-tab, click the Details-button.

    Seting the DPI in xorg.conf should work justa s well, but you really need to post the whole file here if you want help with that.
    Thanks for the tip.

    OK, Xorg.0.log: http://www.pastebin.com/f61d2b406

    /etc/X11/xorg.conf: http://www.pastebin.com/m5dcc970c

    Thanks for taking a look

  4. #4
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to control DPI in Ubuntu, not working

    xorg.conf looks OK to me. Try adding the resolution there as well, that might dom the trick.

    You could also set DPI directly, isnetad of setting the display dimensions, if you only plan to use one resolution. (not that using different than the display's native resolution woiuld make much sense with LCD screen anyway...)

    Code:
    Section "Monitor"
             Identifier      "Configured Monitor"
             Modes "1024x600"       
             Option   "DPI" "118 x 118"
    EndSection

    ..also, the NoDDC line in the device section should be like this:
    Code:
    Option   "NoDDC" "true"
    (you are now missing the "true" -part of the setting)

  5. #5
    Join Date
    Feb 2010
    Beans
    20

    Re: How to control DPI in Ubuntu, not working

    Quote Originally Posted by mcduck View Post
    xorg.conf looks OK to me. Try adding the resolution there as well, that might dom the trick.

    You could also set DPI directly, isnetad of setting the display dimensions, if you only plan to use one resolution. (not that using different than the display's native resolution woiuld make much sense with LCD screen anyway...)

    Code:
    Section "Monitor"
             Identifier      "Configured Monitor"
             Modes "1024x600"       
             Option   "DPI" "118 x 118"
    EndSection
    ..also, the NoDDC line in the device section should be like this:
    Code:
    Option   "NoDDC" "true"
    (you are now missing the "true" -part of the setting)
    Hi, thanks for this tip.

    I tried with all the changes including NoDDC correction, but I get a swiffy display (like TV with interference), commenting out the NoDDC change and restarting gets it working again, however xdpyinfo|grep res still shows 117x117 dpi

    is NoDDC needed to control DPI?

    I've set System/Preferences/Appearance, Fonts-tab, Details to be 160dpi. Not sure why X is not using this for Firefox tho. Or why Firefox is not using the Appearance value directly like other Gnome apps.

    I noticed this in the new Xorg.0.log file:

    (==) intel(0): DPI set to (96, 96)
    (WW) intel(0): Option "DPI" is not used

    Cheers, richy

  6. #6
    Join Date
    Feb 2010
    Beans
    20

    Re: How to control DPI in Ubuntu, not working

    BTW, there is a big security issue in ubuntu.. i can just select "Recovery" -> "Root console" without it ever asking me for the root password!! Is this a known potential prob?

  7. #7
    Join Date
    Feb 2010
    Beans
    20

    Re: How to control DPI in Ubuntu, not working

    I realised that Modes "1024x600" should be in Section "Screen"

    Still not working tho..

    Could Option "IgnoreEDID" "true" help?

    maybe also:
    Option "UseEDID" "False"

  8. #8
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to control DPI in Ubuntu, not working

    The "noDDC" option isn't usually necessary, but some people are suffering from a bug that requires that entry to e able to set the DPI. Since adding that setting didn't help you you should be able to safely leave that option out. Actually things should work better without such option.

    You could indeed try enabling/disabling EDID.

    Firefox probably doesn't follow the Gnome setting because it's not actually a GTK application, even though Mozilla makes it look like one. It uses it's own toolkit (XUL) for the user interface, and that doesn't always work exactly as you'd expect it to...

    ..and no, the recovery mode thing is not a bug. It's a designed feature, since physical access to a computer should always be considered as root access. With physical access to a machine anybody will be able to access all your data in a way or other anyway (be it booting with a live-CD, or removing your hard drives to read them on another machine, or something else) so being able to use the recovery mode doesn't make much of a difference security-wise. On the other hand it makes recovering from many problems considerably easier. If you want to, you can set a Grub password to restrict access to recovery mode, but if anybody gets unrestricted access to your computer you have already lost the game... (the only way to protect your data if your computer gets in wrong hands is to encrypt the data.)
    Last edited by mcduck; February 21st, 2010 at 10:59 PM.

  9. #9
    Join Date
    Feb 2010
    Beans
    20

    Re: How to control DPI in Ubuntu, not working

    Quote Originally Posted by mcduck View Post
    xorg.conf looks OK to me. Try adding the resolution there as well, that might dom the trick.
    I tried two other ideas, not successful tho:

    1)
    /usr/bin/startx defaultserverargs

    Someone suggested changing ubuntu default from -dpi 75 to this:

    defaultserverargs="-dpi 120 -ac -nolisten tcp"

    2)
    /etc/X11/xinit/xserverrc contains this line

    "exec /usr/bin/X11/X -dpi 78 -nolisten tcp"

    i changed to 146, but no difference after reboot.

    So I'm still stuck.. DPI is 117x117 according to xdpyinfo

  10. #10
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to control DPI in Ubuntu, not working

    Quote Originally Posted by richy2010 View Post
    I tried two other ideas, not successful tho:

    1)
    /usr/bin/startx defaultserverargs

    Someone suggested changing ubuntu default from -dpi 75 to this:

    defaultserverargs="-dpi 120 -ac -nolisten tcp"

    2)
    /etc/X11/xinit/xserverrc contains this line

    "exec /usr/bin/X11/X -dpi 78 -nolisten tcp"

    i changed to 146, but no difference after reboot.

    So I'm still stuck.. DPI is 117x117 according to xdpyinfo
    You seem to be trying different DPI value for everything? Perhaps it would help to use the same value in every polace where you try to set it, since there really is only one correct DPI for certain screen size & resolution...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •