Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 32

Thread: Oops!

  1. #21
    Join Date
    Oct 2008
    Beans
    255
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Oops!

    Oops! sorry about that misunderstanding

    no idea why its not working. Does this happen even when you login as some other user? and do all other plugins work all right?
    The answer to life, the universe and everything...
    vim -c help42

  2. #22
    Join Date
    Oct 2008
    Beans
    255
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Oops!

    Also try starting rhytmbox like this from the terminal:
    Code:
    rhythmbox -d
    It starts the player in debug mode, and now, see if you get any error output etc. when you fiddle with the plugin.
    The answer to life, the universe and everything...
    vim -c help42

  3. #23
    Join Date
    Nov 2009
    Beans
    99
    Distro
    Ubuntu 12.04 Precise Pangolin

    Smile Re: Oops!

    Quote Originally Posted by n0dix View Post
    ahh,???

    Btw, the world doesn't end with RhythmBox, you can install other programs like Exaile, Banshee, Amarok, Songbird, etc.
    I don't know what the
    ahh,???
    means, but...yeah, I know Rhythmbox isn't the end, it's just that I'm not particularly a fan of installing multiple programs that do the exact same thing, and for me, pretty much all media library programs are alike. Exaile and Banshee I'm considering because I've heard the integrate well with AWN. Songbird I've tried, but the skin I wanted (and basically the only reason I tried it) didn't work. And Amarok? Eh, I'll stick with just GNOME libs until I start trying to install KDE 3.5 for Baghira alongside. If worst comes to worst, though, I would consider others, though if I can't get this working. And it's not that the program doesn't work; it indexes and plays my music wonderfully, it's that one stubborn plugin! Well, I'll come up with something....

  4. #24
    Join Date
    Nov 2009
    Beans
    99
    Distro
    Ubuntu 12.04 Precise Pangolin

    Red face Re: Oops!

    Quote Originally Posted by raktarok View Post
    Also try starting rhytmbox like this from the terminal:
    Code:
    rhythmbox -d
    It starts the player in debug mode, and now, see if you get any error output etc. when you fiddle with the plugin.
    Here's the scoop:
    Code:
    (19:42:14) [0x2193500] [rb_python_module_init] rb-python-module.c:395: Init of python module
    (19:42:14) [0x2193500] [rb_python_object_get_type] rb-python-plugin.c:269: Registering python plugin instance: ArtDisplayPlugin+RBPythonPlugin
    
    (rhythmbox:18549): GLib-GObject-WARNING **: Two different plugins tried to register 'ArtDisplayPlugin+RBPythonPlugin'.
    
    (rhythmbox:18549): Rhythmbox-CRITICAL **: rb_plugin_activate: assertion `RB_IS_PLUGIN (plugin)' failed
    (19:42:27) [0x2193500] [rb_shell_window_configure_cb] rb-shell.c:1635: storing window size of 1001:677
    (19:42:27) [0x2193500] [rb_shell_window_configure_cb] rb-shell.c:1647: storing window position of 715:110
    
    (rhythmbox:18549): Rhythmbox-CRITICAL **: rb_plugin_deactivate: assertion `RB_IS_PLUGIN (plugin)' failed
    Other than where it says failed, I don't know what it means... A little more help, Doc?

    EDIT: By the way, this is the part where I click activate the plugin and deactivate it. Yes, I have had it activated before and it still didn't work--I'm not that stupid. Anyway, like I said, this is just the part where I select the check box, then deselect it.
    Last edited by clicker4721; February 26th, 2010 at 02:47 AM. Reason: Needed to add something...Duh...

  5. #25
    Join Date
    Oct 2008
    Beans
    255
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Oops!

    Quote Originally Posted by clicker4721 View Post

    (rhythmbox:18549): GLib-GObject-WARNING **: Two different plugins tried to register 'ArtDisplayPlugin+RBPythonPlugin'.
    This may be the problem. Maybe you have a copy of the plugin in the rhythmbox config directory? Please check the directory .gnome2/rhythmbox in your home folder, and see if there are any plugins inside it. Delete them if there are.

    If this does not help, try disabling all other plugins, and see if it works when it is the only one enabled. You can also try deleting all other plugin folders from /usr/lib/rhythmbox/plugins directory, and see if it works now..

    Also try deleting the whole rhythmbox directory in .gnome2...
    Last edited by raktarok; February 26th, 2010 at 02:56 AM.
    The answer to life, the universe and everything...
    vim -c help42

  6. #26
    Join Date
    Nov 2009
    Beans
    99
    Distro
    Ubuntu 12.04 Precise Pangolin

    Arrow Re: Oops!

    Quote Originally Posted by raktarok View Post
    This may be the problem. Maybe you have a copy of the plugin in the rhythmbox config directory? Please check the directory .gnome2/rhythmbox in your home folder, and see if there are any plugins inside it. Delete them if there are.

    If this does not help, try disabling all other plugins, and see if it works when it is the only one enabled. You can also try deleting all other plugin folders from /usr/lib/rhythmbox/plugins directory, and see if it works now..

    Also try deleting the whole rhythmbox directory in .gnome2...
    Alright! The plugin itself works, and it will display cover art. Unfortunately, it will not fetch it; which, I know, can be overcome with a simple drag-and-drop but getting the cover is an inconvenience. Regardless, it works fine--apparently, whenever I extracted Carlee's tarball, I hit merge, and the Linux file system allows duplicates, so I had two of almost every script in the lib directory. In contrast, I use AWN, and am trying to implement the AWN Rhythmbox Cover Art plugin alongside the Cover Art Display plugin. The same error occurs whenever I try to use it with the Cover Art Display plugin...Remediable?

    EDIT: With some more piddling, got Cover Art plugin working correctly, i.e. fetching works.
    Last edited by clicker4721; February 27th, 2010 at 02:26 AM. Reason: Update

  7. #27
    Join Date
    Nov 2009
    Beans
    99
    Distro
    Ubuntu 12.04 Precise Pangolin

    Post Re: Oops!

    I think the key to my problem is in this error readout:
    Code:
    (19:38:36) [0x18e8500] [rb_python_module_init] rb-python-module.c:395: Init of python module
    (19:38:36) [0x18e8500] [rb_python_object_get_type] rb-python-plugin.c:269: Registering python plugin instance: ArtDisplayPlugin+RBPythonPlugin
    
    (rhythmbox:12684): GLib-GObject-WARNING **: Two different plugins tried to register 'ArtDisplayPlugin+RBPythonPlugin'.
    
    (rhythmbox:12684): Rhythmbox-CRITICAL **: rb_plugin_activate: assertion `RB_IS_PLUGIN (plugin)' failed
    
    (rhythmbox:12684): Rhythmbox-CRITICAL **: rb_plugin_deactivate: assertion `RB_IS_PLUGIN (plugin)' failed
    This has to be more specific than I'm giving it credit for. Apparently, both cover art viewers are registering the same something...I've tried deleting scripts from one directory and seeing if the other plugin still works--no good. Please help, I'm almost through.

  8. #28
    Join Date
    Oct 2008
    Beans
    255
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Oops!

    Did you use the plugin from this page?
    http://wiki.awn-project.org/Plugins:Rhythmbox

    The screenshots there show the plugin working with the latest design of awn. Which version of awn are you using? are you using the one found in the repos, or in ppa? Try updating awn by adding this line to your sources, if you have not done so.

    Code:
    deb http://ppa.launchpad.net/awn-testing/ppa/ubuntu karmic main
    You are using karmic, right? and now install the latest awn:

    Code:
    sudo apt-get install avant-window-navigator-trunk
    I am using the old, stable awn and I tried using the awn rhythmbox plugin from the above webpage. I am also getting the same error as you. I tried fiddling with the plugin files, but I have had no luck so far.

    And I also noticed that the cover art plugin is not fetching covers for me, how did you solve that? I would like to learn that too..

    Hope we solve this soon!
    The answer to life, the universe and everything...
    vim -c help42

  9. #29
    Join Date
    Nov 2009
    Beans
    99
    Distro
    Ubuntu 12.04 Precise Pangolin

    Lightbulb Re: Oops!

    Quote Originally Posted by raktarok View Post
    Did you use the plugin from this page?
    http://wiki.awn-project.org/Plugins:Rhythmbox

    The screenshots there show the plugin working with the latest design of awn. Which version of awn are you using? are you using the one found in the repos, or in ppa? Try updating awn by adding this line to your sources, if you have not done so.

    Code:
    deb http://ppa.launchpad.net/awn-testing/ppa/ubuntu karmic main
    You are using karmic, right? and now install the latest awn:

    Code:
    sudo apt-get install avant-window-navigator-trunk
    I am using the old, stable awn and I tried using the awn rhythmbox plugin from the above webpage. I am also getting the same error as you. I tried fiddling with the plugin files, but I have had no luck so far.

    And I also noticed that the cover art plugin is not fetching covers for me, how did you solve that? I would like to learn that too..

    Hope we solve this soon!
    1. Yes, that's where I download my plugin.
    2. No, I'm using Jaunty because it is so much more customizable then Karmic; for me, personal is the name of the game.
    3. I too, tried tweaking them, and only did so well.
    4. The cover art problem is strange; I'm not real sure what I did. I did a bunch of screw-up, and then a reinstall fixed it. Go figure.

  10. #30
    Join Date
    Nov 2009
    Beans
    99
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Re: Oops!

    Uhh...hello?
    ~A-Con

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •