Results 1 to 4 of 4

Thread: Using Mixxx with more than two channels

  1. #1
    Join Date
    Jun 2007
    Location
    USA
    Beans
    291
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Using Mixxx with more than two channels

    I'm using a Macbook 2,1 with an Ubuntu variant called Crunchbang, which uses straight ALSA without pulse, for what it's worth.

    I bought a Berhinger UCA202 usb audio interface in order to preview tracks to beat match. The card was recognized and works automagically, but I have a snag when I try and set up the channels. If I use channels 1-2 for the output of the UCA202 to the speakers and then use channels 3-4 for the internal sound card to my headphones, I get terrible audio quality with lots of pops, skipping, and the program becomes unstable.

    However, if I use channels 1-2 for both, the problem goes away immediately, but it becomes more difficult to cue the tracks because I'm listening to the full mix through my headphones.

    Does this have anything to do with latency? Or the limitations of my internal sound card?

    Any help would be greatly appreciated.

    -Rog
    Macbook 2,1 2.16 Core 2 Duo / 2Gb Ram / 120Gb HDD: Ubuntu Studio 9.04 64 Bit/ Mac OS X 10.4.11

    Registered Linux User # 449355 / Registered Ubuntu User # 16921

  2. #2
    Join Date
    Jan 2009
    Location
    The Netherlands
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Using Mixxx with more than two channels

    Hello Rog-Mahal, did you try different samplerates? And what are your current Mixxx settings? And which version of Mixxx are you using?

  3. #3
    Join Date
    Jun 2007
    Location
    USA
    Beans
    291
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Using Mixxx with more than two channels

    I'm using Mixxx 1.6.1, which is the version in the Ubuntu repos. No luck with different samplerates, the usb sound card that I'm using only supports 44.1kHz and 48kHz and switching between them makes no difference.

    Thanks for the reply.
    Macbook 2,1 2.16 Core 2 Duo / 2Gb Ram / 120Gb HDD: Ubuntu Studio 9.04 64 Bit/ Mac OS X 10.4.11

    Registered Linux User # 449355 / Registered Ubuntu User # 16921

  4. #4
    Join Date
    Jan 2007
    Beans
    8

    Re: Using Mixxx with more than two channels

    Hi Rog-Mahal,

    Could you please try out the Mixxx 1.8.0 beta? It's available from our website, http://mixxx.org

    If the same problem with multiple soundcards persists, try increasing your latency in the preferences dialog. Some soundcards, especially internal ones, cannot handle low latency. If you are still having problems please file a bug in our tracker http://bugs.launchpad.net/mixxx

    Thanks,
    RJ Ryan

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •