Results 1 to 9 of 9

Thread: Connects to router, dsl modem, but no internet

  1. #1
    Join Date
    Dec 2008
    Beans
    33
    Distro
    Ubuntu 11.04 Natty Narwhal

    Connects to router, dsl modem, but no internet

    I recently installed Ubuntu Netbook Remix 9.10 on a Dell Inspiron Mini. I'm having trouble getting any sort of networking working on the system, however. I can access my router and DSL modem through ethernet, however, when I try to access a website it times out very quickly in Firefox.

    Also, I'm having trouble getting the Wireless to activate as well. It wants me to use the proprietary Broadcom drivers, except when I enter my password and click authenticate it doesn't actually turn them on, it just puts me back at the Hardware Drivers screen, without actually activating the drivers.

  2. #2
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Connects to router, dsl modem, but no internet

    What are results of route -n and contents of /etc/resolv.conf?
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  3. #3
    Join Date
    Dec 2008
    Beans
    33
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Connects to router, dsl modem, but no internet

    Quote Originally Posted by Iowan View Post
    What are results of route -n and contents of /etc/resolv.conf?
    route -n:
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168,1.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0
    169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0

    /etc/resolv.conf:
    namserver 192.168.1.1

  4. #4
    Join Date
    Dec 2008
    Beans
    33
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Connects to router, dsl modem, but no internet

    I'm sorry that I do not know how to make that look better.

  5. #5
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Connects to router, dsl modem, but no internet

    That looks fine...
    Can you ping internet by IP address (74.125.95.103)? by name (google.com)?
    I presume 192.168.1.1 is the router - You can reach (ping) the modem through the router?
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  6. #6
    Join Date
    Dec 2008
    Beans
    33
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Connects to router, dsl modem, but no internet

    Quote Originally Posted by Iowan View Post
    That looks fine...
    Can you ping internet by IP address (74.125.95.103)? by name (google.com)?
    I presume 192.168.1.1 is the router - You can reach (ping) the modem through the router?
    I can indeed ping the modem, google.com, as well as the IP address.

  7. #7
    Join Date
    Dec 2008
    Beans
    33
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Connects to router, dsl modem, but no internet

    I believe the wireless chip being used is the BCM 4322 (PCI-ID 0x432B) and according to linuxwireless.org is unsupported. Bummer.

    As for the wired being able to ping everything but not load any websites through the browser, that is indeed still a mystery.

  8. #8
    Join Date
    Dec 2008
    Beans
    33
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Connects to router, dsl modem, but no internet

    I've managed to get everything limping along. Ethernet is working like a charm, pulling down as fast as the DSL can dish it. The wireless on the other hand is performing sub-par. After removing and reinstalling b43-fwcutter several times through Synaptic, it seems to be working, though downloads are excruciatingly slow, being measured in the thousands of bytes/s.

  9. #9
    Join Date
    Jul 2011
    Beans
    1

    Re: Connects to router, dsl modem, but no internet

    I have an ASUS EEE PC 1005. I installed Ubuntu Netbook Remix 10.04 in it(dual boot with windows). I'm not able to connect to the internet even though the I'm using a LAN cable. But it works fine when I boot to Windows. Will anyone please help me?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •