Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: wlan0 is flukey with static ip address

  1. #11
    Join Date
    Feb 2010
    Location
    Chelmsford, Massachusetts
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: wlan0 is flukey with static ip address

    Hans, you could also divide your subnet into 2 subnets by using a netmask of 255.255.255.128.

    On the first subnet, you could give IP addresses 192.168.1.1-192.168.1.126 to one NIC card, and 192.168.1.128-192.168.1.254 to the other. That way, they stay in the same class of IP address (class C) and at the same time, they are on two different subnets. You should also be able to still utilize your router so you can have access to the outside world if you need it. Your router may need to be changed as well to fit the networking scheme.

  2. #12
    Join Date
    Feb 2010
    Location
    Chelmsford, Massachusetts
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: wlan0 is flukey with static ip address

    wlan0 just went down after I tried to bring the machine up with only wlan0 being configured to go up. So I would say that it takes about 30 min to go down on its own. However, when eth0 is also up with it, it appears to stay up with no problems "sleeping" or "shutting off".

  3. #13
    Join Date
    Feb 2010
    Location
    Chelmsford, Massachusetts
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: wlan0 is flukey with static ip address

    I have just experienced the same problem again. Instead of making an attempt to reconnect to the access point, I took a look at dmesg. I found out that at the very end of dmesg, it gives me the following:

    [584996.380033] wlan0: no probe response from AP XX.XX.XX.XX.XX.XX - disassociating

    I then looked up this "error" to try and find out why this might be happening. As it turns out, others are having this issue as well:

    http://ubuntuforums.org/showthread.php?t=1222805

    I'm hoping someone can try to explain why this is happening. It does seem like the wireless NIC is going into some sort of power saving mode and not waking up when it needs to. Funny thing is that I can use a flag that will shut the power saving off on the wireless NIC, but it doesn't appear to change when I do.

  4. #14
    Join Date
    Feb 2010
    Location
    Chelmsford, Massachusetts
    Beans
    10
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: wlan0 is flukey with static ip address

    bump

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •