Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: No sound at startup

  1. #1
    Join Date
    Feb 2009
    Location
    47.3505, 8.71842
    Beans
    168
    Distro
    Ubuntu 11.04 Natty Narwhal

    No sound at startup

    A few days ago, my sound suddenly stopped working. I was able to get it back with
    Code:
    alsamixer
    , "front" was muted.
    Sadly, this problem also persist when I restart my pc. Is there a way that I dont have to unmute at every startup?

  2. #2
    Join Date
    Feb 2009
    Location
    47.3505, 8.71842
    Beans
    168
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No sound at startup

    bump

  3. #3
    Join Date
    Sep 2009
    Beans
    401
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: No sound at startup

    PulseAudio overwrites your saved alsamixer settings on startup.

    The easiest way to fix this is to remove PulseAudio:
    Code:
    sudo apt-get install gstreamer0.10-alsa gnome-alsamixer
    sudo apt-get purge pulseaudio gstreamer0.10-pulseaudio vlc-plugin-pulse

  4. #4
    Join Date
    Feb 2009
    Location
    47.3505, 8.71842
    Beans
    168
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No sound at startup

    Sound works from the start again, thanks a lot. Whats the whole deal anyway with pulseaudio and ALSA ? What exactly did I install and what did I uninstall?
    New Problem: The volume control in the panel is gone, and my volume control buttons dont work anymore.
    Last edited by Zilioum; February 3rd, 2010 at 05:03 PM. Reason: New Problem

  5. #5
    Join Date
    Feb 2009
    Location
    47.3505, 8.71842
    Beans
    168
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No sound at startup

    bump

  6. #6
    Join Date
    Feb 2009
    Location
    47.3505, 8.71842
    Beans
    168
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No sound at startup

    How can I reinstall ALSA? Should I get rid of PulseAudio so I dont have the same problem again (no sound at startup). Do I need both?
    “The ships hung in the sky in much the same way that bricks don't.”
    Douglas Adams

  7. #7
    Join Date
    Feb 2009
    Location
    47.3505, 8.71842
    Beans
    168
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No sound at startup

    After some research, I decided to reinstall PulseAudio since I need it. Everything is back to normal, which means no sound at startup again.
    “The ships hung in the sky in much the same way that bricks don't.”
    Douglas Adams

  8. #8
    Join Date
    Feb 2009
    Location
    47.3505, 8.71842
    Beans
    168
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No sound at startup

    bump
    “The ships hung in the sky in much the same way that bricks don't.”
    Douglas Adams

  9. #9
    Join Date
    Nov 2009
    Beans
    57

    Re: No sound at startup

    I had the same annoying problem with muted sound after each new start in 9.10. This seems to have been fixed in Lucid. I suggest you wait till the official release and then upgrade.

    If this is not a solution, I'd look for a start up script to change the volume. Unfortunately I have limited Linux experience to write such a script myself, but googling might help. This should not be a big thing.

  10. #10
    Join Date
    Feb 2009
    Location
    47.3505, 8.71842
    Beans
    168
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: No sound at startup

    Thanks, good to know. Has anyone another suggestions? Or an explanations why this happened in the first place? Because my sound worked without problem for months.
    “The ships hung in the sky in much the same way that bricks don't.”
    Douglas Adams

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •