Results 1 to 5 of 5

Thread: DNS IP address configuration

  1. #1
    Join Date
    Jun 2008
    Beans
    47

    DNS IP address configuration

    Hi,

    I am using Ubuntu 9.04 (x86-64).

    My internet connection is not working, i've tried to fix it and the issue seems to be with DNS. I can ping google's IP, but i can ping it URL.

    I have used the GUI network manager(from Gnome's equivalent of the Windows system tray), to add the DNS IP addresses to the IPv4 wired connection - that hasn't helped.

    I have checked
    Code:
    /etc/resolv.conf
    and the IP addresses show up there.
    Code:
    # Generated by NetworkManager
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    I have also checked
    Code:
    /etc/dhcp3/dhclient.conf
    for
    Code:
    prepend domain-name-servers 192.168.1.1,208.67.222.222,208.67.220.220;
    IP address assignment is via DHCP, i need to "force" the DNS Server IP addresses on the ethernet connection.

    How can this be done?

    thanks

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,562
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: DNS IP address configuration

    /etc/dhcp3/dhclient.conf
    Does the behavior improve if you remove the highlighted parts?
    Code:
    request subnet-mask, broadcast-address, time-offset, routers,
            domain-name, domain-name-servers, domain-search, host-name,
            netbios-name-servers, netbios-scope, interface-mtu,
            rfc3442-classless-static-routes, ntp-servers;
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jun 2008
    Beans
    47

    Re: DNS IP address configuration

    hi,

    thanks for the reply, i tried what you said. It didn't work.

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,562
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: DNS IP address configuration

    First, I notice that these are inconsistent:
    # Generated by NetworkManager
    nameserver 208.67.222.222
    nameserver 208.67.220.220
    And this:
    prepend domain-name-servers 192.168.1.1,208.67.222.222,208.67.220.220;
    I suggest you amend /etc/dhcp3/dhclient.conf as follows:
    Code:
    supersede domain-name-servers 208.67.222.222,208.67.220.220;
    Please let us know.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Jun 2008
    Beans
    47

    Re: DNS IP address configuration

    hi,

    thanks again for the response, i was unwell, could only manage to to try this today and it worked after i made the change you mentioned.

    thanks.

    just in case someone faces the same issue in future, heres a how to on forcing DNS Address in Ubuntu:
    1)Right click the NetworkManager Applet (its usually one of the icons to the left of the power button on Ubuntu 9.04) and select Edit Connections...
    2)Select the appropriate connection and click Edit(it may ask you for your password)
    3)On the next window that appears go to the IPv4 Settings Tab and type the primary and secondary DNS IP addresses separated by a comma. Then click apply.
    4)On the terminal type sudo gedit /etc/dhcp3/dhclient.conf and edit the part where it says supersede domain-name-servers ... to supersede domain-name-servers PRIMARY_DNS_IP SECONDARY_DNS_IP
    5)Restart networking by typing sudo /etc/init.d/networking restart in a terminal.
    6)Get browsing
    Note: There may be better ways to do this,this has worked for me. Hope this is of help.

    Thanks again chili555 for helping out.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •