Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Starling[star1] Mouse/tack pad broken

  1. #1
    Join Date
    Dec 2009
    Beans
    54
    Distro
    Ubuntu 10.04 Lucid Lynx

    Exclamation Starling[star1] Mouse/tack pad broken

    Hey peoples! I installed the new updates on my star1 and after words, the screen went blank and the mouse wouldn't move. So I cycled the power and when it rebooted my mouse and the track pad both were unresponsive! I can't do anything because the mouse doesn't work. WHAT NOW?!?!?!?!?! BTW I have xfce and gnome using synaptic. ALSO, when it boots up, on the log in screen it has a message that says: MAL [something] is not running. And the title of the window is: Xfce power manager. IDK if this has anything to do with it. Please comment.

  2. #2
    Join Date
    Sep 2006
    Location
    Denver, Colorado
    Beans
    5,638
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Starling[star1] Mouse/tack pad broken

    Try using a USB mouse until we get it figured out.

    We don't support xfce, but try booting into gnome and see if you have the same problem.
    To err is human, to forgive is very ... dog-like.

    Thomas Aaron
    FetchMasters, LLC

  3. #3
    Join Date
    Nov 2009
    Beans
    11

    Re: Starling[star1] Mouse/tack pad broken

    Quote Originally Posted by black_ice=cream View Post
    Hey peoples! I installed the new updates on my star1 and after words, the screen went blank and the mouse wouldn't move. So I cycled the power and when it rebooted my mouse and the track pad both were unresponsive! I can't do anything because the mouse doesn't work. WHAT NOW?!?!?!?!?! BTW I have xfce and gnome using synaptic. ALSO, when it boots up, on the log in screen it has a message that says: MAL [something] is not running. And the title of the window is: Xfce power manager. IDK if this has anything to do with it. Please comment.
    The same thing happened to my Starling this morning, while updating. I loaded the kernel in recovery mode, but everything I've tried there isn't helping. When I ran the "Repair broken packages" option, it says that there are problems with the "winbind" package. I tried to remove/purge it using aptitude, to no avail.

    Any ideas?

  4. #4
    Join Date
    Nov 2009
    Beans
    11

    Re: Starling[star1] Mouse/tack pad broken

    Quote Originally Posted by thomasaaron View Post
    Try using a USB mouse until we get it figured out.

    We don't support xfce, but try booting into gnome and see if you have the same problem.
    I tried that, it doesn't work ..

  5. #5
    Join Date
    Sep 2006
    Location
    Denver, Colorado
    Beans
    5,638
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Starling[star1] Mouse/tack pad broken

    OK, I'm updating my Starling to see if anything goes wrong...
    To err is human, to forgive is very ... dog-like.

    Thomas Aaron
    FetchMasters, LLC

  6. #6
    Join Date
    Sep 2006
    Location
    Denver, Colorado
    Beans
    5,638
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Starling[star1] Mouse/tack pad broken

    OK, I just ran updates and nothing broke. So it is something specific to your set-up.

    It kind of sounds like a grub issue to me. Are you running 9.04 or 9.10
    To err is human, to forgive is very ... dog-like.

    Thomas Aaron
    FetchMasters, LLC

  7. #7
    Join Date
    Nov 2009
    Beans
    11

    Re: Starling[star1] Mouse/tack pad broken

    Quote Originally Posted by thomasaaron View Post
    ok, i just ran updates and nothing broke. So it is something specific to your set-up.

    It kind of sounds like a grub issue to me. Are you running 9.04 or 9.10
    9.10

  8. #8
    Join Date
    Sep 2006
    Location
    Denver, Colorado
    Beans
    5,638
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Starling[star1] Mouse/tack pad broken

    When you see the "Grub" in the upper left, try pressing the "Shift" key to get a kernel menu. Select the previous non-recovery mode kernel and boot from it. Let me know if your touchpad works there.
    To err is human, to forgive is very ... dog-like.

    Thomas Aaron
    FetchMasters, LLC

  9. #9
    Join Date
    Nov 2009
    Beans
    11

    Re: Starling[star1] Mouse/tack pad broken

    Quote Originally Posted by thomasaaron View Post
    When you see the "Grub" in the upper left, try pressing the "Shift" key to get a kernel menu. Select the previous non-recovery mode kernel and boot from it. Let me know if your touchpad works there.
    Yeah, I had already tried this. It doesn't work - no mouse, and looks like no keyboard either (since I can't ctrl-alt-F to another tty).

    Looked at dmesg, the only errors I can find are hal segfaults (about 5 in a row each time):

    hal[1655]: segfault at ef8ce37c ip 08057d36 sp bf8edd40 error 5 in hald[8048000+5a000]

  10. #10
    Join Date
    Nov 2009
    Beans
    11

    Re: Starling[star1] Mouse/tack pad broken

    Fixed it! I reinstalled the hal package, and now everything is back to normal after rebooting. Thanks for all your help, Tom!

    I'm guessing something in this morning's update broke hal ...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •