Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: wireless for T-40

  1. #1
    Join Date
    Jan 2010
    Beans
    9

    wireless for T-40

    Hi,

    I installed Ubuntu and I cant get my wireless connection to work. I found that I need ndiswrapper to update my drivers following the sticky post in here. However there is a problem, because I cant successfully run ndiswrapper on my system.
    Please help.

    Ubuntu 9.10, IBM ThinkPad T-40, what am I doing wrong?


    prem@prem-laptop:~/Desktop/ndiswrapper-1.55$ make uninstall
    NOTE: Not all installed files are removed, as different distributions install ndiswrapper files at different places.
    Run uninstall as many times as necessary until no "removing" messages appear below.
    removing /lib/modules/2.6.31-14-generic/kernel/ubuntu/ndiswrapper/ndiswrapper.ko
    /bin/rm: cannot remove `/lib/modules/2.6.31-14-generic/kernel/ubuntu/ndiswrapper/ndiswrapper.ko': Permission denied
    make: *** [uninstall] Error 1
    prem@prem-laptop:~/Desktop/ndiswrapper-1.55$


    prem@prem-laptop:~/Desktop/ndiswrapper-1.55$ make
    make -C driver
    make[1]: Entering directory `/home/prem/Desktop/ndiswrapper-1.55/driver'
    make -C /usr/src/linux-headers-2.6.31-14-generic M=/home/prem/Desktop/ndiswrapper-1.55/driver
    make[2]: Entering directory `/usr/src/linux-headers-2.6.31-14-generic'
    CC [M] /home/prem/Desktop/ndiswrapper-1.55/driver/crt.o
    In file included from /home/prem/Desktop/ndiswrapper-1.55/driver/crt.c:16:
    /home/prem/Desktop/ndiswrapper-1.55/driver/ntoskernel.h: In function ‘PushEntrySList’:
    /home/prem/Desktop/ndiswrapper-1.55/driver/ntoskernel.h:905: error: implicit declaration of function ‘cmpxchg8b’
    make[3]: *** [/home/prem/Desktop/ndiswrapper-1.55/driver/crt.o] Error 1
    make[2]: *** [_module_/home/prem/Desktop/ndiswrapper-1.55/driver] Error 2
    make[2]: Leaving directory `/usr/src/linux-headers-2.6.31-14-generic'
    make[1]: *** [modules] Error 2
    make[1]: Leaving directory `/home/prem/Desktop/ndiswrapper-1.55/driver'
    make: *** [all] Error 2
    prem@prem-laptop:~/Desktop/ndiswrapper-1.55$

  2. #2
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless for T-40

    I am answering this post from my T40. I am wondering which wireless chipset yours has that doesn't work natively. What have you tried to get the wireless to work?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Jan 2010
    Beans
    9

    Re: wireless for T-40

    Cisco Aironet Wireless 80.11b

    I'm very new to ubuntu, so I tried to read as much about this issue as I can understand (with my limited knowledge). I know my BIOS has the wireless device turned on (Fn + F5 normally works in windows, but in ubuntu I did not notice any changes when I press it).

  4. #4
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless for T-40

    Ahh! The good old Aironet! Please open a terminal and do:
    Code:
    dmesg | grep -i airo
    sudo lshw -C network
    Let's see what's happening, or not, under the hood.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  5. #5
    Join Date
    Jan 2010
    Beans
    9

    Re: wireless for T-40

    prem@prem-laptop:~$ dmesg | grep -i airo
    [ 13.562474] airo(): Probing for PCI adapters
    [ 13.562545] airo 0000:02:02.0: PCI INT A -> Link[LNKC] -> GSI 11 (level, low) -> IRQ 11
    [ 13.562568] airo(): Found an MPI350 card
    [ 14.599617] airo(eth1): Firmware version 5.60.10
    [ 14.599621] airo(eth1): WPA supported.
    [ 14.599624] airo(eth1): MAC enabled 00:02:8a:ba:5a:f3
    [ 14.601389] airo(): Finished probing for PCI adapters
    [ 17.048165] airo(eth1): set_wep_key: key length to set was zero
    [ 17.048173] airo(eth1): failed to set WEP key at index 0: -1.
    [ 17.048235] airo(eth1): set_wep_key: key length to set was zero
    [ 17.048239] airo(eth1): failed to set WEP key at index 1: -1.
    [ 17.048261] airo(eth1): set_wep_key: key length to set was zero
    [ 17.048265] airo(eth1): failed to set WEP key at index 2: -1.
    [ 17.048286] airo(eth1): set_wep_key: key length to set was zero
    [ 17.048289] airo(eth1): failed to set WEP key at index 3: -1.
    [ 17.050854] airo(eth1): cmd:1 status:7f01 rsp0:88 rsp1:ff10 rsp2:c0f0
    [ 17.050860] airo(eth1): Bad MAC enable reason=88, rid=ff10, offset=49392
    [ 17.144407] airo(eth1): cmd:103 status:7f03 rsp0:0 rsp1:ff10 rsp2:c0f0
    [ 37.413696] airo(eth1): cmd:103 status:7f03 rsp0:0 rsp1:ff10 rsp2:c0f0
    [ 67.413565] airo(eth1): cmd:103 status:7f03 rsp0:0 rsp1:ff10 rsp2:c0f0
    [ 107.413826] airo(eth1): cmd:103 status:7f03 rsp0:0 rsp1:ff10 rsp2:c0f0
    [ 157.426056] airo(eth1): cmd:103 status:7f03 rsp0:0 rsp1:ff10 rsp2:c0f0

    a few pages of the above...


    and then

    prem@prem-laptop:~$ sudo lshw -C network
    [sudo] password for prem:
    *-network:0 DISABLED
    description: Wireless interface
    product: Cisco Aironet Wireless 802.11b
    vendor: AIRONET Wireless Communications
    physical id: 2
    bus info: pci@0000:02:02.0
    logical name: eth1
    version: 00
    serial: 00:02:8a:ba:5a:f3
    width: 32 bits
    clock: 33MHz
    capabilities: pm vpd bus_master cap_list rom ethernet physical wireless logical
    configuration: broadcast=yes driver=airo latency=64 maxlatency=4 mingnt=4 multicast=yes wireless=IEEE 802.11-DS
    resources: irq:11 ioport:8000(size=256) memory:c0200000-c0203fff memory:c0400000-c07fffff memory:c0800000-c09fffff(prefetchable)
    *-network:1
    description: Ethernet interface
    product: 82801DB PRO/100 VE (MOB) Ethernet Controller
    vendor: Intel Corporation
    physical id: 8
    bus info: pci@0000:02:08.0
    logical name: eth0
    version: 81
    serial: 00:0d:60:37:27:cb
    size: 100MB/s
    capacity: 100MB/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=e100 driverversion=3.5.24-k2-NAPI duplex=full firmware=N/A ip=192.168.1.67 latency=66 link=yes maxlatency=56 mingnt=8 multicast=yes port=MII speed=100MB/s
    resources: irq:11 memory:c0204000-c0204fff ioport:8400(size=64)
    prem@prem-laptop:~$

    hmmm... DISABLED?

  6. #6
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless for T-40

    Please open a terminal and do:
    Code:
    sudo gedit /etc/modprobe.d/blacklist.conf
    Add these lines:
    Code:
    # these aes modules break the airo driver
    blacklist padlock-aes
    blacklist geode-aes
    Proofread, save and close gedit. Reboot and let us know if the wireless now works. If not, please post:
    Code:
    lsmod
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  7. #7
    Join Date
    Jan 2010
    Beans
    9

    Re: wireless for T-40

    I got it to work. However, I also had to change settings on my router:

    went from hidden, no ssid, wpa-psk, channel 1 (2412Mhz) to

    open WEP, SSID enabled.

    wonder why I couldnt find WPA-PSK encryption when left-clicking on the icon in ubuntu. I only had options of WEP 40 and 128 bit.

    Thank you for help

  8. #8
    Join Date
    Jan 2010
    Beans
    9

    Re: wireless for T-40

    Also, after the change of router settings, all my other devices on the network (2 laps, iphone and a PS3) get intermittent connection. hhmmmmmm......

  9. #9
    Join Date
    Jan 2010
    Beans
    9

    Re: wireless for T-40

    Do I need wpa_supplicant and do I need to edit /user/network/interfaces in 9.10?
    Will this interfere with Network Manager?

  10. #10
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,228
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: wireless for T-40

    Do I need wpa_supplicant
    Probably so.
    Code:
    sudo apt-get install wpa-supplicant
    do I need to edit /user/network/interfaces in 9.10?
    It's actually /etc/network/interfaces, and no, you don't need to touch it.
    Will this interfere with Network Manager?
    interfaces most definitely will.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •