Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Wireless Internet "Device Not Ready"

  1. #11
    Join Date
    Jan 2010
    Beans
    7

    Re: Wireless Internet "Device Not Ready"

    Hey Chili, once again thank you very much for all this help.

    Where I'm at now is I connected my computer directly to the router with a "firewire" cord or whatever, sorry don't know the proper terms. From there I was able to connect to the internet with my wired ethernet connection. I tried the sudo

    sudo apt-get install b43-fwcutter


    and got this

    sudo apt-get install b43-fwcutter

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldn't find package b43-fwcutter


    I then followed your link to that alternate firmware package, and after struggling for a while to figure out how to get the "permissions" to be able to extract the files into lib\firmware I got the files in there, but haven't seen any change in my wireless. Still says "device not ready"

    I appreciate all your patients and help, any idea of where I can go from here?

  2. #12
    Join Date
    Jan 2010
    Beans
    7

    Re: Wireless Internet "Device Not Ready"

    update!


    Not sure what made the difference since my last post, I refreshed the network and didn't see any changes. But just now I took a look and it is working! So I'm guessing it was the firmware download you linked me to. Thank you very much for all your help, I am EXTREMELY greatful.

  3. #13
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,567
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Wireless Internet "Device Not Ready"

    Glad it's working! Enjoy!
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #14
    Join Date
    Nov 2010
    Beans
    9

    Re: Wireless Internet "Device Not Ready"

    i'm having the same issue, i did what y'all did here and it still didn't work

    Code:
    vzybilly@VZYServ:~$ dmesg | grep b43
    [    1.394579] b43-pci-bridge 0000:02:03.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [    8.869749] b43-phy0: Broadcom 4318 WLAN found (core revision 9)
    [    9.051700] Registered led device: b43-phy0::tx
    [    9.051720] Registered led device: b43-phy0::rx
    [    9.051742] Registered led device: b43-phy0::radio
    [   22.852369] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
    [   22.852375] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
    [   22.852379] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
    [343377.517230] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
    [343377.517237] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
    [343377.517241] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
    vzybilly@VZYServ:~$ sudo apt-get install b43-fwcutter
    [sudo] password for vzybilly: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
      b43-fwcutter
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 16.3kB of archives.
    After this operation, 81.9kB of additional disk space will be used.
    Get:1 http://us.archive.ubuntu.com/ubuntu/ maverick/main b43-fwcutter i386 1:013-2 [16.3kB]
    Fetched 16.3kB in 0s (31.6kB/s)       
    Selecting previously deselected package b43-fwcutter.
    (Reading database ... 124238 files and directories currently installed.)
    Unpacking b43-fwcutter (from .../b43-fwcutter_1%3a013-2_i386.deb) ...
    Processing triggers for man-db ...
    Setting up b43-fwcutter (1:013-2) ...
    vzybilly@VZYServ:~$ dmesg | grep b43
    [    1.394579] b43-pci-bridge 0000:02:03.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [    8.869749] b43-phy0: Broadcom 4318 WLAN found (core revision 9)
    [    9.051700] Registered led device: b43-phy0::tx
    [    9.051720] Registered led device: b43-phy0::rx
    [    9.051742] Registered led device: b43-phy0::radio
    [   22.852369] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
    [   22.852375] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
    [   22.852379] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
    [343377.517230] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
    [343377.517237] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
    [343377.517241] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
    vzybilly@VZYServ:~$ rfkill list
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    vzybilly@VZYServ:~$ dmesg | grep wlan
    vzybilly@VZYServ:~$
    i restarted and got this

    Code:
    vzybilly@VZYServ:~$ dmesg | grep b43
    [    1.396367] b43-pci-bridge 0000:02:03.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
    [   27.397177] b43-phy0: Broadcom 4318 WLAN found (core revision 9)
    [   27.892903] Registered led device: b43-phy0::tx
    [   27.892924] Registered led device: b43-phy0::rx
    [   27.892944] Registered led device: b43-phy0::radio
    [   30.307648] b43-phy0 ERROR: Firmware file "b43/ucode5.fw" not found
    [   30.307654] b43-phy0 ERROR: Firmware file "b43-open/ucode5.fw" not found
    [   30.307658] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.
    vzybilly@VZYServ:~$
    thanks for all of your help, it would be awesome if the wireless would work on this computer

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •