Page 12 of 25 FirstFirst ... 2101112131422 ... LastLast
Results 111 to 120 of 246

Thread: HOWTO: Proper Screencasting on Linux

  1. #111
    Join Date
    Sep 2009
    Location
    Holland
    Beans
    20
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Proper Screencasting on Linux

    Oh, thank you so much for the tutorial!! I wanted to do screencasting for a long time now and when I finally found something I could really use it for (pitching a solution for sharing pictures that is made at our education, with the use of gallery3) I stumbled upon this tutorial.

    As I want to use open source solutions regardless of a whatever lack of quality as long as it's getting the point across this worked out beautifully. I didn't experience a lack of quality in the .ogg end result at all actually.. I was surprised the 'lossless' .mkv file went from 100mb to only 60mb in the .ogg result..

    Btw; I anticipated that explaining how to use program you don't need 30fps, so I set it to 23fps which was fine..

  2. #112
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: HOWTO: Proper Screencasting on Linux

    You can encode to the new open format "WebM", which should give you much better quality than .ogg with Theora. Just replace libtheora with libvpx (assuming you followed the ffmpeg building guide, you should have that included as well) and encode the file in 2 passes with the -pass 1/2 option. Also, change the extension to .webm instead of .ogg.

    Example:
    Pass 1:
    Code:
    ffmpeg -i output.mkv -an -vcodec libvpx -b 1000k -pass 1 our-final-product.webm
    Pass 2:
    Code:
    ffmpeg -i output.mkv -acodec libvorbis -ab 128k -ac 2 -vcodec libvpx -b 1000k -threads 2 -pass 2 our-final-product.webm
    Change the bitrate (-b 1000k) to control the size/quality tradeoff. Also, change the number of threads (-threads 2) to suit the number of threads your CPU has. If your CPU is not multi-threaded, you can omit the -threads option completely. If you have a modern web browser, you can open the file and play it natively inside it. A WebM file consists of VP8 video and Vorbis audio mulitplexed into a .webm container (which is basically a subset of the Matroska container, aka .mkv).
    Last edited by verb3k; March 26th, 2011 at 11:08 PM. Reason: Better commands
    Freedom is neither exclusive nor unlimited.

  3. #113
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: HOWTO: Proper Screencasting on Linux

    Guide update: Added WebM example, updated the guide to reflect the change from "q" to "ctrl-c" to stop recording.
    Freedom is neither exclusive nor unlimited.

  4. #114
    Join Date
    Jan 2010
    Beans
    177
    Distro
    Ubuntu 10.04 Lucid Lynx

    How2 stop ffmpegs x11grab grabbing the mouse cursor ?

    Hi there,

    I've been searching this thread and read various postings in the www but didn't find a real answer to my issue.
    It has been awhile since I captured some gaming videos under Linux with ffmpeg but on my newly set up Ubuntu 10.04 x64 box ffmpeg (with x11grab) records an ugly white mouse cursor in the middle of the screen even if no cursor should be visibile (e.g. playing Q3A in fullscreen mode).
    On the same system with archlinux x64 I never experience such behaviour. Of course it is possible that this was an older version of ffmpeg which didn't capture mouse pointers at all ?
    Is there an option to disable any mouse cursor capturing ?

    Edit: I would be fine with rebuilding ffmpeg from source.

    TIA,
    Holger

    P.S.: A small note to those who experience audio delay with ffmpeg and PA. I found out that my system produces a constant delay of 2100 ms. If I resync audio and video afterwards by this value everything is perfectly in sync.
    Last edited by HolgerB; April 4th, 2011 at 02:56 PM.
    Xubuntu 12.04 x64 // AMD E-350 (2x1.6 GHz) // 8 GB DDR3 RAM // GeForce 9500GT (1GB) with passive cooling

  5. #115
    Join Date
    Sep 2006
    Beans
    3,480

    Re: How2 stop ffmpegs x11grab grabbing the mouse cursor ?

    Quote Originally Posted by HolgerB View Post
    Is there an option to disable any mouse cursor capturing ?
    There is a nomouse option:
    Code:
    -i :0.0+nomouse
    Works with FFmpeg from the repository for Maverick at least.

  6. #116
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: How2 stop ffmpegs x11grab grabbing the mouse cursor ?

    Quote Originally Posted by FakeOutdoorsman View Post
    There is a nomouse option:
    Code:
    -i :0.0+nomouse
    Works with FFmpeg from the repository for Maverick at least.
    Awesome. Works on git FFmpeg too. NB4 I add it to the guide.
    Thanks.

    EDIT: Added. Thanks again.
    Last edited by verb3k; April 4th, 2011 at 08:24 PM.
    Freedom is neither exclusive nor unlimited.

  7. #117
    Join Date
    Jan 2010
    Beans
    177
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How2 stop ffmpegs x11grab grabbing the mouse cursor ?

    Quote Originally Posted by FakeOutdoorsman View Post
    There is a nomouse option:
    Code:
    -i :0.0+nomouse
    Works with FFmpeg from the repository for Maverick at least.
    Thanks for your hint but at least my version SVN-r0.5.1-4:0.5.1-1ubuntu1.1 does not seem to care
    Xubuntu 12.04 x64 // AMD E-350 (2x1.6 GHz) // 8 GB DDR3 RAM // GeForce 9500GT (1GB) with passive cooling

  8. #118
    Join Date
    Apr 2011
    Beans
    7
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Question Re: HOWTO: Proper Screencasting on Linux

    I've had some experience with gtk-recordMyDesktop, but after I switched from a 32-bits desktop pc to a 64-bits laptop (Ubuntu 10.10), RMD started performing badly: The last part of the captured video does not show up in the final ogv video

    I tried ffmpeg using this and many other guides, without the expected/promised result. You're claiming a zero-quality loss, although I experience the opposite: see attachment.
    The upper part of the screenshot shows the original sample, the bottom part shows the result after capturing: A very perceivable result. The colors are different, and some particles are faded.

    How can I capture a part of my screen without any loss in quality? I want to edit the captured screen using Kdenlive, then upload it to YouTube (using h.264).

    I used the following code:
    Code:
    ffmpeg -f x11grab -r 15 -s 768x512 -i :0.0+810,55 -vcodec libx264 -vpre lossless_ultrafast -threads 0 /tmp/ffmpeg-tests/out.mkv
    I tried all possible vpre options and over twenty file extensions, yet no satisfying result. Could anyone help me with solving this extremely annoying issue?
    Attached Images Attached Images

  9. #119
    Join Date
    Jan 2010
    Beans
    177
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO: Proper Screencasting on Linux

    Quote Originally Posted by M759 View Post
    I my screen without any loss in quality? I want to edit the captured screen using Kdenlive, then upload it to YouTube (using h.264).
    I would go for huffyuv for video codec which is lossless. Audio could be plain pcm or flac.
    You should always check out the captured video in mplayer or vlc if you experience image corruption in kdenlive or any other video editing software.

    I can post my ffmpeg rec command this evening if you like.
    Last edited by HolgerB; April 7th, 2011 at 03:45 PM.
    Xubuntu 12.04 x64 // AMD E-350 (2x1.6 GHz) // 8 GB DDR3 RAM // GeForce 9500GT (1GB) with passive cooling

  10. #120
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: HOWTO: Proper Screencasting on Linux

    Quote Originally Posted by M759 View Post
    I've had some experience with gtk-recordMyDesktop, but after I switched from a 32-bits desktop pc to a 64-bits laptop (Ubuntu 10.10), RMD started performing badly: The last part of the captured video does not show up in the final ogv video

    I tried ffmpeg using this and many other guides, without the expected/promised result. You're claiming a zero-quality loss, although I experience the opposite: see attachment.
    The upper part of the screenshot shows the original sample, the bottom part shows the result after capturing: A very perceivable result. The colors are different, and some particles are faded.

    How can I capture a part of my screen without any loss in quality? I want to edit the captured screen using Kdenlive, then upload it to YouTube (using h.264).

    I used the following code:
    Code:
    ffmpeg -f x11grab -r 15 -s 768x512 -i :0.0+810,55 -vcodec libx264 -vpre lossless_ultrafast -threads 0 /tmp/ffmpeg-tests/out.mkv
    I tried all possible vpre options and over twenty file extensions, yet no satisfying result. Could anyone help me with solving this extremely annoying issue?
    This is probably because libx264 does not yet support the 4:4:4 color space; edges of very small and sharp lines might appear a bit blurred. Go ask the x264 developers to add it.
    Freedom is neither exclusive nor unlimited.

Page 12 of 25 FirstFirst ... 2101112131422 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •