Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

  1. #11
    Join Date
    Sep 2009
    Beans
    12

    Talking Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Worked for me too! Thanks! First time I've had tear-free video using nvidia drivers!

    Karmic 64bit
    Dual GTX 260 core 216 superclocked in SLI.

  2. #12
    Join Date
    May 2009
    Beans
    12

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Tearing is still not fixed in Lucid, but this tutorial works here aswell. updated

  3. #13
    Join Date
    Sep 2009
    Beans
    1

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Great great help kopiwe!!!!! Thank you very much.... I've been loking for a solution to this since ubuntu 9.10 with an nvidia GeForce 7200 SE until ubuntu lucid with an nvidia GT220!!!!
    Worked like a charm here!!!!!

  4. #14
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,663
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    This works! Thanks kopiwe , ...but

    I'd like to ad a caveat. If you have dual head setup, you need an extra trick (especially if you have two different monitors). The following steps works when the monitors are configured as two separate X Screens.

    When you go to CompizConfig Setting Manager (CSM), before going to General Options, you'll see in the upper left corner a field that shows Screen 0, or Screen 1. You need to setup Sync to VBlank for both screens.

    The problem is that even if you change that field for both screens, it DOES NOT work unless you do it separately:

    1. Open CSM on screen 0 (main monitor) and set Sync to VBlank. Close it.
    2. Go to your screen 1 (other monitor), and open CSM there. Now set Sync to VBlank there.


    ...and then worked for me (I even have a compiz-cube working in each screen!)
    Regards.
    Last edited by papibe; June 22nd, 2010 at 08:48 PM. Reason: more detail.

  5. #15
    Join Date
    Jun 2010
    Location
    Lithuania
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Thanks , thats useful.

  6. #16
    Join Date
    May 2010
    Location
    Snellville, GA
    Beans
    66
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    This fixed the tearing for me in Lucid. Using VLC everthing works great. I still get herky jerkyness playing matroska vids on mplayer though. Any fix for that?
    Asus Eeebox PC EB1501 (TV!)
    iMac G5
    HP Pavilion dv6zse

  7. #17
    Join Date
    May 2009
    Beans
    12

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Quote Originally Posted by selittl View Post
    This fixed the tearing for me in Lucid. Using VLC everthing works great. I still get herky jerkyness playing matroska vids on mplayer though. Any fix for that?

    Matroska is only the container for a codec, wich is probably the h.264 in your case. If it is, you could try the "vdpau" instead of the "xv" video output. VDPAU uses your graphic card to accelerate video playback.

  8. #18
    Join Date
    Apr 2007
    Location
    London, Ontario, Canada
    Beans
    51

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    Works well on the work laptop, but not on the home one. Home laptop is an old Compaq R3000 which uses the 440 Go GPU. For some reason, enabling V-Sync in Compiz causes it to not come out of stand-by/suspend. I imagine this is just a quirky issue related to that particular system though. The tearing is not too bad on it anyway.
    You need only two tools: WD-40 and Duct Tape. If it doesn't move and it should, use WD-40. If it moves and shouldn't, use the duct tape. - Red Green

  9. #19
    Join Date
    Mar 2012
    Beans
    1

    Re: HOWTO: Get rid of video TEARING in Compiz with NVIDIA

    My tearing problem was caused becauce i have two screens. I Started nvidia settings: under the tab xvideo settings i selected my tv to be the "sync to this display device". At first i tried with the compiz thing but i did not even have the setting to set the refresh rate after unchecking auto detect

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •