Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Wireless Perfect... Wired =Black Hole

  1. #1
    Join Date
    Jan 2010
    Location
    Lee's Summit, MO
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Wireless Perfect... Wired =Black Hole

    Ok, Like everyone that posts on this forum, I am a complete newbie when it comes to ubuntu. I was finally tired of vista locking up and decided to scrap it and load ubuntu 9.10. Overall it is awesome. Wireless works perfectly, no video card issues 10000 times faster than vista, the best solution I ever did. But for some reason when I plug a network cord in and turn off wireless I have no connectivity. I have a Toshiba Satellite a205-s5800 and it seems like there is no clear area to find out information on it.

    Any ideas?

  2. #2
    Join Date
    Dec 2009
    Location
    Panama City, FL, USA
    Beans
    543
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireless Perfect... Wired =Black Hole

    A little more information might help. Could you post the output of "sudo lshw -C network"?

  3. #3
    Join Date
    Jan 2010
    Location
    Lee's Summit, MO
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Wireless Perfect... Wired =Black Hole

    *-network
    description: Ethernet interface
    product: 88E8039 PCI-E Fast Ethernet Controller
    vendor: Marvell Technology Group Ltd.
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: eth0
    version: 14
    serial: 00:a0:d1:9d:dc:81
    size: 10MB/s
    capacity: 100MB/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.23 duplex=half firmware=N/A latency=0 link=yes multicast=yes port=twisted pair speed=10MB/s
    resources: irq:30 memory:f0000000-f0003fff ioport:2000(size=256)
    *-network
    description: Wireless interface
    physical id: 1
    logical name: wlan0
    serial: 00:16:44:9b:24:9e
    capabilities: ethernet physical wireless
    configuration: broadcast=yes ip=192.168.1.201 multicast=yes wireless=IEEE 802.11bg


    Wireless works fine... but wired network will not connect
    Last edited by cavan; January 10th, 2010 at 09:31 PM. Reason: adding more

  4. #4
    Join Date
    Dec 2009
    Location
    Panama City, FL, USA
    Beans
    543
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireless Perfect... Wired =Black Hole

    Hmm...nothing too weird there. How about the output of "ifconfig eth0" and "route -n"?

  5. #5
    Join Date
    Jan 2010
    Location
    Lee's Summit, MO
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Wireless Perfect... Wired =Black Hole

    brad@brad-laptop:~$ ifconfig eth0
    eth0 Link encap:Ethernet HWaddr 00:a0:d1:9d:dc:81
    UP BROADCAST MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
    Interrupt:16
    brad@brad-laptop:~$ route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.1.0 0.0.0.0 255.255.255.0 U 2 0 0 wlan0
    169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlan0
    0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0

  6. #6
    Join Date
    Jan 2010
    Location
    Lee's Summit, MO
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Wireless Perfect... Wired =Black Hole

    still for some reason the network cables do not connect me to the internet, just wireless... I have tried the stupid stuff like switching network cables and ports on the switch and still nothing.

  7. #7
    Join Date
    Dec 2009
    Location
    Panama City, FL, USA
    Beans
    543
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireless Perfect... Wired =Black Hole

    For starters you don't have an IP address on your eth0 interface. Are you using DHCP or static IP on your network? How are you connected exactly?

  8. #8
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Wireless Perfect... Wired =Black Hole

    Check Network Manager applet - there should be an "auto eth0" or something similar. See if it is set to "Connect automatically".

    Another option would be to try (from a terminal):
    Code:
    sudo dhclient eth0
    Last edited by Iowan; January 19th, 2010 at 10:47 PM. Reason: Oops... forgot the sudo
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  9. #9
    Join Date
    Jan 2010
    Location
    Lee's Summit, MO
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Wireless Perfect... Wired =Black Hole

    I attach through a normal DHCP router. I have one workgroup switch connected to a Wireless Router to a cable modem.

    When I do: dhclient eth0
    I get:

    Internet Systems Consortium DHCP Client v3.1.2
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    can't create /var/lib/dhcp3/dhcpclient.leases: Permission denied
    SIOCSIFADDR: Permission denied
    SIOCSIFFLAGS: Permission denied
    SIOCSIFFLAGS: Permission denied
    Open a socket for LPF: Operation not permitted

  10. #10
    Join Date
    Dec 2009
    Location
    Panama City, FL, USA
    Beans
    543
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Wireless Perfect... Wired =Black Hole

    You have to run dhclient as a superuser. Try:
    Code:
    sudo dhclient eth0

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •