Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Right Alt key doesn't work

  1. #1
    Join Date
    Oct 2007
    Location
    Earth
    Beans
    Hidden!
    Distro
    Ubuntu

    Exclamation Right Alt key doesn't work

    I run "xev" and left alt reads "Alt_L" while right alt reads "ISO_Level3_Shift".

    I tried googling it and found this:

    The culprit is as VF said: in /etc/X11/xorg.conf the option ' Option
    "XkbOptions" "lv3:ralt_switch" ' is written, and it should not be.

    Workaround:
    Edit that file with sudo privileges and put a '#' in front of the line ' Option
    "XkbOptions" "lv3:ralt_switch" '
    Save open documents and restart X (Ctrl+Alt+Backspace)


    That didn't fix it.

    I have a fresh install of Ubuntu Studio 9.10.

    I also tried setting Keyboard Preferences, "Keyboard Layout Options", "Alt/Win key behavior", to "Alt and Meta are on Alt keys"... but that didn't work. So I put it back how it was.

    There is, however, this interesting thing in the keyboard layout options window:

    "Key to choose 3rd level" > "Right Alt" (is check-marked/enabled)

    What the hell is "3rd level"? lol Anyway, I tried disabling it and it automatically re-enabled! (When I re-opened that window it was checked again).

    So how do I get right-alt key to work?

    And what the heck is the reason for it not working anyway? :-p

    I want my "Alt_R" back!

    Thanks!

    EDIT-
    Okay I set keyboard layout options to "right alt never uses 3rd level". My right-alt works now.
    But what the heck is "3rd level"? At the moment it's not enabled. What purpose would anybody have for some "3rd level" function (whatever it is)?
    Last edited by Th3Professor; January 22nd, 2010 at 06:01 AM.

  2. #2
    Join Date
    Oct 2007
    Location
    Earth
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Right Alt key doesn't work

    I run "xev" and left alt reads "Alt_L" while right alt reads "ISO_Level3_Shift".

    I tried googling it and found this:

    The culprit is as VF said: in /etc/X11/xorg.conf the option ' Option
    "XkbOptions" "lv3:ralt_switch" ' is written, and it should not be.

    Workaround:
    Edit that file with sudo privileges and put a '#' in front of the line ' Option
    "XkbOptions" "lv3:ralt_switch" '
    Save open documents and restart X (Ctrl+Alt+Backspace)


    That didn't fix it.

    I have a fresh install of Ubuntu Studio 9.10.

    I also tried setting Keyboard Preferences, "Keyboard Layout Options", "Alt/Win key behavior", to "Alt and Meta are on Alt keys"... but that didn't work. So I put it back how it was.

    There is, however, this interesting thing in the keyboard layout options window:

    "Key to choose 3rd level" > "Right Alt" (is check-marked/enabled)

    What the hell is "3rd level"? lol Anyway, I tried disabling it and it automatically re-enabled! (When I re-opened that window it was checked again).

    So how do I get right-alt key to work?

    And what the heck is the reason for it not working anyway? :-p

    I want my "Alt_R" back!

    Thanks!

    EDIT-
    Okay I set keyboard layout options to "right alt never uses 3rd level". My right-alt works now.
    But what the heck is "3rd level"? At the moment it's not enabled. What purpose would anybody have for some "3rd level" function (whatever it is)?

  3. #3
    Join Date
    Oct 2007
    Location
    Earth
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Right Alt key doesn't work

    what the heck is "3rd level"?

    At the moment it's not enabled.

    What purpose would anybody have for some "3rd level" function (whatever it is)?

  4. #4
    Join Date
    Oct 2007
    Location
    Earth
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Right Alt key doesn't work

    bump!

    Is there a reason 'level 3' or '3rd level' should be re-enabled?

  5. #5
    Join Date
    Feb 2007
    Location
    West Hills CA
    Beans
    9,141
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Right Alt key doesn't work

    I have an ibm thinkpad t43p. It's missing the "windows" key, also known as the Super key or meta key. I added some .Xmodmap commands to change my right_alt key to mimic the Super key. (I was trying to get Gnome-Do to work, and it needs the Super key.)

    Under xev it shows it as ISO_Level3_Shift. Gnome-Do still doesn't come up with Super--Spacebar, so I still have some work to do.

    I don't know what Level3 is, but it looks like you chose a keyboard layout without a "windows" key and it is making the substitution for you. Try changing the keyboard layout and reboot X or logout and log back in to see if that fixes it.

    So basically, I have the opposite problem as you. I have a working Alt_Right and I want to change it to a functioning Level3 key.
    -------------------------------------
    Oooh Shiny: PopularPages

    Unumquodque potest reparantur. Patientia sit virtus.

  6. #6
    Join Date
    Oct 2007
    Location
    Earth
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Right Alt key doesn't work

    Quote Originally Posted by tgalati4 View Post
    I have an ibm thinkpad t43p. It's missing the "windows" key, also known as the Super key or meta key. I added some .Xmodmap commands to change my right_alt key to mimic the Super key. (I was trying to get Gnome-Do to work, and it needs the Super key.)

    Under xev it shows it as ISO_Level3_Shift. Gnome-Do still doesn't come up with Super--Spacebar, so I still have some work to do.

    I don't know what Level3 is, but it looks like you chose a keyboard layout without a "windows" key and it is making the substitution for you. Try changing the keyboard layout and reboot X or logout and log back in to see if that fixes it.

    So basically, I have the opposite problem as you. I have a working Alt_Right and I want to change it to a functioning Level3 key.
    I went with the default/automatic keyboard selection process at install (running 9.10).

    I have a Razer Lycosa keyboard. Any ideas on which keyboard layout I should use in Linux/Ubuntu Studio 9.10 for that keyboard?
    Last edited by Th3Professor; January 25th, 2010 at 06:15 AM. Reason: whoops, i means "Razer", not "Razor".

  7. #7
    Join Date
    Feb 2007
    Location
    West Hills CA
    Beans
    9,141
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Right Alt key doesn't work

    Look in the keyboard settings dialog box. There are several to choose from. Try looking for the Razor brand, or just pick a few generic ones.

    Otherwise, add a few commands to .Xmodmap to remap the key. Search the forums for xmodmap.
    -------------------------------------
    Oooh Shiny: PopularPages

    Unumquodque potest reparantur. Patientia sit virtus.

  8. #8
    Join Date
    Oct 2007
    Location
    Earth
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Right Alt key doesn't work

    No razer or lycosa listings in the keyboard lists for keyboard settings/layouts/etc.

    I googled razer lycosa xmodmap and ...the closest thing that came up in google search was *this* thread. LOL! Google's really updating their search bot things fast these days!

    Anyway, I'm using a generic layout now I think. I don't know why the right-alt wasn't working. It is now but that "3rd level" stuff is totally alien to me.

  9. #9
    Join Date
    Feb 2007
    Location
    West Hills CA
    Beans
    9,141
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Right Alt key doesn't work

    If you spend some time learning the xmodmap bindings, you can program all of your extra.keys. Then publish your key bindings here. At least google will find it.
    -------------------------------------
    Oooh Shiny: PopularPages

    Unumquodque potest reparantur. Patientia sit virtus.

  10. #10
    Join Date
    Aug 2006
    Beans
    9

    Re: Right Alt key doesn't work

    The purpose of a third-level chooser key is to provide another key which acts like a Shift key to give further options. For example, some of us type a lot in Esperanto so we can use the third level key to give accented letters, for instance: g G ĝ Ĝ using G, Shift G, RightAlt G and RightAlt Shift G respectively. The keyboard layout system gives each user the option of which key to use for the third level, and fourth level with the Shift key. I use the LeftWin key rather than RightAlt, which may be more commonly used for this purpose.

    If you don't need a third-level chooser key then deselect it/them using the keyboard layout manager.

    See also: http://ubuntuforums.org/showthread.php?t=914137

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •