Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: ssh tunnel issue 'bind: Cannot assign requested address'

  1. #11
    Join Date
    Jan 2010
    Beans
    11

    Re: ssh tunnel issue 'bind: Cannot assign requested address'

    Forcing ipv4 (-4) seems to work too, so I would think that the issue would be ssh trying to assign the inet6 address to localhost, but running the commands:

    Code:
    ip add show | grep inet6
    Code:
    ip addr show | grep inet6
    don't return anything. Any ideas?

  2. #12
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: ssh tunnel issue 'bind: Cannot assign requested address'

    Have you previously done something to disable IPv6 on your system? 9.10 will configure localhost ipv6 addresses by default, so if they aren't there, my best guess is that IPv6 has been disabled.

    I suggest that you comment out all lines related to IPv6 in /etc/hosts, reboot, and try again without either the IPv6 related work-arounds (i.e. use your original command line). It could be that when you removed the IPv6 localhost entry previously that there was some cache somewhere continuing to screw things up. That seems unlikely, but it's my best guess at the moment.

  3. #13
    Join Date
    Feb 2006
    Beans
    11

    Lightbulb Re: ssh tunnel issue 'bind: Cannot assign requested address'

    Quote Originally Posted by crowds0 View Post
    running the command: "ip addr show | grep inet6" didn't return anything. Any ideas?
    A ha! That's the problem. The loopback device "lo" should be set to ::1.

    Try this,

    Code:
    sudo ip addr add ::1 dev lo
    I'd bet dollars to donuts that ssh tunneling will work after that. Of course, you'll need to figure out where to put that so that it gets set automatically when you boot up. I can tell you how my machine works, but unfortunately it might not help you much. Network Manager always mangles my network, so I disabled it. Instead of nm, I use the following in /etc/network/interfaces,

    Code:
    # The loopback network interface
    auto lo
    iface lo inet loopback
    If you change that file, you can use
    Code:
    sudo ifdown lo
    sudo ifup lo
    to make it take effect without having to reboot. Let us know if that solves the problem.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •