Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: using pspi in gimp - dependancies not met...

  1. #1
    Join Date
    Feb 2009
    Location
    Land of over 15,000 Lakes
    Beans
    122
    Distro
    Ubuntu 10.04 Lucid Lynx

    [SOLVED] using pspi in gimp - dependancies not met...

    The solution is in the second post.

    [original post]
    Hey, just wondering...

    I'm trying to use that photoshop plug-in for gimp. Since it hasn't been updated in ages, there is only an i386 version, but it ought to work under amd64 anyway if all the dependencies are met.

    If there is anyone with a clue how to fix this, I would happily appreciate it. I have to restart my computer every time I want to use the PS plugins, and I couldn't get the plugin working under wine gimp either.

    thanks
    Last edited by Megrimn; February 21st, 2010 at 10:46 PM.
    ~Do Not Be Deceived! This is a signature!~
    ~$sudolife: I don't post junk but then again, I don't update it much, either~
    AXE COP IZ DA BOMB

  2. #2
    Join Date
    Jan 2010
    Beans
    1

    Re: using pspi in gimp - dependancies not met...

    How to install PSPI to work under 64-bit Ubuntu. I am writing these
    instructions on my Jaunty installation, for Gimp 2.6.6.

    Most of the basic instructions can be found here:
    http://www.instructables.com/id/Phot...s_In_The_GIMP/
    but there are a few special instructions for installing pspi on an Ubuntu
    64-bit system.

    There is quite a bit of overlap between the instructions found on the above
    website and the steps outlined below.

    1) Create a directory to save the pspi download, I'll call mine ~/pspi_download

    $ cd
    $ mkdir pspi_download
    $ cd ~/pspi_download

    2) Download pspi (Use your web browser to go to
    http://tml.pp.fi/gimp/pspi.html, and click on the link for
    "Ubuntu 5.10 binary".) Save file gimp-pspi-1.0.5.ubuntu.i386.tar.gz
    in the ~/pspi_download directory you created above.

    3) Unzip it:

    $ gunzip gimp-pspi-1.0.5.ubuntu.i386.tar.gz

    4) Extract the files from the tar:

    $ tar -xfv gimp-pspi-1.0.5.ubuntu.i386.tar

    5) Copy files pspi and pspi.exe.so to your personal Gimp plug-in folder.
    Mine is ~/.gimp-2.6/plug-ins

    $ cp pspi pspi.exe ~/.gimp-2.6/plug-ins

    6) There are 32-bit Gimp files missing that must be installed in order
    for pspi to work.

    To see the files that are missing, use this command:
    $ cd ~/.gimp-2.6/plug-ins
    $ ldd pspi.exe.so | grep not

    You should see the following:

    libgimpui-2.0.so.0 => not found
    libgimpwidgets-2.0.so.0 => not found
    libgimp-2.0.so.0 => not found
    libgimpmath-2.0.so.0 => not found
    libgimpcolor-2.0.so.0 => not found
    libgimpbase-2.0.so.0 => not found

    7) Using a web browser, download the 32-bit .deb package that contains
    these files. You can find the package here:

    http://packages.ubuntu.com/jaunty/i3...mp2.0/download

    8.) Save (don't install) libgimp2.0_2.6.6-0ubuntu1.1_i386.deb to a new
    directory called ~/libgimp_32bit_download

    9) Unpack the files from the .deb package like this:

    $ cd ~/libgimp_32bit_download
    $ mkdir unpack
    $ dpkg-deb -x libgimp2.0_2.6.6-0ubuntu1.1_i386.deb unpack

    10) In the unpack directory, you will find some subdirectories. Go to
    the usr/lib directory:

    $ cd unpack/usr/lib

    11) Change the permissions of all the regular files (not the symbolic links) to
    -rwxr-xr-x (755):

    $ sudo chmod 755 lib*.6

    12) Copy all the files (including links) to /usr/lib32:

    $ sudo cp -d * /usr/lib32

    Note: The -d option tells cp to also copy the symbolic links

    13) Repeat step 6, except this time, you should see NO files listed:

    $ cd ~/.gimp-2.6/plug-ins
    $ ldd pspi.exe.so | grep not

    No files should be listed. If there are any, you did something wrong
    above, so go back and double check.

    14) Run gimp. It should recognize the new pspi plugin. Click on the Filters
    menu. At the bottom, you should see a new menu option, "Photoshop
    Plug-in Settings..."

    15) At this point, pspi is installed properly on your 64-bit Ubuntu machine.
    Follow the rest of the instructions found at
    http://www.instructables.com/id/Phot...s_In_The_GIMP/
    in order to configure and use it. You can start at step 3.

    I hope you find these instructions helpful.
    Last edited by Vince1; January 31st, 2010 at 04:59 AM.

  3. #3
    Join Date
    Oct 2007
    Location
    NC, US
    Beans
    18
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: using pspi in gimp - dependancies not met...

    Vince1, please accept my most heartfelt thanks! I'd already installed PSPI, downloaded the 32-bit package, copied the few missing 32-bit files, verified their subsequent presence, and was feeling like the world's most glaring idiot.

    When I saw no "Xtns" menu, I'd even looked in the "Filters" menu, but had missed the "Photoshop Plug-in Settings..." sub-menu, simply for lack of having scrolled down far enough.

    I hate to even admit that in a public forum, but I do so in hope it'll help someone else, assuming I'm actually NOT the only user on the planet who made the same mistake.

    Even some relatively recent instructional posts in other venues still refer to an "Xtns" menu not present in GIMP 2.6x, which I suppose I'd somehow expected PSPI to create

  4. #4
    Join Date
    Feb 2009
    Location
    Land of over 15,000 Lakes
    Beans
    122
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: using pspi in gimp - dependancies not met...

    Thanks. This totally helped!
    ~Do Not Be Deceived! This is a signature!~
    ~$sudolife: I don't post junk but then again, I don't update it much, either~
    AXE COP IZ DA BOMB

  5. #5
    Join Date
    Jan 2010
    Beans
    1

    Re: using pspi in gimp - dependancies not met...

    thanks, it worked.
    tho, i cannot install a plugin I need, Portraiture.
    The plugin appears and I can select it but nothing happens.
    I need to install it but I don't know how. I will look into this more tho

  6. #6
    Join Date
    Apr 2007
    Location
    Pensacola, FL
    Beans
    160
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: using pspi in gimp - dependancies not met...

    I love you! I changed a few steps in the process(I didn't use the terminal to copy/paste and unpack) But it works! Thanks a lot, now I can take my photos to the next level.

  7. #7
    Join Date
    Nov 2009
    Beans
    3

    Re: using pspi in gimp - dependancies not met...

    Hi, i've followed the whole guide and have the FRACTALIUS photoshop plug-in installed correctly in GIMP. I can open my photo and the plug-in and preview all of the presets perfectly modified, but when I click on apply it closes the plug-in and all I can see is the original photo without the effect applied. What might have gone wrong? I am using ubuntu 10.04 amd 64 on a presario v5000, with GIMP 2.6.8

    Thanks in advance for any advice,

    Duncan

    p.s. sometimes I get this error after a minute :

    El complemento ha fallado: «pspi» <- plug-in has failed
    (/home/duncan/.gimp-2.6/plug-ins/pspi)

  8. #8
    Join Date
    Feb 2009
    Location
    Land of over 15,000 Lakes
    Beans
    122
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: using pspi in gimp - dependancies not met...

    Quote Originally Posted by sounddunk View Post
    Hi, i've followed the whole guide and have the FRACTALIUS photoshop plug-in installed correctly in GIMP. I can open my photo and the plug-in and preview all of the presets perfectly modified, but when I click on apply it closes the plug-in and all I can see is the original photo without the effect applied. What might have gone wrong? I am using ubuntu 10.04 amd 64 on a presario v5000, with GIMP 2.6.8

    Thanks in advance for any advice,

    Duncan

    p.s. sometimes I get this error after a minute :

    El complemento ha fallado: «pspi» <- plug-in has failed
    (/home/duncan/.gimp-2.6/plug-ins/pspi)
    Yes, I get this too, but there is a workaround.

    After hitting 'apply' in fractalius, go to the 'filters' menu and select 'Repeat "Fractalius"'. The keyboard shortcut is ctrl+F. It will now do what you originally asked it to do. This works for some other plugins that cause this problem as well.
    ~Do Not Be Deceived! This is a signature!~
    ~$sudolife: I don't post junk but then again, I don't update it much, either~
    AXE COP IZ DA BOMB

  9. #9
    Join Date
    Nov 2009
    Beans
    3

    Re: using pspi in gimp - dependancies not met...

    thanks a lot! got it working and it looks great!
    duncan

  10. #10
    Join Date
    May 2006
    Location
    México, D.F.
    Beans
    17
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: using pspi in gimp - dependancies not met...

    Thank you very much, Vince1. You're the man!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •