Results 1 to 6 of 6

Thread: mounting a shared NAS (cifs) drive (and using latex)

  1. #1
    Join Date
    Nov 2009
    Beans
    1

    Question mounting a shared NAS (cifs) drive (and using latex)

    I am encountering some weird problems when mounting a shared NAS drive (and using Latex (and subversion)).

    First it was quite a hassle to mount the drive and have read write permissions as a user. I figured out that the probably correct way of doing it in /etc/fstab is:

    Code:
    //server/share /home/me/folder cifs user,noauto,username=#,password=#,domain=# 0 0
    user so that I can mount the drive as user and don't have to use sudo. (If I used sudo, all files would be owned by root and would not have read write access as a user.)

    noauto because auto won't work since the network connection is not established when the mounting is done while booting.

    So then I can do mount folder and voila everything works. I am listed as the owner of all files, although I am not, but I guess that is because the share is on a windows machine. I have access to the folders that I am supposed to have access to and everything works fine, except:

    Code:
    $ latex foo.tex
    This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
     %&-line parsing enabled.
    entering extended mode
    ! I can't find file `foo.tex'.
    <*> Please type another input file name:
    The file is definitely there though, e.g.

    Code:
    $ cat foo.tex | latex
    will work fine.

    (Also, svnadmin create will not work. But this might be a problem with Berkeley DB, which is not supposed to be used on a shared drive.)

    Any ideas what I might be doing wrong here?

  2. #2
    Join Date
    Feb 2007
    Beans
    13

    Re: mounting a shared NAS (cifs) drive (and using latex)

    I don't know of a solution, but I am also experiencing this problem with a cifs mounted network drive.

    As for now, I have to work on a local disk when using latex, which breaks up my workflow pretty badly.

    texi2pdf foo.tex
    Results in:

    This is pdfTeXk, Version 3.141592-1.40.3 (Web2C 7.5.6)
    file:line:error style messages enabled.
    %&-line parsing enabled.
    entering extended mode
    LaTeX2e <2005/12/01>
    Babel <v3.8h> and hyphenation patterns for english, usenglishmax, dumylang, noh
    yphenation, polish, swedish, loaded.
    ! I can't find file `./foo.tex'.
    <*> ...3 \let~\normaltilde \input ./foo.tex
    I would also be interested in a solution.

  3. #3
    Join Date
    Jun 2010
    Beans
    6

    Re: mounting a shared NAS (cifs) drive (and using latex)

    I have the same problem here, no solution yet

  4. #4
    Join Date
    Mar 2009
    Beans
    3

    Re: mounting a shared NAS (cifs) drive (and using latex)

    I had similar problems and found that adding the options
    nobrl and noserverino to the mount line fixed the problem.
    Thus I am now using the follow mount command

    Code:
    sudo mount -t cifs -ousername=<server_user_name>,uid=<local_user_id>,gid=<local_group>,file_mode=0777,dir_mode=0777,nobrl,noserverino //server/path /mounts/localmountpoint

    Visit
    http://tug.org/pipermail/tex-k/2010-June/002183.html
    and
    http://www.tug.org/pipermail/tex-liv...ch/025026.html

    The solution was given in the thread

    http://www.openoffice.org/issues/show_bug.cgi?id=104974

    Scroll down to the comments posted on
    Mon Dec 14 07:46:55 +0000 2009

  5. #5
    Join Date
    Jun 2010
    Beans
    6

    Talking Re: mounting a shared NAS (cifs) drive (and using latex)

    Quote Originally Posted by rmbzz View Post
    I had similar problems and found that adding the options
    nobrl and noserverino to the mount line fixed the problem.
    It works! thank you very much!!!!

  6. #6
    Join Date
    Aug 2006
    Location
    Portugal
    Beans
    43
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: mounting a shared NAS (cifs) drive (and using latex)

    Thanks rmbzz!

    Adding nobrl and noserverino to the mount options solves my problem though just partially. If I generate a dvi, i.e. running
    Code:
    latex foo.tex
    everything works fine. But if I try to generate a pdf,
    Code:
    latex -output-format=pdf foo.tex
    or
    Code:
    pdflatex foo.tex
    I get the following error:
    Code:
    !pdfTeX error: latex: getcwd() failed (No such file or directory), path too lon
    g?
     ==> Fatal error occurred, no output PDF file produced!
    As it says it's a getcwd() error which I can solve only by removing the noserverino, but then I get back into the
    Code:
    ! I can't find file `foo.tex'.
    error reported by steple.

    Thus I'm in a loop. Any ideia to get me out of this?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •