Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Login screen defaults to secondary monitor

  1. #1
    Join Date
    Oct 2008
    Location
    Cambridge, MA
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Login screen defaults to secondary monitor

    I have a dual monitor setup with the primary on the left and the secondary on the right. When the login screen comes up after a reboot for instance, the login options such as user selection are on the secondary (right) monitor. How can I change this? Thanks.

  2. #2
    Join Date
    Dec 2008
    Location
    Manchester, NH
    Beans
    384
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Login screen defaults to secondary monitor

    I've seen the same thing happen with my friends laptop. His solution is to plug in after login.

    That might not make sense with a desktop set-up though
    Laptops: S76 Panp5, HP tc4400
    Other: numerous old desktops/laptops running ubuntu or puppy linux

  3. #3
    Join Date
    Mar 2008
    Location
    Liverpool, United Kingdom
    Beans
    1,664
    Distro
    Ubuntu 14.04 Trusty Tahr

    Wink Re: Login screen defaults to secondary monitor

    Quote Originally Posted by protargol View Post
    I have a dual monitor setup with the primary on the left and the secondary on the right. When the login screen comes up after a reboot for instance, the login options such as user selection are on the secondary (right) monitor. How can I change this? Thanks.
    You'll need to do this as root, so follow these instructions.

    1 - Paste this command into terminal: gksudo nvidia-settings

    2 - Click on X Server Display Configuration

    3 - Click on the monitor that you wish to make the main monitor

    4 - Check the box stating Make This The Primary Display For The X Screen

    5 - Click Apply

    6 - Click Save To X Configuration File & press Quit

    You have now set the login screen to appear on your desired monitor, this will be your main monitor, to change it, just follow the instructions again but this time choosing the other monitor.

  4. #4
    Join Date
    Dec 2008
    Location
    Manchester, NH
    Beans
    384
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Login screen defaults to secondary monitor

    Quote Originally Posted by scouser73 View Post
    1 - Paste this command into terminal: gksudo nvidia-settings
    Would that only be if you are using the nvidia driver?
    Laptops: S76 Panp5, HP tc4400
    Other: numerous old desktops/laptops running ubuntu or puppy linux

  5. #5
    Join Date
    Dec 2009
    Beans
    1

    Re: Login screen defaults to secondary monitor

    Hi scouser73.
    Actually I have the same problem.
    And the other problem is 6 - Click Save To X Configuration File. When I did this, the system informs me that failed to parse existing X config files..........
    Could you help me with this?
    Thanks a lot

  6. #6
    Join Date
    Mar 2008
    Location
    Liverpool, United Kingdom
    Beans
    1,664
    Distro
    Ubuntu 14.04 Trusty Tahr

    Wink Re: Login screen defaults to secondary monitor

    Quote Originally Posted by shiwen1984 View Post
    Hi scouser73.
    Actually I have the same problem.
    And the other problem is 6 - Click Save To X Configuration File. When I did this, the system informs me that failed to parse existing X config files..........
    Could you help me with this?
    Thanks a lot
    Paste these commands into Terminal to create a new Xorg.conf, that should now have created a new xconfig file.

    The first step creates a backup of your currently working xorg.conf file.
    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak


    Step 2 runs the NVIDIA utility to generate a new xorg.conf file that the utility can actually read.
    sudo nvidia-xconfig


    Step 3 runs the graphical NVIDIA setup tool as root, so you can actually save your changes.
    sudo nvidia-settings


    If this does not work then after step 1, do sudo rm /etc/X11/xorg.conf to delete your current xorg.conf file. Then run sudo nvidia-xconfig and sudo nvidia-settings.
    Last edited by scouser73; January 12th, 2010 at 12:43 PM.

  7. #7
    Join Date
    Mar 2008
    Location
    Liverpool, United Kingdom
    Beans
    1,664
    Distro
    Ubuntu 14.04 Trusty Tahr

    Wink Re: Login screen defaults to secondary monitor

    Quote Originally Posted by miniyak View Post
    Would that only be if you are using the nvidia driver?
    Yes, that command is for use with nVidia graphics cards only.

  8. #8
    Join Date
    Jan 2010
    Beans
    1
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Login screen defaults to secondary monitor

    Is there any fixes for Intel onboard cards?
    Trying to run multiple monitors on a HP6930p and it's giving me the same problem.

  9. #9
    Join Date
    Dec 2008
    Location
    Manchester, NH
    Beans
    384
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Login screen defaults to secondary monitor

    scouser73's suggestion may work well for me and my panp5 (her nvidia card doest want to properly do dual screens either) but where ive seen this exact problem was on a dell laptop w/ onboard intel stuff

    seems that ubuntu prioritizes the monitor of the highest vertical resolution as the main monitor for some odd reason, some how changing all the settings you wanted on start-up.
    Laptops: S76 Panp5, HP tc4400
    Other: numerous old desktops/laptops running ubuntu or puppy linux

  10. #10
    Join Date
    Oct 2008
    Location
    Cambridge, MA
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Login screen defaults to secondary monitor

    I'm not sure what's not working, but it treats the left monitor as the default (shows all Ubuntu boot images and text), then switches to the right monitor for login, and then back to left monitor for further Ubuntu initialization. I'm thinking it's not an xorg.conf issue. I could post what my xorg.conf file looks like, but I think the issue is elsewhere

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •