Results 1 to 3 of 3

Thread: XBox not displaying albums correctly from Fuppes

Hybrid View

  1. #1
    Join Date
    Jan 2010
    Location
    North Yorkshire, UK
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    XBox not displaying albums correctly from Fuppes

    Hi,

    Sorry if I'm asking stupid questions. I've been through the forums, and can't seem to find the answers. Thanks to EVERYONE who has posted fuppes related advice though, you've filled my last 3 days with so much fun! I'm a complete newbie with linux. I had a half hearted fiddle about 6 years ago, but nothing since. But I've decided I want rid of the horror that is Windows, and stumbled upon Ubuntu. Installled it last week. First priority, videos and music to the XBox (can't lose Microsoft!). I'm using Ubuntu 9.10.

    So, after much, much, much reinstalling and playing with config files, I now have Fuppes streaming to my XBox. I can stream both audio and video, and I'm even happy with the folder structure in the Video section too! (Eventually! ).

    I now have two problems:

    1) When rebuilding the database, I get:

    Code:
    TagLib: MPEG::Header::parse() -- Invalid sample rate.
    TagLib: MPEG::Header::parse() -- Invalid sample rate.
    TagLib: MPEG::Properties::read() -- Page headers were invalid.
    Segmentation fault
    The line before is repeated lots and lots of times before it gives up. However, it still seems to have created the database, because all I then have to do is start Fuppes up and rebuild the folder structure and it works.

    2) I spent ages trawling through the forums to get this far, and I did get music sorted by artist, album, etc. However, when sorted by album, each album shows lots of times. Is there a way to stop this? I only want each album to show once. Seems to mainly affect compilation albums with multiple artists.

    Thanks in advance to anyone that can help me.

    For anyone who hasn't got as far as me, persist! You'll get there eventually. I'll attach my fuppes.cfg and vfolder.cfg. I am using version 0.660, and used a mixture of advice from all the tutorials to get here. Use this guide: http://ubuntuforums.org/showthread.php?t=1310511 , but later on in that guide in someone's reply, there's a link to the new version.

    I also had to install some additional packages (this was guess work...using Synaptic Package Manager), to ensure that during the ./configure, the Taglib and mpeg4ip/mp4v2 are both enabled, otherwise you have no hope of your XBox sorting your music.

    Oh, and if you edit your config files in the fuppes directory, open a terminal and run the following to put them in the place fuppes actually looks for them!:

    Code:
    sudo cp fuppes/fuppes.cfg .fuppes
    sudo cp fuppes/vfolder.cfg .fuppes
    Persevere and Good Luck!

    fuppes.cfg:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <fuppes_config version="0.7.2.3">
      <shared_objects>
        <!--<dir>/mnt/music</dir>-->
        <!--<itunes>/Users/.../iTunes.xml</itunes>-->
        <dir>/media/1EDF-3D38/Video</dir>
        <dir>/media/1EDF-3D38/Music</dir>
      </shared_objects>
      <network>
        <!--empty = automatic detection-->
        <interface>eth0</interface>
        <!--empty or 0 = random port-->
        <http_port>9137</http_port>
        <!--list of ip addresses allowed to access fuppes. if empty all ips are allowed-->
        <allowed_ips>
          <!--<ip>192.168.0.1</ip>-->
          <ip></ip>
        </allowed_ips>
      </network>
      <content_directory>
        <!--a list of possible charsets can be found under:
          http://www.gnu.org/software/libiconv/-->
        <local_charset>UTF-8</local_charset>
        <!--libs used for metadata extraction when building the database. [true|false]-->
        <use_imagemagick>true</use_imagemagick>
        <use_taglib>true</use_taglib>
        <use_libavformat>true</use_libavformat>
      </content_directory>
      <transcoding>
        <!--[lame|twolame]-->
        <audio_encoder>lame</audio_encoder>
        <!--[true|false]-->
        <transcode_vorbis>true</transcode_vorbis>
        <transcode_musepack>true</transcode_musepack>
        <transcode_flac>true</transcode_flac>
      </transcoding>
      <device_settings>
        <!--"default" settings are inhertied by specific devices and can be overwritten-->
        <device name="default">
          <!--specify the maximum length for file names (0 or empty = unlimited)-->
          <max_file_name_length>0</max_file_name_length>
          <!--[file|container]-->
          <playlist_style>file</playlist_style>
          <show_childcount_in_title>false</show_childcount_in_title>
          <enable_dlna>false</enable_dlna>
          <transcoding_release_delay>4</transcoding_release_delay>
          <file_settings>
            <!--audio files-->
            <file ext="mp3">
              <type>AUDIO_ITEM</type>
              <mime_type>audio/mpeg</mime_type>
              <dlna>MP3</dlna>
            </file>
            <file ext="ogg">
              <type>AUDIO_ITEM</type>
              <mime_type>application/octet-stream</mime_type>
              <transcode enabled="true">
                <ext>mp3</ext>
                <mime_type>audio/mpeg</mime_type>
                <dlna>MP3</dlna>
                <http_encoding>chunked</http_encoding>
                <decoder>vorbis</decoder>
                <encoder>lame</encoder>
                <bitrate>192</bitrate>
                <samplerate>44100</samplerate>
              </transcode>
            </file>
            <file ext="mpc">
              <type>AUDIO_ITEM</type>
              <mime_type>application/octet-stream</mime_type>
              <transcode enabled="true">
                <ext>mp3</ext>
                <mime_type>audio/mpeg</mime_type>
                <dlna>MP3</dlna>
                <http_encoding>chunked</http_encoding>
                <decoder>musepack</decoder>
                <encoder>lame</encoder>
                <bitrate>192</bitrate>
                <samplerate>44100</samplerate>
              </transcode>
            </file>
            <file ext="wav">
              <type>AUDIO_ITEM</type>
              <mime_type>audio/x-wav</mime_type>
            </file>
            <file ext="flac">
              <type>AUDIO_ITEM</type>
              <mime_type>audio/x-flac</mime_type>
              <transcode enabled="true">
                <ext>mp3</ext>
                <mime_type>audio/mpeg</mime_type>
                <dlna>MP3</dlna>
                <http_encoding>chunked</http_encoding>
                <decoder>flac</decoder>
                <encoder>lame</encoder>
                <bitrate>192</bitrate>
                <samplerate>44100</samplerate>
              </transcode>
            </file>
            <file ext="wma">
              <type>AUDIO_ITEM</type>
              <mime_type>audio/x-ms-wma</mime_type>
              <dlna>WMAFULL</dlna>
            </file>
            <!--image files-->
            <file ext="jpg">
              <ext>jpeg</ext>
              <type>IMAGE_ITEM</type>
              <mime_type>image/jpeg</mime_type>
              <convert enabled="false">
                <!--<dcraw enabled="true">-q 0</dcraw>-->
                <ext>png</ext>
                <mime_type>image/png</mime_type>
                <height>0</height>
                <width>0</width>
                <!--set "greater" to "true" if you only want to resize images greater than "height" or "width"-->
                <greater>false</greater>
                <!--set "less" to "true" if you only want to resize images less than "height" or "width"-->
                <less>false</less>
                <!--set "less" and "greater" to "false" if you always want to resize-->
              </convert>
            </file>
            <file ext="bmp">
              <type>IMAGE_ITEM</type>
              <mime_type>image/bmp</mime_type>
            </file>
            <file ext="png">
              <type>IMAGE_ITEM</type>
              <mime_type>image/png</mime_type>
            </file>
            <file ext="gif">
              <type>IMAGE_ITEM</type>
              <mime_type>image/gif</mime_type>
            </file>
            <!--video files-->
            <file ext="mpg">
              <ext>mpeg</ext>
              <type>VIDEO_ITEM</type>
              <mime_type>video/mpeg</mime_type>
            </file>
            <file ext="mp4">
              <type>VIDEO_ITEM</type>
              <mime_type>video/mp4</mime_type>
            </file>
            <file ext="avi">
              <type>VIDEO_ITEM</type>
              <mime_type>video/avi</mime_type>
            </file>
            <file ext="wmv">
              <type>VIDEO_ITEM</type>
              <mime_type>video/x-ms-wmv</mime_type>
            </file>
            <file ext="vob">
              <type>VIDEO_ITEM</type>
              <mime_type>video/x-ms-vob</mime_type>
            </file>
            <file ext="vdr">
              <type>VIDEO_ITEM</type>
              <mime_type>video/x-extension-vdr</mime_type>
              <transcode enabled="true">
                <ext>vob</ext>
                <mime_type>video/x-ms-vob</mime_type>
              </transcode>
            </file>
            <file ext="flv">
              <type>VIDEO_ITEM</type>
              <mime_type>application/x-flash-video</mime_type>
            </file>
            <file ext="asf">
              <type>VIDEO_ITEM</type>
              <mime_type>video/x-ms-asf</mime_type>
            </file>
            <!--playlists-->
            <file ext="pls">
              <type>PLAYLIST</type>
              <mime_type>audio/x-scpls</mime_type>
            </file>
            <file ext="m3u">
              <type>PLAYLIST</type>
              <mime_type>audio/x-mpegurl</mime_type>
            </file>
          </file_settings>
        </device>
        <!--If you have more than one device it is a good idea to set the ip address manually as some devices may have conflicting "user agents".-->
        <device name="PS3" enabled="false">
          <user_agent>UPnP/1.0 DLNADOC/1.00</user_agent>
          <user_agent>PLAYSTATION3</user_agent>
          <!--<ip></ip>-->
          <enable_dlna>true</enable_dlna>
          <transcoding_release_delay>50</transcoding_release_delay>
          <file_settings>
            <file ext="ogg">
              <type>AUDIO_ITEM_MUSIC_TRACK</type>
              <transcode enabled="true">
                <http_encoding>stream</http_encoding>
              </transcode>
            </file>
          </file_settings>
        </device>
        <device name="Xbox 360" virtual="Xbox 360" enabled="true">
    
    <description_values> 
    <friendly_name>%s %v : 1 : Windows Media Connect</friendly_name> 
    <model_name>Windows Media Connect compatible (%s)</model_name> 
    <model_number>2.0</model_number> 
    </description_values> 
    
          <user_agent>Xbox/2.0.\d+.\d+ UPnP/1.0 Xbox/2.0.\d+.\d+</user_agent>
          <user_agent>Xenon</user_agent>
          <xbox360>true</xbox360>
           <file_settings>
                <file ext="mp3"><type>AUDIO_ITEM_MUSIC_TRACK</type></file>
                <file ext="jpg"><type>IMAGE_ITEM_PHOTO</type></file>
                <file ext="avi"><type>VIDEO_ITEM</type><mime_type>video/avi</mime_type></file>
           </file_settings>
    
        </device>
        <device name="Noxon audio" virtual="default" enabled="false">
          <!--Please enter the address of your Noxon. Automatic detection is impossible because the Noxon does not send a "user-agent" in it's requests-->
          <!--<ip></ip>-->
          <playlist_style>container</playlist_style>
          <show_childcount_in_title>true</show_childcount_in_title>
        </device>
        <device name="Telegent TG 100" virtual="default" enabled="false">
          <user_agent>dma/1.0 \(http://www.cybertan.com.tw/\)</user_agent>
          <user_agent>UPnP/1.0 DLNADOC/1.00</user_agent>
          <playlist_style>file</playlist_style>
          <max_file_name_length>101</max_file_name_length>
        </device>
      </device_settings>
    </fuppes_config>
    vfolder.cfg:

    Code:
    <?xml version="1.0" encoding="UTF-8"?>
    <fuppes_vfolder_config version="0.2">
    
     <vfolder_layout device="default" enabled="false">
    
        <vfolder name="Genre">
          <vfolders property="genre">
            <items type="audioItem" />
          </vfolders>
        </vfolder>
    
        <vfolder name="Genre/Artists">
          <vfolders property="genre">
            <vfolders property="artist">
              <items type="audioItem" />
            </vfolders>
          </vfolders>
        </vfolder>
    
        <vfolder name="Artists/Albums">
          <vfolders property="artist">
            <vfolders property="album">
              <items type="audioItem" />
            </vfolders>
          </vfolders>
        </vfolder> 
        
        <vfolder name="ABC/Artists/Albums">
          <vfolders split="ABC">
            <vfolders property="artist">
              <vfolders property="album">
                <items type="audioItem" />
              </vfolders>
            </vfolders>
          </vfolders>
        </vfolder>
           
        <vfolder name="Photos">
          <vfolder name="All">
            <items type="imageItem" />
          </vfolder>
          <vfolder name="Folders">
            <folders filter="contains(imageItem)" />
          </vfolder>      
        </vfolder>
    
        <vfolder name="Videos">
          <vfolder name="All">
            <items type="videoItem" />
          </vfolder>
          <vfolder name="Folders">
            <folders filter="contains(videoItem)" />
          </vfolder>
        </vfolder>
        
        <vfolder name="shared dirs">
          <shared_dirs full_extend="true" />
        </vfolder>
        
      </vfolder_layout>
    
      <vfolder_layout device="Xbox 360" enabled="true" create_references="true" create_container_details="true">
    
        <vfolder name="Music" id="1">
          <vfolder name="Album" id="7">
            <vfolders property="album" type="container.album.musicAlbum">
              <items type="audioItem" />
            </vfolders>
          </vfolder>
                
          <vfolder name="All Music" id="4">
            <items type="audioItem" />
          </vfolder>
          
          <vfolder name="Artist" id="6">
            <vfolders property="artist" type="container.person.musicArtist">
              <items type="audioItem" />
            </vfolders>
          </vfolder>
          
          <vfolder name="Folders" id="20">
            <folders filter="contains(audioItem)" />
          </vfolder>
          
          <vfolder name="Genre" id="5">
            <vfolders property="genre" type="container.genre.musicGenre">
              <items type="audioItem" />
            </vfolders>
          </vfolder>
          
          <vfolder name="Playlist" id="15" />
        </vfolder>
       
        <vfolder name="Pictures" id="3">
          <vfolder name="Album" id="13" />
          
          <vfolder name="All Pictures" id="11">
            <items type="imageItem" />
          </vfolder>
          
          <vfolder name="Date Taken" id="12" />
          
          <vfolder name="Folders" id="22">
            <folders filter="contains(imageItem)" />
          </vfolder>
        </vfolder>
    
        <vfolder name="Playlists" id="18">
          <vfolder name="All Playlists" id="19" />
          <vfolder name="Folders" id="23" />
        </vfolder>
    
        <vfolder name="Video" id="2">
          <vfolder name="Actor" id="10">
            <folders filter="contains(videoItem)" />
          </vfolder>
          <vfolder name="Album" id="14" />
          <vfolder name="All Video" id="8">
        <items type="videoItem" />
        </vfolder>
         <vfolder name="Folders" id="21" />
         <vfolder name="Genre" id="9" />
       </vfolder>
       <vfolder name="Browse Folders" id="21">  
    <shared_dirs full_extend="true" />  
    </vfolder>
    
      </vfolder_layout>
    
    </fuppes_vfolder_config>
    Thanks for reading, hope this helps, or you can help me!

    Nick.

  2. #2
    Join Date
    Jan 2010
    Location
    North Yorkshire, UK
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: XBox not displaying albums correctly from Fuppes

    anyone?

  3. #3
    Join Date
    Jun 2012
    Beans
    1

    Re: XBox not displaying albums correctly from Fuppes

    ... I did get music sorted by artist, album, etc. However, when sorted by album, each album shows lots of times. Is there a way to stop this? I only want each album to show once. Seems to mainly affect compilation albums with multiple artists.
    I am having the same issue using 0.692. Were you able to solve this ? I read that you need to disable virtual containers completely, but that seems a bit drastic, no?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •