Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: ubuntu error initiating conversation with authentication system

  1. #1
    Join Date
    Jan 2010
    Beans
    1
    Distro
    Ubuntu 9.10 Karmic Koala

    ubuntu error initiating conversation with authentication system

    I got this ERROR shortly after trying to eliminate the need to enter my keyring for the network applet. This ("error initiating conversation with authentication system") at the login screen. I want to note some things.
    -Im running 64 bit 9.10 Ubuntu
    -I used (@include common-pamkeyring)
    -I disabled the autologin option prior to restarting my desktop
    -I could not log back in through graphical interface.
    So at this point what I did was this.
    Restart
    Held "Esc"
    Entered the root shell
    And entered this command: sudo nano /etc/pam.d/gdm

    I deleted the line(@include common-pamkeyring)

    Hit "F3" to save

    Hit "F2" to exit

    Ran command: sudo reboot

    Now I was able to login regularly through the graphical interface.

    HOPE THIS HELPS THOSE WHO FIND THEMSELVES AT THESE ODDS.

    My Question is, Is there any way I can stop having to enter my keyring without going through this again with 9.10 Ubuntu??? HELP PLZ

  2. #2
    Join Date
    Aug 2009
    Beans
    1

    Re: ubuntu error initiating conversation with authentication system

    I had this same error with the same conditions: pam, network manager keyring access, using Karmic Netbook Remix.

    Thanks for posting a solution!

    Regarding the Network Manager asking for keyring on autologin: I bypassed the issue of needing the keyring this way (for a wireless connection):

    Open Network Connections
    Select which connection you are using (wired/wireless, etc.)
    at the bottom of the first tab is a checkbox to make the connection "Available to all Users".

    This made network manager stop asking for access to the keyring on login (auto or manual).

    Nik

  3. #3
    Join Date
    Feb 2010
    Beans
    1

    Re: ubuntu error initiating conversation with authentication system

    Thx... you've saved me a lot of time reinstalling.

  4. #4
    Join Date
    Mar 2010
    Beans
    39

    Re: ubuntu error initiating conversation with authentication system

    Thanks Gionani7 and toomanyplugs! I thought I was really stuck there

  5. #5
    Join Date
    May 2008
    Beans
    161

    Re: ubuntu error initiating conversation with authentication system

    You are my hero this morning. Ran updates at home (Lucid 10.4), booted at work and was locked out of my system. As an Ubuntu evangelist, it's really bad if I have to cry for help and this was a major problem. Solved in seconds, THANK YOU!
    Last edited by windfix; May 6th, 2010 at 07:38 PM.

  6. #6
    Join Date
    May 2010
    Beans
    1

    Re: ubuntu error initiating conversation with authentication system

    Thank you guys so much. HUGE help!

  7. #7
    Join Date
    May 2010
    Beans
    5

    Re: ubuntu error initiating conversation with authentication system

    Yes, thank you! It worked for me too!

  8. #8
    Join Date
    Aug 2010
    Beans
    1
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: ubuntu error initiating conversation with authentication system

    I have this same error message coming up, but I never used the @include common-pamkeyring command in the /etc/pam.d/gdm file. Wondering if anyone knows of something else that can cause this error to come up. If it is of any help, I am currently running ubuntu 10.04 dual booting with win7.

  9. #9
    Join Date
    Jun 2008
    Beans
    39

    Re: ubuntu error initiating conversation with authentication system

    I am having the same problem, except holding the ESC key does nothing for me. How can I get into a command prompt before the login screen?

  10. #10
    Join Date
    Jan 2007
    Location
    Chicago, IL
    Beans
    15
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: ubuntu error initiating conversation with authentication system

    Pressing ctrl+alt+F1 should get you to the command prompt. To get back to the GUI press ctrl+alt+F7. You can actually use F1-F6 to get to a different prompt.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •