Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 41

Thread: [SOLVED]Increase monitor resolution

  1. #11
    Join Date
    Dec 2009
    Beans
    9

    Re: [SOLVED]Increase monitor resolution

    Edit the gdm default file:

    Code:
    sudo gedit /etc/gdm/Init/Default
    Look at the end of the file for:
    Code:
          fi
        fi
      fi
    fi
    
    exit 0
    Add the touch command:
    Code:
          fi
        fi
      fi
    fi
    
    touch /var/tmp/testgdm
    
    exit 0
    Reboot your computer and look for the /var/tmp/testgdm if it exist:
    Code:
    ls -alg /var/tmp/testgdm
    If the file doesn't exist, then the gdm default is not executed, meaning the code you have added from the first post is also not executed.

    Pls note this is to verify the file /etc/gdm/Init/Default is executed, so the coded provided in the first post is also executed.

  2. #12
    Join Date
    Oct 2009
    Location
    UK
    Beans
    67
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question Re: [SOLVED]Increase monitor resolution

    OK now we are making progress. File does not exist! Now what? Thank you

  3. #13
    Join Date
    Dec 2009
    Beans
    9

    Re: [SOLVED]Increase monitor resolution

    In fact, we're back to square one. What all that means is the proposed solution to add the xrandr command in /etc/gdm/Init/Default doesn't work. It doesnt mean the xrandr is not the right solution (it is), but the gdm did not get executed, so the added commands never got executed.

    I'm not expert enough on how the gdm (gnome login system) works to provide you with a valid solution, but you may do the trick by adding the xrandr commands in an executable script that gets started after your login. This is not elegant, but may work.

    To create a script file:

    Code:
    sudo gedit /usr/local/bin/increase_resolution.sh
    then add to your file:
    Code:
    #!/bin/bash
    
    xrandr --newmode "1024x768"   70.00  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
    
    xrandr --addmode VGA1 1024x768_60.00
    
    xrandr --output VGA1 --mode 1024x768
    ensure you follow post 1 to define the exact xrandr command.

    Then change the file to executable
    Code:
    sudo chmod +x /usr/local/bin/increase_resolution.sh
    and you can execute to get the resolution changed.
    You may add the script to the applications that starts with your session.

  4. #14
    Join Date
    May 2009
    Location
    Sri Lanka
    Beans
    31
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: [SOLVED]Increase monitor resolution

    yep!! guys wizel is correct, if step 6 is not working for you guys ,for some strange reason, just use a script as wizel has suggested and make it run at startup.
    Thats what i did initially it works, but when you log in your resolution get changed and it just..... see for you selves.

    go to

    preferences >> startup applications -> add
    and add the script to the startup.remember to make it executabe.Right click the script file and go to permissions and check the make it executable box.

  5. #15
    Join Date
    Oct 2009
    Location
    UK
    Beans
    67
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED]Increase monitor resolution

    I did a bit more digging and (via Synaptoc) reinstalled gnome-session. A cold restart later 1024x768 is back up and running. Not sure which combination of steps worked but THANKS!

  6. #16
    Join Date
    Dec 2009
    Beans
    9

    Re: [SOLVED]Increase monitor resolution

    I'm glad you've solved the issue. The gnome.session (the gdm part) was clearly broken as proved by the touch command.

    For documentation purposes only, could you pls see if the /etc/gdm/Init/Default contais the xrandr commands by running:
    Code:
    grep xrandr /etc/gdm/Init/Default

  7. #17
    Join Date
    Oct 2009
    Location
    UK
    Beans
    67
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED]Increase monitor resolution

    This output does make reference to 1024x768. Thanks!

  8. #18
    Join Date
    Dec 2009
    Beans
    9

    Re: [SOLVED]Increase monitor resolution

    OK, so probably gmd was broken.

  9. #19
    Join Date
    Dec 2009
    Location
    Illinois USA
    Beans
    136
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: [SOLVED]Increase monitor resolution

    Wizel,
    I seek your wize counsel!

    My results are a "no go" on Sharag's method and so far the same with the "script".

    I do not know how to do the correct steps after the 1st Sudo and the ad-hoc gedit comes up. From that point what is the play-by-play? What all goes into "terminal" just the 2 sudo's? I have my own data for the 4 lines:
    #!/bin/bash
    xrandr ............
    xrandr...............
    xrandr................

    Does the 4 lines above only go in the ad-hoc gedit or also in the terminal?

    The 2 nd sudo goes only in the terminal? In "startup applications" I have never gotten the choice to "make the 4 lines of script from the ad-hoc gedit, executable" after pasting into the "Startup Applications menu".
    <br><br>Sure could use some counsel from anyone?!
    Last edited by Tourdog; January 15th, 2010 at 07:08 PM.
    Tourdog:
    HP 1630 Pavilion desktop, AMD64, 2 gigs, 250 gig hd, Nvidia Gforce 6150Le, Tried Knoppix, Netbook Remix and 9.10 Karmic Koala. Now it is Lucid Lynx 10.04 LTS as solo OS.

  10. #20
    Join Date
    Dec 2009
    Location
    Illinois USA
    Beans
    136
    Distro
    Ubuntu 10.04 Lucid Lynx

    Smile Re: [SOLVED]Increase monitor resolution

    I finally solved the problem by using a script in "Startup Apps" by pointing to the xorg.config. It works very well..................... finally I have 1280 x 1024 at each boot-up automatically (my monitor is a flat 19")

    Thanks!
    Tourdog:
    HP 1630 Pavilion desktop, AMD64, 2 gigs, 250 gig hd, Nvidia Gforce 6150Le, Tried Knoppix, Netbook Remix and 9.10 Karmic Koala. Now it is Lucid Lynx 10.04 LTS as solo OS.

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •