Hi,
I was able to resolve the error with this scenario (combined from different replies on different forums)

sudo apt-get autoremove
sudo apt-get install lsb-core
./GoogleEarthLinux.bin --target /tmp/ge
cd /tmp/ge/setup.data/bin/Linux/x86/
sudo mv setup.gtk2 setup.gtk2.bkup
sudo mv setup.gtk setup.gtk2
cd /tmp/ge
./setup.sh

and I am ignore ipv6

I tried different things, the crucial was installation of lsb-core