Results 1 to 6 of 6

Thread: How to force 'Do Nothing' for 'When Lid is Closed'

  1. #1
    Join Date
    Jan 2005
    Beans
    3

    How to force 'Do Nothing' for 'When Lid is Closed'

    Hi,

    I am running Ubuntu Desktop 9.10 on a my laptop and sometimes I have an external monitor connected. When that is the case, I want to close the lid. But if I do, the laptop suspend. I don't want that and there is no option for this in 9.10 under power management. In 9.04, there were separate configurations for when on AC or Battery, and there was an option 'Do Nothing' when lid is close.

    Can someone please tell me how to accomplish this without the 'Power Management' utility?

    If there are Ubuntu developers here, please restore the separate configurations as it was in 9.04.

    Thanks.

    .v

  2. #2
    Join Date
    Jul 2006
    Location
    Sweden
    Beans
    52
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How to force 'Do Nothing' for 'When Lid is Closed'

    Did you find any solution for this? I'm having the same problem. I would like to put my laptop away when I'm at my desk and use external screen, keyboard and mouse. But at the moment, as soon as I close the lid, my external screen goes black.

  3. #3
    Join Date
    Feb 2009
    Beans
    3

    Re: How to force 'Do Nothing' for 'When Lid is Closed'

    This option was hidden. Here's how you can set it:

    Code:
    #$ gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_ac "nothing"
    Reference: https://bugs.launchpad.net/ubuntu/+s...er/+bug/416236

  4. #4
    Join Date
    Aug 2011
    Beans
    2

    Talking Re: How to force 'Do Nothing' for 'When Lid is Closed'

    Quote Originally Posted by xantus View Post
    This option was hidden. Here's how you can set it:

    Code:
    #$ gconftool-2 --type string --set /apps/gnome-power-manager/buttons/lid_ac "nothing"
    Reference: https://bugs.launchpad.net/ubuntu/+s...er/+bug/416236
    heeyyy thanks.it works good.

  5. #5
    Join Date
    Jun 2010
    Location
    Berlin, Germany
    Beans
    10
    Distro
    Ubuntu 10.04 Lucid Lynx

    Question Re: How to force 'Do Nothing' for 'When Lid is Closed'

    It doesn't work for me. I have an integrated Intel graphic chipset and an external monitor connected using a DisplayPort cable.

    I did set When laptop lid is closed: do nothing, but it ignores this setting and both displays go off.

    I could not even switch off the laptop monitor using the Monitor Preferences, both monitors would go off, but using Xrandr works:

    Code:
    xrandr --output LVDS1 --off
    This switches off the laptop monitor. But I can not close the lid. Why is the "do nothing" setting ignored?
    Last edited by hamoid; November 18th, 2011 at 11:59 AM. Reason: Mistake in the sample code

  6. #6
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    Re: How to force 'Do Nothing' for 'When Lid is Closed'

    Quote Originally Posted by hamoid View Post
    It doesn't work for me. I have an integrated Intel graphic chipset and an external monitor connected using a DisplayPort cable.

    I did set When laptop lid is closed: do nothing, but it ignores this setting and both displays go off.

    I could not even switch off the laptop monitor using the Monitor Preferences, both monitors would go off, but using Xrandr works:

    Code:
    xrandr --output LVDS1 --off
    This switches off the laptop monitor. But I can not close the lid. Why is the "do nothing" setting ignored?
    the same happens here with oneiric and using an external monitor.. if I close the lid of the laptop the external monitor goes blank even if I've selected to do "nothing" from dconf.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •