Results 1 to 6 of 6

Thread: sleep/suspend workes once - after that immediate wakeup

Hybrid View

  1. #1
    Join Date
    Jul 2009
    Beans
    4

    sleep/suspend workes once - after that immediate wakeup

    I have a new install of 64-bit karmic (Gnome and KDE), dualbooting with XP on a desktop with the ASUS M3N78-EM Mobo.

    My problem, is that I can suspend to RAM only once. The first time everything works just fine, the computer suspends, and starts nicely from the power button. But if I try to suspend a second time (without a reboot or hibernate in between), the computer first seems to suspend, but then immediately wakes itself up again. After this I can continue to work normally, but suspend continues to wake itself up, whenever I try it.

    my /proc/acpi/wakeup shows everything as disabled (no poweron in there).

    Here is my pm-suspend.log with an immediate awake, in case it's of any help.
    Attached Files Attached Files

  2. #2
    Join Date
    Jul 2005
    Beans
    82

    Re: sleep/suspend workes once - after that immediate wakeup

    I don't know why it works, but add the following to the end of your kernel line in /boot/grub/menu.lst

    Code:
    usbcore.autosuspend=-1

    Source: http://xbmc.org/forum/showthread.php?&t=60127&page=6

  3. #3
    Join Date
    Jul 2009
    Beans
    4

    Re: sleep/suspend workes once - after that immediate wakeup

    Thank You!

    That seems to solve it. Although your solution was for the old grub. With a fresh Karmic, I have grub 2 and had to do the following

    1.
    add "usbcore.autosuspend=-1" to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub
    2.
    run sudo update-grub
    3.
    reboot

    After that I have suspend working as many times i like. Can anyone tell me what kind of averse effects disabling the usb autosuspend will have on my system, if any?

    Marking this as solved.

  4. #4
    Join Date
    Jul 2005
    Beans
    82

    Re: sleep/suspend workes once - after that immediate wakeup

    I do not think there are any adverse effects associated with this setting. I actually spent a good portion of the day searching for why usbcore.autosuspend causes the machine to wake up immediately.

    The only thing I could come up with is that autosuspend tries to suspend a USB device only to have the USB device "wake up" after the computer was in standby. This would cause the system to resume because of the USB wakeup. I have no idea if that is the reason, but it is my best guess.

    This link talks about usbcore.autosuspend: http://lwn.net/Articles/253587/

    Also, adding the line
    Code:
    options usbcore.autosuspend=-1
    to /etc/modprobe.d/options is a method to disable without messing with your bootloader.

  5. #5
    Join Date
    Jul 2009
    Beans
    4

    Re: sleep/suspend workes once - after that immediate wakeup

    Again, that does not work on my system.

    Without being sure at all, I think this has to do with which kernel you are running. If I have understood what I have read correctly, some older kernels run usbcore as a module (modprobe.d/options is the place), whereas the newer kernels (2.6.30 upwards???) has it in the kernel itself?

  6. #6
    Join Date
    May 2007
    Beans
    75
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: sleep/suspend workes once - after that immediate wakeup

    thanks so much for this solution.
    Is this a motherboard/bios bug?

    Could I've debugged this myself, because I spent way too much time into this and feel very stupid.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •