Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Turn off TouchPad completely

  1. #11
    Join Date
    Mar 2009
    Location
    Gongyi, Henan, China
    Beans
    29
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Turn off TouchPad completely

    Hi Zeezam,

    That's really weird! As for bash-aliases vs. bash_aliases, I think it's just a suggested name ... you can name the file whatever you want as long as it matches up to the if/fi statments in .bashrc. Here's mine:

    Code:
    # Alias definitions.
    # You may want to put all your additions into a separate file like
    # ~/.bash_aliases, instead of adding them here directly.
    # See /usr/share/doc/bash-doc/examples in the bash-doc package.
    
    #
    if [ -f ~/.bash-aliases ]; then
        . ~/.bash-aliases
    fi
    It's strange how it doesn't work, though. One thing I thought of is maybe the aliases in the .bashrc are uncommented. Right under the above bit of code there are several alias commands in an if/fi statement, then a couple more by themselves. In my .bashrc they are all commented ... is this the case with you, too?

    Can you create on-the-fly aliases? For example can you use the alias command in a terminal prompt? That is, can you enter one of the alias commands into the terminal and have it work for that session?

    I'm afraid I am no Linux guru (obviously ), and this is the limit of my ability to help you ... hope it works, and if not, I hope someone with a greater geekitude than will descend upon this thread!
    Go Canucks Go!

  2. #12
    Join Date
    May 2008
    Beans
    105

    Re: Turn off TouchPad completely

    Quote Originally Posted by turvyc View Post
    Hi Zeezam,

    That's really weird! As for bash-aliases vs. bash_aliases, I think it's just a suggested name ... you can name the file whatever you want as long as it matches up to the if/fi statments in .bashrc. Here's mine:

    Code:
    # Alias definitions.
    # You may want to put all your additions into a separate file like
    # ~/.bash_aliases, instead of adding them here directly.
    # See /usr/share/doc/bash-doc/examples in the bash-doc package.
    
    #
    if [ -f ~/.bash-aliases ]; then
        . ~/.bash-aliases
    fi
    It's strange how it doesn't work, though. One thing I thought of is maybe the aliases in the .bashrc are uncommented. Right under the above bit of code there are several alias commands in an if/fi statement, then a couple more by themselves. In my .bashrc they are all commented ... is this the case with you, too?

    Can you create on-the-fly aliases? For example can you use the alias command in a terminal prompt? That is, can you enter one of the alias commands into the terminal and have it work for that session?

    I'm afraid I am no Linux guru (obviously ), and this is the limit of my ability to help you ... hope it works, and if not, I hope someone with a greater geekitude than will descend upon this thread!
    I created the aliases in .bashrc instead.
    After I ran source .bashrc and it worked. Maybe it works with .bash-aliases if I run source .bashrc before a try to run the alias...

  3. #13
    Join Date
    Jan 2010
    Location
    Dade City Florida
    Beans
    59
    Distro
    Ubuntu Development Release

    Re: Turn off TouchPad completely

    I have a similar problem. The "Touchpad" tab is not present on my machine which is a dm3-1039wm and has an ALPS unlike the original poster, I want to use my touchpad but get frustrated by how as I type the cusor jumps, and I have to start all over again. Any suggestions as to how to get this tab to show up?

  4. #14
    Join Date
    Mar 2009
    Location
    Gongyi, Henan, China
    Beans
    29
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Turn off TouchPad completely

    Hello Bluefoxox,

    I just did a quick search, and this post had an idea that worked for another guy.

    Essentially, edit your xorg.conf, using these commands:

    Code:
    # First back up the original:
    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.my.backup
    # Now open it for editing:
    sudo gedit /etc/X11/xorg.conf
    Now add the line <Option "SHMConfig" "on">, so it looks like this:

    Code:
    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizScrollDelta" "0"
    Option "SHMConfig" "on"
    EndSection
    Now, I realize that this example says it's for a Synaptics pad, but the original poster had an alps touchpad, and he claimed this method worked.

    Anyways, with this option enabled, you can install syndaemon if it's not on your computer already. This disables your touchpad only when you're typing. For the full list you can just type <syndaemon -h>. Myself, I have it in my startup applications, with these args:

    Code:
    syndaemon -S -t -d -i 1
    -S forces it to Synclient (lets it run), -t disables only tapping and scrolling (not movement), -d starts it as a daemon, -i is the length of time disabled in seconds.

    Hope this works for you!
    Go Canucks Go!

  5. #15
    Join Date
    Oct 2007
    Beans
    8
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Turn off TouchPad completely

    Quote Originally Posted by wrsh1983 View Post
    I use hp dm3 1030us, and I have the same problem with you (the button on the top of touchpad does not work). However, you can disable touchpad by using command:

    sudo rmmod psmouse

    and enable it with

    sudo modprobe psmouse
    You my friend...are my new most favorite person in the world (for a few minutes). That was bugging the hell out of me.

    Thank you much.

    Edit:

    A quick note. This route only allows for it to be turned off from the terminal...meaning every time you reboot you have to do it again.

    If you want a permanent way to turn off the touchpad you can use the black list feature.

    http://ubuntuforums.org/showthread.php?t=166624

    so type:
    sudo su
    echo blacklist psmouse >> /etc/modprobe.d/blacklist-custom.conf

    This creates a custom blacklist file that runs on boot and shots off the internal mouse (or the touchpad in this case).
    Worked for me.
    Last edited by meesekiller; February 3rd, 2010 at 05:13 AM. Reason: More info.

  6. #16
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,724
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Turn off TouchPad completely

    just install g pointing devices settings in synaptic then tweak it as you like under applications-other-pointing devices the jumping around cursor was driving me nuts

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •