Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Acecad USB Tablet with bad karma in Karmic

  1. #1
    Join Date
    Apr 2007
    Beans
    461
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Question Acecad USB Tablet with bad karma in Karmic

    Hi,

    I wanted to use an old Dynalink FreeDraw tablet with stylus and I remember it working in Gutsy (or before?). Now, with a fresh install of Karmic, when I plug in the tablet it does get recognized and I am able to control the mouse position with it but no clicking let alone drawing with pressure sensitivity in Gimp for instance

    I notice xinput --list (see below) shows "Acecad USB Tablet" but with "Type is TOUCHPAD". That used to be "Type is TABLET"...

    Is there any way to make Karmic use the tablet (with usb_acecad driver) as a tablet and not as a touchpad?

    Thanks for any tips!

    Code:
    ~$ xinput --list
    "Virtual core pointer"	id=0	[XPointer]
    	Num_buttons is 32
    	Num_axes is 2
    	Mode is Relative
    	Motion_buffer is 256
    	Axis 0 :
    		Min_value is -1
    		Max_value is -1
    		Resolution is 0
    	Axis 1 :
    		Min_value is -1
    		Max_value is -1
    		Resolution is 0
    "Virtual core keyboard"	id=1	[XKeyboard]
    	Num_keys is 248
    	Min_keycode is 8
    	Max_keycode is 255
    "SynPS/2 Synaptics TouchPad"	id=2	[XExtensionPointer]
    	Type is TOUCHPAD
    	Num_buttons is 12
    	Num_axes is 2
    	Mode is Relative
    	Motion_buffer is 256
    	Axis 0 :
    		Min_value is 1472
    		Max_value is 5472
    		Resolution is 1
    	Axis 1 :
    		Min_value is 1408
    		Max_value is 4448
    		Resolution is 1
    "Acecad USB Tablet"	id=3	[XExtensionPointer]
    	Type is TOUCHPAD
    	Num_buttons is 5
    	Num_axes is 3
    	Mode is Absolute
    	Motion_buffer is 256
    	Axis 0 :
    		Min_value is 0
    		Max_value is 5000
    		Resolution is 10000
    	Axis 1 :
    		Min_value is 0
    		Max_value is 3750
    		Resolution is 10000
    	Axis 2 :
    		Min_value is 0
    		Max_value is 512
    		Resolution is 10000
    "Power Button"	id=4	[XExtensionKeyboard]
    	Type is KEYBOARD
    	Num_keys is 248
    	Min_keycode is 8
    	Max_keycode is 255
    "Sleep Button"	id=5	[XExtensionKeyboard]
    	Type is KEYBOARD
    	Num_keys is 248
    	Min_keycode is 8
    	Max_keycode is 255
    "AT Translated Set 2 keyboard"	id=6	[XExtensionKeyboard]
    	Type is KEYBOARD
    	Num_keys is 248
    	Min_keycode is 8
    	Max_keycode is 255
    "Macintosh mouse button emulation"	id=7	[XExtensionPointer]
    	Type is MOUSE
    	Num_buttons is 5
    	Num_axes is 2
    	Mode is Relative
    	Motion_buffer is 256
    	Axis 0 :
    		Min_value is -1
    		Max_value is -1
    		Resolution is 1
    	Axis 1 :
    		Min_value is -1
    		Max_value is -1
    		Resolution is 1
    Code:
    ~$ dmesg | grep usb
    [    0.172669] usbcore: registered new interface driver usbfs
    [    0.172689] usbcore: registered new interface driver hub
    [    0.172721] usbcore: registered new device driver usb
    [    0.690109] usb usb1: configuration #1 chosen from 1 choice
    [    0.752085] usb usb2: configuration #1 chosen from 1 choice
    [    0.812091] usb usb3: configuration #1 chosen from 1 choice
    [    1.290219] usb 2-1: new low speed USB device using ohci_hcd and address 2
    [    1.537164] usb 2-1: configuration #1 chosen from 1 choice
    [    1.547792] usbcore: registered new interface driver hiddev
    [    1.547859] usbcore: registered new interface driver usbhid
    [    1.547864] usbhid: v2.6:USB HID core driver
    [   18.337987] input: Acecad USB Tablet as /devices/pci0000:00/0000:00:1c.0/usb2/2-1/2-1:1.0/input/input5
    [   18.338089] usbcore: registered new interface driver usb_acecad
    And related excerpt from /var/log/Xorg.0.log :
    Code:
    (II) config/hal: Adding input device Acecad USB Tablet
    (II) LoadModule: "evdev"
    (II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
    (II) Module evdev: vendor="X.Org Foundation"
    	compiled for 1.6.4, module version = 2.2.5
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 4.0
    (**) Acecad USB Tablet: always reports core events
    (**) Acecad USB Tablet: Device: "/dev/input/event5"
    (II) Acecad USB Tablet: Found 3 mouse buttons
    (II) Acecad USB Tablet: Found x and y absolute axes
    (II) Acecad USB Tablet: Found absolute touchpad
    (II) Acecad USB Tablet: Configuring as touchpad
    (**) Acecad USB Tablet: YAxisMapping: buttons 4 and 5
    (**) Acecad USB Tablet: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
    (II) XINPUT: Adding extended input device "Acecad USB Tablet" (type: TOUCHPAD)
    (**) Acecad USB Tablet: (accel) keeping acceleration scheme 1
    (**) Acecad USB Tablet: (accel) filter chain progression: 2.00
    (**) Acecad USB Tablet: (accel) filter stage 0: 20.00 ms
    (**) Acecad USB Tablet: (accel) set acceleration profile 0
    (II) Acecad USB Tablet: initialized for absolute axes.

  2. #2
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Acecad USB Tablet with bad karma in Karmic

    Hi RavanH,

    It may be doable. It sounds like you've installed the Acecad USB Tablet driver. Is that what it's called? Is the usb kernel driver for the Acecad drivers called usb_acecad.ko? Do you see it in:
    Code:
    lsmod
    or
    Code:
    lsmod | grep usb_acecad
    If so then you just need a .fdi to attach the Acecad X11 driver to the tablet. Right now the evdev driver is grabbing it:
    (II) config/hal: Adding input device Acecad USB Tablet
    (II) LoadModule: "evdev"
    (II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
    and configuring it as a touchpad. We'd need to look at your lshal:
    Code:
    lshal>lshal.txt

  3. #3
    Join Date
    Apr 2007
    Beans
    461
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acecad USB Tablet with bad karma in Karmic

    Quote Originally Posted by Favux View Post
    Hi RavanH,

    It may be doable. It sounds like you've installed the Acecad USB Tablet driver. Is that what it's called? Is the usb kernel driver for the Acecad drivers called usb_acecad.ko? Do you see it in:
    Code:
    lsmod
    or
    Code:
    lsmod | grep usb_acecad
    No, lsmod | grep usb_acecad returns nothing... The funny thing is that dmesg reports:
    Code:
    [   18.337987] input: Acecad USB Tablet as /devices/pci0000:00/0000:00:1c.0/usb2/2-1/2-1:1.0/input/input5
    [   18.338089] usbcore: registered new interface driver usb_acecad
    So I suppose it is indeed the usb_acecad driver that is being used...

    Quote Originally Posted by Favux View Post
    If so then you just need a .fdi to attach the Acecad X11 driver to the tablet. Right now the evdev driver is grabbing it:

    and configuring it as a touchpad. We'd need to look at your lshal:
    Code:
    lshal>lshal.txt
    So I found that this created a text file lshal.txt in my home folder (sorry, I am not an expert Linux user)... I'll try and find all related sections and paste them here.

    I really appreciate your help, thanks

  4. #4
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Acecad USB Tablet with bad karma in Karmic

    Hi RavanH,

    Right, the text file is what we want. If you right click on it you can compress it with Create Archive. Then using Managing Attachments you can attach it to your post.

  5. #5
    Join Date
    Apr 2007
    Beans
    461
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acecad USB Tablet with bad karma in Karmic

    Quote Originally Posted by Favux View Post
    Hi RavanH,

    Right, the text file is what we want. If you right click on it you can compress it with Create Archive. Then using Managing Attachments you can attach it to your post.
    Haha, I never noticed that paper-clip before! See attached archive for complete file...
    Attached Files Attached Files

  6. #6
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Acecad USB Tablet with bad karma in Karmic

    Hi RavanH,

    Great! OK, I'll look lshal over. Do you happen to have the old xorg.conf where you set up the Acecad? That would be very helpful.

    And what did you do to install the driver(s)?

  7. #7
    Join Date
    Apr 2007
    Beans
    461
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acecad USB Tablet with bad karma in Karmic

    Quote Originally Posted by Favux View Post
    Hi RavanH,

    Great! OK, I'll look lshal over. Do you happen to have the old xorg.conf where you set up the Acecad? That would be very helpful.

    And what did you do to install the driver(s)?
    No, sorry, I do not have that anymore. However, I have been testing with setting the tablet up by creating a xorg.conf in Karmic and using the acecad driver after installing xserver-xorg-input-acecad in Synaptic. It seems to work (it is recognized as a tablet and I can click and drag and even set it up in Gimp for pressure sensitiveness) but it feels jumpy and nervous. Also, then there are two devices configured: one using the usb_acecad driver and the other the acecad driver. I really would like to use the kernel/evdev/hal one if that could be made to work.

    Here is what I tested with in xorg.conf:
    Code:
    Section "InputDevice"
        Identifier     "Acecad USB Tablet"
        Driver         "acecad"
        Option         "Device" "auto-dev"
    EndSection
    
    Section "ServerLayout"
        Identifier     "Simple Layout"
        InputDevice    "Acecad USB Tablet" "SendCoreEvents"
    EndSection

  8. #8
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Acecad USB Tablet with bad karma in Karmic

    Hi RavanH,

    OK, return the xorg.conf to pristine Karmic fresh install condition. Remove anything you added for Acecad (or comment (#) it out) including probably the "ServerLayout".

    Let's try this and see where it gets us:
    Code:
    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
    
    <deviceinfo version="0.2">
      <device>
        <match key="input.originating_device" contains="if0">
          <match key="info.product" contains="Acecad">
            <merge key="input.x11_driver" type="string">acecad</merge>
            <merge key="input.x11_options.Type" type="string">stylus</merge>
            <merge key="info.product" type="string">stylus</merge>
          </match>
        </match>
      </device>
    </deviceinfo>
    Add the entire above contents to the .fdi file you create with:
    Code:
    gksudo gedit /etc/hal/fdi/policy/10-acecad.fdi
    Save, Close, and reboot.

    What other features do you have. Buttons on the stylus? Eraser on the stylus? Buttons on the tablet? etc. And do you remember how you set them up in xorg.conf?

  9. #9
    Join Date
    Apr 2007
    Beans
    461
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Acecad USB Tablet with bad karma in Karmic

    Quote Originally Posted by Favux View Post
    Hi RavanH,

    OK, return the xorg.conf to pristine Karmic fresh install condition. Remove anything you added for Acecad (or comment (#) it out) including probably the "ServerLayout".
    I already did that to revert to the automatic usb_acecad setup by hal. I had also removed the xserver-xorg-input-acecad package again, so that is probably why...
    Quote Originally Posted by Favux View Post
    Code:
    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
    
    <deviceinfo version="0.2">
      <device>
        <match key="input.originating_device" contains="if0">
          <match key="info.product" contains="Acecad">
            <merge key="input.x11_driver" type="string">acecad</merge>
            <merge key="input.x11_options.Type" type="string">stylus</merge>
            <merge key="info.product" type="string">stylus</merge>
          </match>
        </match>
      </device>
    </deviceinfo>
    Add the entire above contents to the .fdi file you create with:
    Code:
    gksudo gedit /etc/hal/fdi/policy/10-acecad.fdi
    Save, Close, and reboot.
    ...did not work straight away. After re-installing the acecad package, it did indeed give a result somewhat similar to the xorg.conf method. Only without use of one of the two buttons on the stylus. But with the nervousness and jumpy mousepointer handling. Is there a way to use the usb_acecad (kernel?) driver because I like the way that one seems to get me much more subtle control over the mouse pointer...

    Quote Originally Posted by Favux View Post
    What other features do you have. Buttons on the stylus? Eraser on the stylus? Buttons on the tablet? etc. And do you remember how you set them up in xorg.conf?
    No buttons on the tablet but two buttons (plus a sensitive point of-course) on the stylus. And an eraser? Is that not just assigning eraser function to a button?

    With the above content for 10-acecad.fdi, the stylus works and the tip corresponds with left-mous-click. And the top button on the stylus corresponds with a right-mouse-click. I haven't tested pressure sensitivity in Gimp yet.

    Have to go now but will be back within 24 hours to report further tests. Again, thanks for helping me out!

  10. #10
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Acecad USB Tablet with bad karma in Karmic

    Hi RavanH,

    Outstanding! It sounds like the .fdi worked. You're right, xserver-xorg-input-acecad needs to be installed. I'm assuming you tried the tablet after installing that and the stylus didn't work. In other words the package didn't install an acecad.fdi. Otherwise having two .fdi's might be a problem.

    We probably should look at:
    Code:
    xinput --list
    and
    Code:
    Xorg.0.log
    and also
    Code:
    lshal>lshal2.txt
    But with the nervousness and jumpy mousepointer handling.
    That could be due to a low battery. Does the stylus take a battery? It could be a bad usb cable. Also make sure it's firmly plugged in on both ends. It could be a bad usb port on the computer end. Also plug it in direct, not through a hub, while you're setting up.

    Some drivers let you change the surpress level on the data the stylus is reporting, which could smooth it out. Is there a manual for acecad?:
    Code:
    man acecad
    That would be helpful to look at. We could also try one at a time and/or some combination of:
    Code:
          <merge key="input.x11_options.USB" type="string">on</merge>
          <merge key="input.x11_options.Mode" type="string">absolute</merge>
          <merge key="input.x11_options.SendCoreEvents" type="string">true </merge>
    Which is why a man would be helpful.

    Some styli like the Wacom ones have a eraser-like button on the back of the stylus. It depresses into the barrel of the stylus and also gives pressure in Gimp so you can smudge.

    The stylus buttons depend on the driver so we could try adding to the .fdi:
    Code:
    <merge key="input.x11_options.Button2" type="string">2</merge>
    <merge key="input.x11_options.Button3" type="string">3</merge>
    Is there a way to use the usb_acecad (kernel?) driver because I like the way that one seems to get me much more subtle control over the mouse pointer...
    I'm not sure what you're saying. There must be one active since your tablet is active, presumably from the acecad package. Does it show up in lsmod? If not it could be directly in the kernel in the usb-hid part. Did I miss something and you had a tablet specific kernel driver at one point?

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •