Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: OpenGL: ChoosePixelFormat failed

  1. #11
    Join Date
    Aug 2011
    Beans
    14

    Re: OpenGL: ChoosePixelFormat failed

    thanks a lot! it worked! ujuuu!

  2. #12
    Join Date
    Oct 2010
    Beans
    17

    Re: OpenGL: ChoosePixelFormat failed

    Quote Originally Posted by noriegafam View Post
    This post is a little old but I decided to add some input to it since it might help some else trying to run Sketchup7 on Karmic Koala 9.10.

    It is always better to download the last version of wine from their site since the Ubuntu repository is a little outdated.

    The version wine version that is working for me is 1.1.43.

    The fix is real simple:

    Fix:
    Open your wine menu and open the C drive (/home/user/.Wine)
    Open the Windows Folder
    Find Regedit.exe and run it with Wine
    Find: HKEY_CURRENT_USER\Software\Google\SketchUp6\GLConf ig\Display
    There are three entries - Look at the bottom one, name 'HW_OK"
    Double click it and change the data from a 0 to a 1
    Run Sketchup7

    that should do it. I read some postings mentioning problems with black screens, which are related to compiz; in that case just disable compiz.

    I hope this can help someone. I've been trying get Sketchup running for the longest time, I finally got it working with this little trick.

    good luck

    Can I just add that this solution also works for SU8 on Linux Mint 12 with Wine 1.3.28.

    many thanks

  3. #13
    Join Date
    Dec 2008
    Beans
    4

    Re: OpenGL: ChoosePixelFormat failed

    A thousand thanks for this tip. Worked like a charm. I am running Wine 1.4 on lubuntu 12.04, with SketchUp 8.

  4. #14
    Join Date
    Jun 2010
    Location
    Poznan, Poland
    Beans
    1
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: OpenGL: ChoosePixelFormat failed

    Thank you noriegafam. I used your advice with Wine 1.4 and Sketchup 8.0.
    It works!

  5. #15
    Join Date
    Oct 2008
    Beans
    19

    Re: OpenGL: ChoosePixelFormat failed

    Worked for me, too, thanks! In case you need everything spelled out (like I did), here's how to run regedit.exe from terminal.

    Code:
    cd ~/.wine/drive_c/windows
    wine regedit.exe

  6. #16
    Join Date
    Jun 2009
    Location
    Moca, Puerto Rico
    Beans
    3
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: OpenGL: ChoosePixelFormat failed

    Thanks!!

    FYI to all, im running:
    Wine 1.4.1
    Google Sketchup 8
    Ubuntu 12.10

  7. #17
    Join Date
    Jul 2011
    Beans
    3

    Re: OpenGL: ChoosePixelFormat failed

    Thank you. Much appreciated.
    This worked for me as well.
    I am using Ubuntu version 12.04
    Wine 1.5
    Sketchup 8
    Amd 64 bit processor.

  8. #18
    Join Date
    Feb 2011
    Beans
    15

    Re: OpenGL: ChoosePixelFormat failed

    Hello everyone!

    I know this is digging up an old thread, but I'm having the same problem as the OP, but can not seem to get through the fix, and I'm hoping someone here will be able to help me. To summarise, I am trying to install and run Google SketchUp 8 under Wine (not sure the Wine version) on my HP ProBook 4430s laptop with a Intel HD Graphics 3000 GPU and Ubuntu 13.04 64 bit. I have SketchUp installed, and it launches, but when I try to use SketchUp it fails and gives the error, "SketchUp was unable to initialize OpenGL....." I'm trying to follow the fix posted here, but when I run the regedit.exe file I cannot find a directory called "Google" under \HKEY_CURRENT_USER\Software, so I can go no further. Can someone help me with this please?

    Thank you for your help!

    -Elaphe

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •