Results 1 to 7 of 7

Thread: gmpc: Could not grab multimedia key

  1. #1
    Join Date
    Nov 2006
    Beans
    22

    gmpc: Could not grab multimedia key

    Hello,

    I'm using GMPC as a front-end for mpd.

    I'm running Ubuntu 9.10, and when I start gmpc,
    I get the error:

    Could not grab multimedia key:
    PlayPause: XF86AudioPlay
    Ensure that your window manager (or other applications)
    have not already bound this key for some other function, then
    restart gmpc.

    I'm using the Microsoft Natural Ergonomic keyboard 4000,
    and it has a "Play/Pause" button at the top. I looked
    under the "System -> Preferences -> Keyboard/Mouse" settings,
    and the Keyboard model says "Microsoft Natural".

    It appears that some other application has grabbed the XF86AudioPlay, and the gmpc is complaining about it.

    Has anyone had this problem? I can re-map the gmpc settings, but I'd like to know if there's a better fix for this problem --
    maybe I could find the program that is stealing the XF86Play buttons?

    Thanks,
    --Nate

  2. #2
    Join Date
    Mar 2007
    Beans
    5
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: gmpc: Could not grab multimedia key

    Hi, I have the same problem. Dont know what to do. With Sonata (other mpd client) the keys work.

  3. #3
    Join Date
    Jan 2005
    Beans
    47

    Re: gmpc: Could not grab multimedia key

    add the gmpc-mmkeys plugin and disable gmpc's bindings..

    This will make gmpc use gnome's keybinding thingy.

  4. #4
    Join Date
    Mar 2007
    Beans
    5
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: gmpc: Could not grab multimedia key

    Quote Originally Posted by qball View Post
    add the gmpc-mmkeys plugin and disable gmpc's bindings..

    This will make gmpc use gnome's keybinding thingy.
    thank you, that worked for me! =)

  5. #5
    Join Date
    Nov 2005
    Location
    Ester, AK, USA
    Beans
    162
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gmpc: Could not grab multimedia key

    Quote Originally Posted by qball View Post
    add the gmpc-mmkeys plugin and disable gmpc's bindings..
    How do I do these?

    UPDATE: OK, to disable gmpc's bindings, edit ~/.gmpc/gmpc.cfg, navigate to the KEYBINDINGS section and change all keybindings to "0" (zero). I still can't find the gmpc-mmkeys plugin, but perhaps it's somehow hidden in the raft of plugins I installed when I installed gmpc. At any rate, I no longer get the startup error.
    Last edited by David Valentine; March 13th, 2010 at 07:19 AM. Reason: update
    If you torture data hard enough, they will confess to anything

  6. #6
    Join Date
    Apr 2008
    Beans
    131

    Re: gmpc: Could not grab multimedia key

    Quote Originally Posted by David Valentine View Post
    How do I do these?

    UPDATE: OK, to disable gmpc's bindings, edit ~/.gmpc/gmpc.cfg, navigate to the KEYBINDINGS section and change all keybindings to "0" (zero). I still can't find the gmpc-mmkeys plugin, but perhaps it's somehow hidden in the raft of plugins I installed when I installed gmpc. At any rate, I no longer get the startup error.

    i already had it at 0s and i can't find the gmpc-mmkeys plugin, any help?

    UPDATE: i found the package in this repo https://launchpad.net/~gmpc-trunk/+archive/ppa
    Last edited by Elcid247; March 18th, 2010 at 07:00 PM.

  7. #7
    Join Date
    Aug 2010
    Beans
    2

    Smile Re: gmpc / gmpc-mmkeys now is in the Ubuntu package gmpc-plugins

    No need to use an external PPA for this: gmpc-mmkeys is already in gmpc-plugins - at least in Ubuntu 11.04. I still get the error message on gmpc startup, but the XF86AudioPlay key now works!
    (make sure the "Gnome multimedia keys plugin" is enabled by clicking "plugins:" in the gmpc preferences).

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •