Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

  1. #11
    Join Date
    Mar 2009
    Beans
    5

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    Yeah, very same problem for me. I used to mount the NTFS partition without a single problem until this morning. Now I start getting the "Authentication required" pop up.

  2. #12
    Join Date
    Feb 2010
    Beans
    2
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    I checked if PolicyKit Authentication Agent on and it was on.

    There should be another reason. Anyone solved this problem yet?

    In System --> Preferences --> Startup Applications I had been disabling some of programs. It turns out that you need the PolicyKit Authentication Agent enabled. This allowed me to mount the drives that I didn't have access to before. I didn't realize that I needed that for drives located on the main system. Once enabled it allowed me to authenticate and mount the drives.

  3. #13
    Join Date
    Feb 2010
    Beans
    2
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    Finally found the way to fix this problem.

    Do the following



    Got this info from : http://rayslinux.blogspot.com/2009/1...-to-mount.html


    Use Terminal and:

    sudo gedit /usr/share/polkit-1/actions/org.freedesktop.devicekit.disks.policy

    Find the id:
    org.freedesktop.devicekit.disks.filesystem-mount-system-internal

    Look for the line:
    'allow_active'auth_admin_keep'/allow_active'
    and replace it with:
    'allow_active'yes'/allow_active'
    Sorry the < character is being interpreted by blogger so it has been changed to '

    And save!


    Have fun!

  4. #14
    Join Date
    Apr 2007
    Location
    Denmark
    Beans
    134
    Distro
    Ubuntu Development Release

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    Quote Originally Posted by brokenleg View Post
    Finally found the way to fix this problem.

    Do the following



    Got this info from : http://rayslinux.blogspot.com/2009/1...-to-mount.html


    Use Terminal and:

    sudo gedit /usr/share/polkit-1/actions/org.freedesktop.devicekit.disks.policy

    Find the id:
    org.freedesktop.devicekit.disks.filesystem-mount-system-internal

    Look for the line:
    'allow_active'auth_admin_keep'/allow_active'
    and replace it with:
    'allow_active'yes'/allow_active'
    Sorry the < character is being interpreted by blogger so it has been changed to '

    And save!


    Have fun!
    I love you...
    Ubuntu user: #19306 | Device: HP DV5-1150eo

  5. #15
    Join Date
    Apr 2007
    Location
    Denmark
    Beans
    134
    Distro
    Ubuntu Development Release

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    Strange, this only works until reboot ...
    Ubuntu user: #19306 | Device: HP DV5-1150eo

  6. #16
    Join Date
    Jan 2010
    Location
    U.K.
    Beans
    81
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    Great fix brokenleg. This did the trick for me (and held after reboot), though i am no longer asked for my password when i select to mount my OS X partition via nautilus, but this is an improvement.

    Cheers.

  7. #17
    Join Date
    Oct 2006
    Beans
    20

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    I hear you. I keep trying Ubuntu, but it's not a user-friendly operating system. And if Ubuntu isn't, then what linux OS is?

  8. #18
    Join Date
    Nov 2009
    Beans
    5

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    Hey All,

    I've got the same problem on kubutu 9.10 and tried the solutions posted above but like someone else above the fix doesn't survive a reboot. I've tried making similar edits to :

    /home/drreid/.kde/share/config/policykit-kderc
    /usr/share/PolicyKit/policy/org.freedesktop.policykit.policy
    /usr/share/polkit-1/actions/org.freedesktop.policykit.policy

    but still no luck.
    Last edited by drreid; April 5th, 2010 at 09:02 PM.

  9. #19

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    but like someone else above the fix doesn't survive a reboot.
    The edit described should work, and survive a reboot (but not an update to devicekit-disks
    So maybe it's a kubuntu thing...

    Anyway for karmic I prefer this method which will survive an update, you may want to give it a go.

    I'd suggest you undo your edits (editing these files willy-nilly is not recommended

    You could at the very least reinstall devicekit-disks which will overwrite any edits you made there.

    Code:
    sudo apt-get --reinstall install devicekit-disks
    Then follow as described here - 2 simple steps - use copy and paste

    http://ubuntuforums.org/showthread.p...01#post9071501

  10. #20
    Join Date
    Nov 2009
    Beans
    5

    Re: Suddenly: "Unable to mount"-"Authentication is required" on disk volumes.

    Thanks for the effort mc4man. I tried your fix. but I am still asked for the admin password.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •