Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 37

Thread: asoundconf is dead, long live asoundconf!

  1. #11
    Join Date
    Oct 2006
    Beans
    619
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: asoundconf is dead, long live asoundconf!

    craig@craig-desktop:~$ asoundconf list
    Names of available sound cards:
    Live
    craig@craig-desktop:~$ asoundconf set-default-card Live
    craig@craig-desktop:~$ asoundconf
    Usage:
    asoundconf is-active
    asoundconf get|delete PARAMETER
    asoundconf set PARAMETER VALUE
    asoundconf list

    Convenience macro functions:
    asoundconf set-default-card PARAMETER
    asoundconf reset-default-card
    asoundconf set-alsa
    asoundconf unset-alsa
    asoundconf set-oss PARAMETER
    asoundconf unset-oss

    craig@craig-desktop:~$ asound-gtk
    asound-gtk: command not found
    craig@craig-desktop:~$ asoundconf-gtk
    /home/craig/.themes/Darker theme/gtk-2.0/gtkrc:50: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    /home/craig/.themes/Darker theme/gtk-2.0/gtkrc:51: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
    /home/craig/.themes/Darker theme/gtk-2.0/gtkrc:52: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
    You need to make sure asoundconf is active!
    By default, asoundconf's configuration file is ~/.asoundrc.asoundconf
    and must be included in ~/.asoundrc. Open this file to make sure it is!
    craig@craig-desktop:~$

  2. #12
    Join Date
    Sep 2006
    Location
    Not far from reality...
    Beans
    236
    Distro
    Xubuntu 11.10 Oneiric Ocelot

    Re: asoundconf is dead, long live asoundconf!

    Well, you almost got through it...

    asoundconf is-active


    Is actually a command you need to type into the terminal, just in case you didn't know this.

    Aside from that, it looks like everything's working just fine. Unless you haven't set asoundconf as active (like the above command does) and you haven't restarted your desktop, I really can't imagine what the issue is.

    Also, just to note - your asoundconf did not show any other sound card. Either you don't have it plugged in at the moment, or there's a serious issue.

    Cheers,
    Ghost
    I am not here for your hearts and your minds - we have enough of those in stock, what we really need right now are feet and elbows...

  3. #13
    Join Date
    Oct 2006
    Beans
    619
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: asoundconf is dead, long live asoundconf!

    Quote Originally Posted by Ghost|BTFH View Post
    Well, you almost got through it...

    asoundconf is-active


    Is actually a command you need to type into the terminal, just in case you didn't know this.

    Aside from that, it looks like everything's working just fine. Unless you haven't set asoundconf as active (like the above command does) and you haven't restarted your desktop, I really can't imagine what the issue is.

    Also, just to note - your asoundconf did not show any other sound card. Either you don't have it plugged in at the moment, or there's a serious issue.

    Cheers,
    Ghost
    Yeah I turned the onboard back on now. But I input this and got this response:
    craig@craig-desktop:~$ asoundconf is-active
    File "/usr/bin/asoundconf", line 53
    needs_oss_dev = '''You have omitted a necessary parameter. Please specify an OSS device (e.g., /dev/dsp).
    ^
    SyntaxError: invalid syntax
    craig@craig-desktop:~$

  4. #14
    Join Date
    Sep 2006
    Location
    Not far from reality...
    Beans
    236
    Distro
    Xubuntu 11.10 Oneiric Ocelot

    Re: asoundconf is dead, long live asoundconf!

    Do you not have ALSA-OSS?

    Make sure you have that installed and give it another go.
    I am not here for your hearts and your minds - we have enough of those in stock, what we really need right now are feet and elbows...

  5. #15
    Join Date
    Jun 2007
    Beans
    10,903

    Re: asoundconf is dead, long live asoundconf!

    This will also help you run "Pulse-less": https://launchpad.net/~dtl131/+archive/ppa

  6. #16
    Join Date
    Sep 2006
    Location
    Not far from reality...
    Beans
    236
    Distro
    Xubuntu 11.10 Oneiric Ocelot

    Re: asoundconf is dead, long live asoundconf!

    Quote Originally Posted by Temüjin View Post
    This will also help you run "Pulse-less": https://launchpad.net/~dtl131/+archive/ppa
    I don't think his issue is going pulse-less, I think he just didn't have everything he needed installed when he set up ALSA.
    I am not here for your hearts and your minds - we have enough of those in stock, what we really need right now are feet and elbows...

  7. #17
    Join Date
    Oct 2006
    Beans
    619
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: asoundconf is dead, long live asoundconf!

    craig@craig-desktop:~$ sudo apt-get install alsa-oss
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    alsa-oss is already the newest version.
    The following packages were automatically installed and are no longer required:
    linux-headers-2.6.31-16 pidgin-data linux-headers-2.6.31-16-generic
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 13 not upgraded.
    craig@craig-desktop:~$

  8. #18
    Join Date
    Sep 2006
    Location
    Not far from reality...
    Beans
    236
    Distro
    Xubuntu 11.10 Oneiric Ocelot

    Re: asoundconf is dead, long live asoundconf!

    I'm honestly at a loss Tumpster.

    At this point, it's a guessing game...okay, it's asking to set a device for oss...

    What if we did...

    asoundconf set-oss Live

    and see if that works?
    I am not here for your hearts and your minds - we have enough of those in stock, what we really need right now are feet and elbows...

  9. #19
    Join Date
    Oct 2006
    Beans
    619
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: asoundconf is dead, long live asoundconf!

    craig@craig-desktop:~$ asounconf-gtk
    No command 'asounconf-gtk' found, did you mean:
    Command 'asoundconf-gtk' from package 'asoundconf-gtk' (universe)
    asounconf-gtk: command not found
    craig@craig-desktop:~$ asoundconf-gtk
    /home/craig/.themes/Darker theme/gtk-2.0/gtkrc:50: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
    /home/craig/.themes/Darker theme/gtk-2.0/gtkrc:51: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
    /home/craig/.themes/Darker theme/gtk-2.0/gtkrc:52: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
    Traceback (most recent call last):
    File "/usr/bin/asoundconf", line 49, in <module>
    needs_default_card = Live
    NameError: name 'Live' is not defined
    You need to make sure asoundconf is active!
    By default, asoundconf's configuration file is ~/.asoundrc.asoundconf
    and must be included in ~/.asoundrc. Open this file to make sure it is!

  10. #20
    Join Date
    Sep 2006
    Location
    Not far from reality...
    Beans
    236
    Distro
    Xubuntu 11.10 Oneiric Ocelot

    Re: asoundconf is dead, long live asoundconf!

    Okay, again...let's do what it says.

    gedit ~/asoundrc.asoundconf

    Make sure Live is set as the default card. If you don't have anything written in the file, then for some reason, you don't have things fully set up.

    Cheers,
    Ghost
    I am not here for your hearts and your minds - we have enough of those in stock, what we really need right now are feet and elbows...

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •