Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: perl: warning: Setting locale failed.

  1. #1
    Join Date
    Dec 2009
    Beans
    1

    perl: warning: Setting locale failed.

    All other threads were closed already, so i started a new one. It may spare some time for you.

    I have a virtual private server running Ubuntu 9.10 and got messages like this:
    Code:
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_US.UTF-8"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    To get rid of the messages I had to run this command:

    Code:
    # locale-gen en_US en_US.UTF-8 hu_HU hu_HU.UTF-8
    then

    Code:
    # dpkg-reconfigure locales
    The problem was solved. I didn't had to edit any files like /etc/environment
    Hope it helps for you!

    I found the solution here:
    http://www.linuxquestions.org/questi...41#post3540541

  2. #2
    Join Date
    Feb 2010
    Location
    Perth, Western Australia
    Beans
    3
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: perl: warning: Setting locale failed.

    didn't fix the error for me

  3. #3
    Join Date
    Mar 2010
    Beans
    3

    Re: perl: warning: Setting locale failed.

    Worked fine for me, thx.

  4. #4
    Join Date
    May 2008
    Location
    Italy/Switzerland
    Beans
    2
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: perl: warning: Setting locale failed.

    Works for me as well! Thanks.

  5. #5
    Join Date
    Sep 2006
    Location
    Maryland, USA
    Beans
    254
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: perl: warning: Setting locale failed.

    Didn't work for me either
    Impari Systems, Inc
    http://www.imparisystems.com

  6. #6
    Join Date
    Aug 2005
    Location
    Brussels
    Beans
    135
    Distro
    Ubuntu Development Release

    Re: perl: warning: Setting locale failed.

    Quote Originally Posted by matthewboh View Post
    Didn't work for me either
    Worked perfectly for me (Ubuntu 10.04). I just ran:

    sudo locale-gen en_US en_US.UTF-8 cy_GB.UTF-8


    Replaced hungarian (hu) for Welsh (cy).

  7. #7
    Join Date
    Jan 2011
    Beans
    4

    Re: perl: warning: Setting locale failed.

    Worked for a new install of 10.04 with added KDE desktop, for which running many applications (perl, firefox) gave "setting locale" error messages when run in Konsole. "sudo locale-gen en_US en_US.UTF-8" solved that problem for me. I kiss the toes of ejmadar for saving me _much_ time and aggravation .

  8. #8
    Join Date
    Apr 2007
    Location
    Edmonton, AB
    Beans
    22
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: perl: warning: Setting locale failed.

    You need to pay attention to your error message and issue a command for your missing locale.

    For example, this is the error I got:

    Code:
    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    	LANGUAGE = "en_CA:en",
    	LC_ALL = (unset),
    	LANG = "en_CA"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    The LANG string is the one you need. So, in my case this command solved my problem:

    Code:
    $ sudo locale-gen en_CA

  9. #9
    Join Date
    Apr 2011
    Beans
    2

    Re: perl: warning: Setting locale failed.

    Hi all,

    I installed ubuntu 10.10 a week ago, and got my vodaphone mobile broadband up and running. then some update was installed (usb modeswitch something) and... I couldn't get vodaphone to start. I got the same issues a in this thread, and with your suggestions I've actually managed to get it running (even though I don't have a clue what I'm actually doing ). So now the application starts up, says its connected, but then I STILL have no internet.

    The wierd thing is: when I left click on the internet icon, I can check enable mobile broadband, but as soon as I touch anything in firefox, the 'check mark' has disappeared...

    So: 1) thanks for all your help so far, and 2) has anyone got a clue what I can try now??

  10. #10
    Join Date
    Jan 2006
    Location
    San Diego
    Beans
    6
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: perl: warning: Setting locale failed.

    Quote Originally Posted by Heels View Post
    Hi all,

    I installed ubuntu 10.10 a week ago, and got my vodaphone mobile broadband up and running. then some update was installed (usb modeswitch something) and... I couldn't get vodaphone to start. I got the same issues a in this thread, and with your suggestions I've actually managed to get it running (even though I don't have a clue what I'm actually doing ). So now the application starts up, says its connected, but then I STILL have no internet.

    The wierd thing is: when I left click on the internet icon, I can check enable mobile broadband, but as soon as I touch anything in firefox, the 'check mark' has disappeared...

    So: 1) thanks for all your help so far, and 2) has anyone got a clue what I can try now??
    You could try starting a new thread.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •