Results 1 to 7 of 7

Thread: libg2c0 not found!

  1. #1
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 12.04 Precise Pangolin

    libg2c0 not found!

    I recently upgraded from 9.04 to 9.10...Now when I try to run a particular program, it says

    /Desktop/comphep-4.5.1/bin/s_comphep.exe: error while loading shared libraries: libg2c.so.0: cannot open shared object file: No such file or directory


    I cant get libg2c through sudo apt or synaptic..what is to be done? Is g77 not available for ubuntu?

  2. #2
    Join Date
    Apr 2007
    Location
    Germany
    Beans
    239
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: libg2c0 not found!

    NEVER use a command given to you before asking and knowing exactly what it does. Make sure you know what it is that you're telling your system to do before doing it; some commands can be very harmful to your system or leave you vulnerable to attack.

  3. #3
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: libg2c0 not found!

    This is what happened when I followed instructions...

    No candidate version found for g77
    No candidate version found for g77
    The following packages will be REMOVED:
    linux-headers-2.6.31-14{u} linux-headers-2.6.31-14-generic{u}
    0 packages upgraded, 0 newly installed, 2 to remove and 4 not upgraded.
    Need to get 0B of archives. After unpacking 82.0MB will be freed.
    Do you want to continue? [Y/n/?]



    I said no.....

  4. #4
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: libg2c0 not found!

    I downloaded the deb package and everything is fine now...


    http://packages.ubuntu.com/jaunty/libg2c0

  5. #5
    Join Date
    Sep 2009
    Beans
    62
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: libg2c0 not found!

    Thank you very much!

  6. #6
    Join Date
    Nov 2008
    Beans
    37
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: libg2c0 not found!

    I ran into this problem with Tomlab (7.4) in Matlab (7.7) in 10.04. I was able to successfully install the program by ignoring the dependencies

    By downloading the deb file from
    http://packages.ubuntu.com/jaunty/libg2c0

    and then running
    sudo dpkg --force-depends -i libg2c0_3.4.6-8ubuntu2_amd64.deb

    Hope that helps any tomlab / matlab linux user out there.

  7. #7
    Join Date
    Oct 2010
    Beans
    1

    Re: libg2c0 not found!

    It has helped me. Thank you.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •