Results 1 to 5 of 5

Thread: Unable to find Ogre3D demos after doing a repository install

  1. #1
    Join Date
    Apr 2008
    Beans
    14

    Unable to find Ogre3D demos after doing a repository install

    Pardon me if this is the wrong section to ask this question.

    I want to try out some basic Ogre3D implementations, and hence I downloaded and installed Ogre3D dev packages using Synaptic Package Manager (on Ubuntu 9.10).

    Once installed, I was trying to figure out where the Ogre3D demos were installed.

    Could some one please point me in the right direction?

    Or should I be going for an approach of getting the Ogre3D sources and doing the build myself? Would I then be able to get the Ogre3D demo?

  2. #2
    Join Date
    Jun 2007
    Beans
    27

    Re: Unable to find Ogre3D demos after doing a repository install

    I know nothing whatsoever about 3D or Ogre but this seem to cover alot:

    http://www.ogre3d.org/wiki/index.php/Ogre_Tutorials

  3. #3
    Join Date
    Sep 2009
    Beans
    1,293

    Re: Unable to find Ogre3D demos after doing a repository install

    ogre demos are not included in the debian packaging due to licensing issues (see debian bug 327423) There used to be a compiledemos.sh script to automatically download and compile them but this seems missing in the latest version, i'm not sure if this was intentional or a bug

  4. #4
    Join Date
    Apr 2008
    Beans
    14

    Re: Unable to find Ogre3D demos after doing a repository install

    Quote Originally Posted by ib.lundgren View Post
    I know nothing whatsoever about 3D or Ogre but this seem to cover alot:

    http://www.ogre3d.org/wiki/index.php/Ogre_Tutorials
    Yes, I was going through those Tutorials too. But most of them requires a particular header file that is available only in the examples/demos. That was another reason I was looking for the demos/examples.

    Quote Originally Posted by SevenMachines View Post
    ogre demos are not included in the debian packaging due to licensing issues (see debian bug 327423) There used to be a compiledemos.sh script to automatically download and compile them but this seems missing in the latest version, i'm not sure if this was intentional or a bug
    Yes SevenMachines - the download script (/usr/share/doc/libogre-dev/examples/compileall.sh ) does seem to be missing in the version (1.6) I installed from repositories. Guess, I need to download the sources and build it myself.

    Thanks for the replies!

  5. #5
    Join Date
    Sep 2009
    Beans
    1,293

    Re: Unable to find Ogre3D demos after doing a repository install

    this is fixed in debian libogre-dev_1.6.4.dfsg1-1. its in debian testing and a sync is requested so it should arrive happilly as part of lucid
    https://bugs.launchpad.net/ubuntu/+s...re/+bug/490492

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •