Results 1 to 5 of 5

Thread: gaming mouse way too sensitive (too fast!)

  1. #1
    Join Date
    May 2008
    Beans
    5

    Question gaming mouse way too sensitive (too fast!)

    I have a SteelSeries Ikari laser mouse which is rated for 3200cpi and so is very sensitive. I have tried to set mouse sensitivity and acceleration in gnome mouse panel to zero without any affect, it still goes way too fast for any normal desktop usage.

    How can I slow down my mouse?

    (I know, I could just turn down the sensitivity in the mouse itself, but I was able turn down the sensitivity down in Windows, so I want to do the same in Linux.)

  2. #2
    Join Date
    Feb 2010
    Location
    Buffalo, NY USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: gaming mouse way too sensitive (too fast!)

    If you're dual-booted to windows, log into windows, load up the mouse's software, and turn down the DPI.

    I had a similar problem with my Steelseries Warcraft mouse running at 3200dpi (way to "touchy."), I turned it down to 1800 and it's alot better in gnome.


    EDIT: Ack, sorry for rezzing an old post.. didn't see the date... (Was trying to find some support for my mouse....)
    Last edited by taurolyon; February 21st, 2010 at 08:16 AM.
    Ubuntu user since 2/16/2010.
    GigaByte MA790FXT-UD5P // AMD Phenom II X4 810 // Patriot Extreme 8GB PC3-12800 DDR3 1600 // Sapphire ATI HD5870 Vapor-X OC

  3. #3
    Join Date
    Jan 2006
    Beans
    90

    Re: gaming mouse way too sensitive (too fast!)

    use this:

    http://patrickmylund.com/blog/loweri...n-ubuntu-9-10/

    Open a terminal
    Run the command: xinput --list --short
    ⎡ Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ Razer USA, Ltd DeathAdder Mouse id=6 [slave pointer (2)]
    ⎜ ↳ Razer USA, Ltd DeathAdder Mouse id=7 [slave pointer (2)]
    ⎜ ↳ Razer DeathAdder id=11 [slave pointer (2)]
    ⎜ ↳ Macintosh mouse button emulation id=12 [slave pointer (2)]
    ⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ Dell Dell USB Keyboard id=10 [slave keyboard (3)]
    Note the name of your device. In my case, manipulating ‘Razer DeathAdder’ worked.
    Set the constant deceleration for the device:
    xinput --set-prop "Razer DeathAdder" "Device Accel Constant Deceleration" 5
    That’s it. You might have to play around with the value, but 5 slowed down my mouse sufficiently.

    To see the current settings for the device:
    xinput --list-props "Razer DeathAdder"
    To turn off mouse acceleration:
    xinput --set-prop "Razer DeathAdder" "Device Accel Velocity Scaling" 1
    To perform the tuning automatically, I simply created a file containing the script below, ran chmod +x on it and added it to System -> Preferences -> Startup Applications in GNOME:

    #!/bin/sh
    xinput --set-prop "Razer DeathAdder" "Device Accel Constant Deceleration" 5
    xinput --set-prop "Razer DeathAdder" "Device Accel Velocity Scaling" 1

  4. #4
    Join Date
    May 2010
    Location
    Norman, OK
    Beans
    8
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: gaming mouse way too sensitive (too fast!)

    You can script this and make it automagically grab the device id, too:

    Code:
    #!/bin/sh
    
    mouse=` xinput | grep DeathAdder | awk '{print $6}' | awk 'BEGIN {FS="=";} {print $2}'`
    xinput --set-prop $mouse "Device Accel Constant Deceleration" 5
    xinput --set-prop $mouse "Device Accel Velocity Scaling" 1
    Just save that into an executable bash script.

  5. #5
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: gaming mouse way too sensitive (too fast!)

    Old thread closed, please don't bump old threads.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •