Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 33

Thread: GRUB + Windows 7 = Can't put windows to sleep/hibernate

  1. #11
    Join Date
    Jan 2011
    Beans
    1

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    This is to confirm one of the earlier solutions (Aeric's).

    My (Dell Inspiron) laptop has 3 Windows partitions (in order, 100 MB marked "DELLUTILITY", 15 GB marked "Recovery", and the main 400+ GB partition marked "OS", with all the normal operating system files and program and user data), in addition to the Ubuntu/Linux area.

    Using Ubuntu's Disk Management tool, I found that the 2nd Windows partition was flagged as bootable. I tried changing the 1st partition to bootable (as suggested by Antithesis). This did not work. Following Aeric's advice, I returned to Windows 7 and (using its Disk Management tool), set the 3rd, "OS" partition to "Active". This worked! I can now successfully hibernate in both Windows 7 and Ubuntu.

    FWIW, when I restarted Ubuntu I now found that the 3rd partition was marked "bootable". I infer that the Windows phrase "Active" must mean the same thing as the Linux phrase "bootable". The significant factor was not to set the first partition bootable/active, but the actual partition used for my system files.

  2. #12
    Join Date
    Apr 2006
    Beans
    1

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    Quote Originally Posted by rvjr View Post
    Hi Justin!

    What did the trick for me is the following:

    You don't need to set the boot flag on the Windows7 partition itself, but really on the FIRST partition on the drive where the Windows partition resides on (in my case this was this small 100MB recovery partition windows automatically creates).

    Best
    Rainer
    Thanks dude..This did the trick for me too.
    Have a nice one.

  3. #13
    Join Date
    Apr 2008
    Beans
    61

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    Quote Originally Posted by justin956235 View Post
    hi i was hoping that you could help me out with this i have the same exact problem, just with a different setup. I have windows 7 installed on hd 2 in my system and ubuntu 9.10 installed on hd 1 with grub installed on it also. I did what you said in here and made it so boot was set to the first partition on the windows drive ( it was already) also i thought it might help to tell u that my linux partition with grub was set to boot also, i think grub set it to that. my system loads and grub works and everything is dandy, but in win 7 i get the same problem that you described with sleep.
    I know this is an old thread, but I have the same problem as Justin and haven't found a solution. I have the GRUB/Ubuntu drive (with some non-OS storage partitions) as hd0/sda and Windows 7 all by itself on hd1/sdb. The Windows 7 and GRUB/Ubuntu partitions are already marked as "boot" in fdisk (below) and GParted and "active" in Windows and Acronis. However, hibernation only works if I bypass GRUB and boot directly from the Windows 7 drive. The solution given here only seems to work if everything is on the same physical drive.

    By the way, there's a quick and easy way to determine whether hibernation problems are due to partition issues or something else. Just go to Control Panel > System > Advanced System Settings > Startup and Recovery > Settings and look at the "Default Operating System" drop-down at the top. If there's a partition issue then the drop-down is empty. EasyBCD will also give you an error message when it starts.

    Code:
    Disk /dev/sda: 1500.3 GB, 1500301910016 bytes
    255 heads, 63 sectors/track, 182401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xc566bf2c
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        4208    33799168   83  Linux
    /dev/sda2            4209       21832   141564779+  17  Hidden HPFS/NTFS
    /dev/sda3           21833      182401  1289770458    f  W95 Ext'd (LBA)
    /dev/sda5           21833       29665    62918537    7  HPFS/NTFS
    /dev/sda6           29666      140627   891302218+   7  HPFS/NTFS
    /dev/sda7          140628      177179   293603899    7  HPFS/NTFS
    /dev/sda8          177180      182401    41945683+   7  HPFS/NTFS
    
    Disk /dev/sdb: 128.0 GB, 128035676160 bytes
    242 heads, 36 sectors/track, 28704 cylinders
    Units = cylinders of 8712 * 512 = 4460544 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x724fc7a9
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1       28704   125032448    7  HPFS/NTFS
    Last edited by Quatrix; August 21st, 2011 at 05:36 AM.

  4. #14
    Join Date
    Nov 2011
    Beans
    1

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    Just a heads up but setting the 100MB System Reserved partition to carry the boot flag fixed not only the issue of my computer not being able to go to Sleep, but it also fixed an error (0x80070002 The system cannot find the file specified) that I was having when I tried using Windows Backup.

  5. #15
    Join Date
    Jul 2009
    Location
    Middle earth
    Beans
    72

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    Nice one! I was looking for this for a long time...

    Just one point in win7 the first partition is the recovery one, so its the partition on which win7 is installed that needs to be selected as boot, in my case its /dev/sda2

    Thanks a Ton! Cheers!
    If I have the belief that I can do it,
    I shall surely acquire the capacity to do it,
    even if I may not have it at the beginning.
    ~M.K. Gandhi

  6. #16
    Join Date
    May 2007
    Beans
    12,540

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    Quote Originally Posted by parth.s View Post
    Nice one! I was looking for this for a long time...

    Just one point in win7 the first partition is the recovery one, so its the partition on which win7 is installed that needs to be selected as boot ...
    Actually -- NO. It's not the order of the partition that matters, it's what it contains.

    When you buy a PC preloaded with Win7, there will be a small 100MB "boot" partition. That is the one containing the boot loader files. The Win7 OS files will be on another partition.

    In other cases, the Win7 boot loader directory and files -- and the Win7 OS files -- are in the same partition.

    The CORRECT partition is the one containing the Win7 boot loader directory and files. Where this happens to be on the drive depends entirely on HOW Win7 was installed.

    So, it's not necessarily true that the correct partition to have the boot flag is the first, or the second, or ... Instead, it's the one containing the boot loader stuff.
    Ubuntu 14.04, Mint 17; MS Win 8.1.
    Will not respond to PM requests for support -- use the forums.

  7. #17
    Join Date
    Feb 2009
    Beans
    20

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    Mark Phelps is right.
    I recommend the following method - if possible:
    The installation of Linux changes the ownership of the boot-procedure. The recovery-partition may not start anymore.

    Therefore:
    BEFORE installing Linux, make a copy of the recovery-partition or primary installation (USB-stick).
    Create a Windows-repair-CD (if the functionality is not included in the recovery-system)
    Install a minimal WUBI or MINT4WIN (4 GB are sufficient). Make a copy of /boot/grub/grub.cfg .
    In this copy, you will find the original values.

    Now install as many Linux-distributions as you want. (By now, I am trying three).
    If the hibernate-function of Win 7 does not work:

    - Start the repair-CD/USB-stick
    - Start the command-line
    - bootrec /fixmbr
    - bootrec /fixboot

    Start the WUBI or MINT4WIN-System (reinstall it if necessary).
    In the terminal:
    sudo update-grub

    Restart.
    The trick is, that hibernation works and Wubi/mint4win gives easy and independent, Win7-compatible (hibernation-friendly) control over Grub. If you don’t need the original copy of grub.cfg, you can install Wubi/mint4win at any time.

  8. #18
    Join Date
    Jul 2011
    Beans
    1

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    I was wondering why win7 was not hibernating. After reading this thread here's what fixed it for me:

    Triple boot partitions: XP, Win7, Ubuntu (in that order). Grub 2.

    cmd.exe (run as admin):
    Code:
    powercfg.exe /hibernate on
    hiberfile size was 75% of RAM size.
    So I changed the registry setting HKLM\System\CurrentControlSet\Control\Power\HiberF ileSizePercent to 100. Rebooted. Now hiberfile size is 100% of RAM size.
    Changed "What power buttons do" to enable hibernate.

    Booted using PartedMagic boot cd and selected XP partition as boot (previously win7 was boot). Rebooted into win7 and now win7 hibernates!

    Thanks folks.

  9. #19
    Join Date
    Nov 2009
    Location
    Somewhere in the world.
    Beans
    37

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    thanks!
    I LOVE UBUNTU!!
    Intel Core i5 540M @ 2533 MHz
    8192 MB (2 x 4096 DDR3-SDRAM )
    ATI Mobility Radeon HD 4670 1 GB(1920x1080 res)

  10. #20
    Join Date
    Apr 2008
    Beans
    61

    Re: GRUB + Windows 7 = Can't put windows to sleep/hibernate

    Quote Originally Posted by CorruptDNA View Post
    thanks!
    Huh?

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •