Results 1 to 4 of 4

Thread: Compiz: No focused window when switching viewports

  1. #1
    Join Date
    Jun 2005
    Beans
    102

    Compiz: No focused window when switching viewports

    I am running Compiz (on Ubuntu 9.10 with Nvidia card). When I switch viewports, none of the windows in the target viewport will have focus. When I then switch back to the last viewport in which I did have focus, the focus will have been lost there as well.

    The problem is exactly as described in this bug here. That's from 2007 and ends with a note that this issue is fixed now.

    But for me, in the latest Ubuntu, I still have that problem

    Has anyone else seen this, or is there a setting I can fiddle with that might fix the problem?

    Thank you very much...

  2. #2
    Join Date
    Jun 2005
    Beans
    102

    Re: Compiz: No focused window when switching viewports

    Hello!

    Am I the only one with that issue?

    I just found the raise-on-rotate option in gconf-editor. It was set to 'off'. After switching it on, it actually worked for about two seconds (I switched viewports and on doing so a window in the other viewport was actually focused). But then it stopped working again. Now toggling that flag does not have any further effect.

    Please, anyone?

  3. #3
    Join Date
    Jan 2007
    Beans
    Hidden!

    Re: Compiz: No focused window when switching viewports

    This was really annoying me as well - I just found out how to fix it.
    1. Enable the compiz "Window Rules" Plugin in the CompizConfig Manager.
    2. Add a "No Focus" rule:
      Code:
      type=Desktop | class=Cairo-dock

    Otherwise, the Desktop gets the focus when you switch to an empty workspace and keeps it after you switch back.

    Tested on Kubuntu 9.10 32bit and Kubuntu 10.04 64bit
    Last edited by cerbero626; July 8th, 2010 at 11:10 PM. Reason: Added distro info

  4. #4
    Join Date
    Aug 2008
    Beans
    5

    Re: Compiz: No focused window when switching viewports

    What fixed it for me:

    1. Enable the compiz "Window Rules" Plugin in the CompizConfig Manager.
    2. Add a "No Focus" rule:

    Code:
    type=Dock
    Thanks for pointing me in the right direction cerbero626.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •