Results 1 to 3 of 3

Thread: Visual configuration changes when booting.

  1. #1
    Join Date
    Nov 2009
    Location
    Buenos Aires
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Smile Visual configuration changes when booting.

    Hello, ladies and gentlemen.


    Before moving on to my problem, I just want to say that I'm new to Ubuntu, so I'll try to give the details I think are relevant. I apologize if this is long or not specific enough. I've read threads on these issues, but I couldn't fix them, yet.

    The problem is the following: At first, I couldn't choose the resolution I normally use (1280x1024), so I started looking around for a solution, and I found this on Ubuntu Wiki

    https://wiki.ubuntu.com/X/Config/Resolution .

    As you can see in the section "Adding undetected resolutions", before the xorg.conf thing, there is the following command:

    Code:
    $ cvt 800 600
    This command let me add the 1280x1024, choose it, and make it work. But when the system is loading, more precisely on the Ubuntu screen with the loading bar before the login screen, it resizes itself from 1280x1024 to 1152x864. I have to change the resolution every time I log in to the system. I don't get used to it because its like the 1152x864 screen is contained in a 1280x1024 black square, which looks quite awful. It doesnt adapt to the size of the screen.

    I thought that saving the configuration on the NVidia panel (GeForce 9500 GT, by the way) would help solve the problem, but I just couldn't save it. The error was/is:

    Unable to remove old X config backup file '/etc/X11/xorg.conf.backup'.
    Reading some threads I managed to save it, but it didn't help at all.

    I could have accesed the xorg.conf and changed things myself, but I didn't want to have to explain more things here

    I will quote what it says:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings: version 1.0 (buildd@palmer) Sun Feb 1 20:21:04 UTC 2009

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 1.0 (buildmeister@builder63) Fri Aug 14 17:54:58 PDT 2009

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "ServerFlags"
    Option "Xinerama" "0"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Samsung"
    HorizSync 30.0 - 70.0
    VertRefresh 50.0 - 160.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 9500 GT"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "1280x1024 +0+0; 1280x960 +0+0"
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection
    That would be one thing. I also have to reconfigure the brightness/gamma thing every single time I boot the system, it doesn't save the configuration.

    Well, thats all. If anyone feels like helping me with one of this issues, I would really appreciate it. I did what I could do/understand, but I need some help

  2. #2
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Visual configuration changes when booting.

    Quote Originally Posted by Lunfardo View Post
    Hello, ladies and gentlemen.


    Before moving on to my problem, I just want to say that I'm new to Ubuntu, so I'll try to give the details I think are relevant. I apologize if this is long or not specific enough. I've read threads on these issues, but I couldn't fix them, yet.

    The problem is the following: At first, I couldn't choose the resolution I normally use (1280x1024), so I started looking around for a solution, and I found this on Ubuntu Wiki
    ..........
    Code:
    gksudo gedit /etc/usplash.conf
    sudo update-initramfs -u -k all
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  3. #3
    Join Date
    Nov 2009
    Location
    Buenos Aires
    Beans
    3
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Visual configuration changes when booting.

    Thank you for your time, but despite I set it to the desired resolution, it would not work. No errors were shown while updating the initramfs.

    Since I will be sharing the computer, I will have to install Windows, then Ubuntu again. Maybe I won't have that problem when I'm back, I hope. Thank you anyway.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •