Results 1 to 7 of 7

Thread: 9.1 upgrade, now pvr350 fails

  1. #1
    Join Date
    Dec 2007
    Beans
    123

    9.1 upgrade, now pvr350 fails

    Since 'upgrading' to 9.10 the PV350 which is hooked to the cable box fails to do anything. The logs (thru mythweb) only show
    "Canceled recording (Recorder Failed)"
    When I go into live TV and change to that tuner it's the last thing the front end will do - have to kill it.

    Both channels of the PVR500 work fine - though they decode directly and can't do the high channels.

    The 350 was working perfectly in 9.04, and I've made no changes which should affect it.

    Any help would be appreciated, I'd sure like to get this fixed as my system is crippled right now.
    Last edited by MonsterMaxx; November 25th, 2009 at 05:58 AM.

  2. #2
    Join Date
    May 2007
    Beans
    2,334

    Re: 9.1 upgrade, now pvr350 fails

    Hi,

    What messages do you see in the syslog (/var/log/syslog) and in the mythtv backend log (/var/log/mthtv-backend.log) when you try and record from the PVR350?

    Regards
    Ian Dobson
    Walking on water and writing software to specification is easy if they're frozen.

    My corner of the internet http://www.planet-ian.com

  3. #3
    Join Date
    Dec 2007
    Beans
    123

    Re: 9.1 upgrade, now pvr350 fails

    the backend log is no more informative

    2009-11-24 23:27:26.300 Canceled recording (Recorder Failed): Curb Your Enthusiasm "The Grand Opening": channel 2504 on cardid 3, sourceid 2
    2009-11-24 23:27:26.305 scheduler: Canceled recording (Recorder Failed): Curb Your Enthusiasm "The Grand Opening": channel 2504 on cardid 3, sourceid 2

    syslog doesn't have anything either. Though this event might be where I tried live TV
    Nov 24 23:28:57 MythTV-SRV kernel: [793492.681360] mythfrontend.re[32380]: segfault at 0 ip 076e6c04 sp a86d6fe0 error 4 in libQtCore.so.4.5.2[7625000+22b000]
    Nov 24 23:29:19 MythTV-SRV pulseaudio[2925]: ratelimit.c: 24 events suppressed
    Last edited by MonsterMaxx; November 25th, 2009 at 08:07 AM.

  4. #4
    Join Date
    Dec 2007
    Beans
    123

    Re: 9.1 upgrade, now pvr350 fails

    I think I'm finding a clue.

    2009-11-25 02:28:11.840 TVRec(3): ASK_RECORDING 3 0 0 0
    2009-11-25 02:28:11.989 MainServer::ANN Monitor
    2009-11-25 02:28:12.006 adding: MythTV-SRV as a client (events: 1)
    2009-11-25 02:28:12.149 TVRec(3): Changing from None to Watching RecordingOnly
    2009-11-25 02:28:12.151 TVRec(3): HW Tuner: 3->3
    /usr/local/bin/6200ch: error while loading shared libraries: libraw1394.so.8: cannot open shared object file: No such file or directory
    2009-11-25 02:28:12.222 ret_pid(5663) child(5663) status(0x7f00)
    2009-11-25 02:28:12.227 ChannelBase: external tuning program exited with error 127
    2009-11-25 02:28:12.242 TVRec(3) Error: Failed to set channel to 501. Reverting to kState_None
    2009-11-25 02:28:12.243 TVRec(3): Changing from Watching RecordingOnly to None
    2009-11-25 02:28:12.275 AutoExpire: CalcParams(): Max required Free Space: 1.0 GB w/freq: 15 min
    2009-11-25 02:28:12.276 Canceled recording (Recorder Failed): Angels in America: channel 2501 on cardid 3, sourceid 2
    2009-11-25 02:28:12.280 scheduler: Canceled recording (Recorder Failed): Angels in America: channel 2501 on cardid 3, sourceid 2
    2009-11-25 02:28:12.365 ProgramInfo, Error: GetPlaybackURL: '2501_20091125022800.mpg' should be local, but it can not be found.


    A friend of mine tweaked the firewire channel changer...seems this got blown up with the 9.10 'upgrade'

  5. #5
    Join Date
    Dec 2007
    Beans
    123

    Re: 9.1 upgrade, now pvr350 fails

    I can't reach my friend. Anyone have any bright ideas how to fix this or do I need to wait for him?

    Cable box is a motorola DCH6200, we were unable to get it to work with the standard firewire channel changer, he tweaked something to make it work in 9.04. Now 9.10 has broken that.

    Bright ideas? Sure would like to get my system fixed.

    Thanks.

  6. #6
    Join Date
    Dec 2007
    Beans
    123

    Re: 9.1 upgrade, now pvr350 fails

    Really? no one has any idea how to fix this thing?

  7. #7
    Join Date
    Dec 2007
    Beans
    123

    Re: 9.1 upgrade, now pvr350 fails

    Finally fixed this, all my my lonesome.

    Here's the keys to the kingdom in case anyone else runs into this problem.

    First I had to make sure the channel changer script was loaded correctly, that is 6200ch is in the right place, it was. Then make sure it's the right version, it was not. So I compiled and updated the 6200ch.

    Next it still wouldn't work. So I had to find out why. Reason is that there's a zillion different DCH6200 cable boxes and they have different internal ids. So, run plugreport to get the vendor and model id. Then edit the 6200ch.c and steal one of the vendor ids and model ids. Don't add another number, this won't work, just replace one.

    Compile and copy to the usr/bin/local dir.

    Test by seeing which node it's on with plugreport and using something like 6200ch -v -n 0 55
    The -v is verbose, the -n 0 tells it node 0 and the 55 is the channel to change to.
    If that works and you don't get an error message, go into backend setup and add the /usr/bin/local/6200ch -n 0 to the channel change line (in my case I had to add the -n 0 to address node 0).

    Restart the backend.

    Voila, it works.


    Yeaaaa, I feel like such a computer geek god today.
    (not really as the audio stuff is still screwed, but I'll fight that battle another day)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •