Page 1 of 2 12 LastLast
Results 1 to 10 of 66

Thread: Unable to mount USB, Not Authorized

Hybrid View

  1. #1
    Join Date
    Oct 2007
    Beans
    1

    Unable to mount USB, Not Authorized

    My father just upgraded his laptop from Jaunty to Karmic and has run into an issue when he plugs in his USB flash drive.

    When he tries to plug in any USB, he gets the error "Unable to mount USB, Not Authorized"

    I am going there after work to check it out, just wondering if anyone has a solution to this.

    Here is a screen shot of the error: http://imgur.com/hvGwY.jpg

    Thanks in advance.

  2. #2
    Join Date
    Nov 2004
    Location
    Anywhere
    Beans
    Hidden!

    Re: Unable to mount USB, Not Authorized

    Quote Originally Posted by bman87 View Post
    My father just upgraded his laptop from Jaunty to Karmic and has run into an issue when he plugs in his USB flash drive.

    When he tries to plug in any USB, he gets the error "Unable to mount USB, Not Authorized"

    I am going there after work to check it out, just wondering if anyone has a solution to this.

    Here is a screen shot of the error: http://imgur.com/hvGwY.jpg

    Thanks in advance.
    It's another bug my friend...lead with it the best you can...

    Bug 478274

    I have the same problem in a minimal karmic install...back to 9.04...i'm a little tired of karmic not working stuff...

  3. #3
    Join Date
    Feb 2008
    Beans
    16

    Re: Unable to mount USB, Not Authorized

    Just ran into this in Karmic. Annoying.

    Do this:
    sudo users-admin, go to Properties > User Privileges and check "Mount user-space filesystems (FUSE)". Log out, log in, try connecting the drive again; it ought to work.

  4. #4
    Join Date
    Jul 2008
    Location
    Oklahoma, USA
    Beans
    31
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Unable to mount USB, Not Authorized

    I am having the same problem...

    I am running a barebones Karmic install.
    (installed command line only, then added fluxbox, nautilus --no-desktop, etc)

    How do I change this using the command line? I assume I need to edit the /etc/groups file, but I checked and I am already in the "disk and plugdev" groups that seems to have the permissions to do this.

    I have mounted the drive manually using the "sudo umount" command, so maybe the problem is tied in with nautilus?

    Thanks

    -Ryan
    Last edited by GeneralSpecific; December 29th, 2009 at 05:55 PM.
    --
    He attacked everything in life with a mix of extraordinary genius and naive incompetence, and it was often difficult to tell which was which.
    - Douglas Adams

  5. #5
    Join Date
    Jul 2008
    Location
    Oklahoma, USA
    Beans
    31
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Unable to mount USB, Not Authorized

    Well, I wish someone had some input for me. I'm still having trouble.

    I found this site and followed the recommendations...no dice.

    To repeat...I can mount using the command line, but nautilus gives me a permission error.

    How do I change the way nautilus handles the permissions of USB drives?

    Does Ubuntu Karmic still use HAL? Is that where my problem lies?
    I'm willing to do the work and the digging myself, but I need to be pointed in the right direction.

    -Ryan
    --
    He attacked everything in life with a mix of extraordinary genius and naive incompetence, and it was often difficult to tell which was which.
    - Douglas Adams

  6. #6
    Join Date
    Jan 2010
    Location
    Twin Cities, Minnesota
    Beans
    2
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Unable to mount USB, Not Authorized

    I am having the same problem now. I did not at first, but I changed to a console login using http://ubuntuguide.net/boot-into-con...up-ubuntu-9-10 . Now I cannot mount my usb drive as a normal user. I enabled the root login and was able to mount it that way, but that is not an acceptable ongoing solution..

    So my guess is that there is something in gdm, or a related part of the boot process, that grants the permissions. However, Google has not yet led me to the answer.

  7. #7
    Join Date
    Jul 2008
    Location
    Oklahoma, USA
    Beans
    31
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Unable to mount USB, Not Authorized

    Hmmmm...

    We may be onto something. I am not using gdm. I am currently using nodm to auto login. Now I would think that by using auto login and not having to type in your password could cause this...BUT...when I disable auto login, manually login and then startx.

    I have the same exact error message: "Not Authorized"

    Could it tie in with the gnome-keyring and nautilus? I think it installs by default, but I don't think I am really using it.

    -Ryan
    Attached Images Attached Images
    --
    He attacked everything in life with a mix of extraordinary genius and naive incompetence, and it was often difficult to tell which was which.
    - Douglas Adams

  8. #8
    Join Date
    Jan 2010
    Location
    Twin Cities, Minnesota
    Beans
    2
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Unable to mount USB, Not Authorized

    More data: With the drive mounted when logged on as root I got this result for the USB drive when running the mount command.

    /dev/sdc1 on /media/Cruzer type vfat (rw,nosuid,nodev,uhelper=devkit,uid=0,gid=0
    ,shortname=mixed,dmask=0077,utf8=1)

    This was after a console logon, and I could not mount the drive as myself--just as root, using the usual Ubuntu configuration of Gnome and Nautilus.

    However, this is an old (Pentium 3) machine. Gnome is rather slow, so I replaced it with the Fluxbox window manager, and installed Thunar as an alternative to Nautilus. This time the USB drive mounted correctly for me--seemed to like the minimalist technology As a practical matter I am OK now, but I am still curious about what happened. Apparently Nautilus has some problem here, somehow interrelated with the boot/gdm issue. FWIW, I reran the mount command. The USB drive showed up with

    /dev/sdc1 on /media/Cruzer type vfat (rw,nosuid,nodev,uhelper=hal,shortname=winnt,iocha rset=utf8,uid=1000)

    I don't know the mount parameters well enough to interpret the results.

    Actually, I should test a couple more combinations: Fluxbox/Nautilus and Gnome/Thunar. That will have to wait for another day.

  9. #9
    Join Date
    Mar 2010
    Location
    England
    Beans
    122
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Unable to mount USB, Not Authorized

    Quote Originally Posted by dnquark View Post
    Just ran into this in Karmic. Annoying.

    Do this:
    sudo users-admin, go to Properties > User Privileges and check "Mount user-space filesystems (FUSE)". Log out, log in, try connecting the drive again; it ought to work.
    I know this topic is old, but I want to say this worked perfectly.

    Installed a second internal hard drive. Had same issues as OP.
    This fixed it! 30 minutes of searching and this fixed it just like that.

  10. #10
    Join Date
    Feb 2009
    Location
    Boone, NC
    Beans
    517
    Distro
    Ubuntu Studio 11.10 Oneiric Ocelot

    Re: Unable to mount USB, Not Authorized

    Quote Originally Posted by dnquark View Post
    Just ran into this in Karmic. Annoying.

    Do this:
    sudo users-admin, go to Properties > User Privileges and check "Mount user-space filesystems (FUSE)". Log out, log in, try connecting the drive again; it ought to work.
    This didn't seem to fix the problem for me. Not only is iPod not detected automatically in banshee when connected (a previous bug that no one has fixed yet), now, there's no workaround for the previous bug at all. I can no longer manually mount the iPod or any USB storage device whatsoever.

    Old banshee bug + new, freshly annoying bug = no more ipods, flash drives,.....

    This is extremely irritating, and a really big distraction from my physics homework. All I want to do is work on my homework and listen to tunes.

    why must the simplest things be so difficult?

    PS: Sorry guys, just venting.
    "Be who you are and say what you feel because those that mind don't matter and those that matter don't mind."
    Ubuntu Registered User #29486

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •