Page 18 of 21 FirstFirst ... 81617181920 ... LastLast
Results 171 to 180 of 201

Thread: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

  1. #171
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    As promised by ALLurGroceries, the Dell mini 10 touchpad is indeed recognized in Maveric. I had to add
    synclient AreaBottomEdge=700 AreaLeftEdge=25 AreaRightEdge=1125 MinSpeed=0.3 AccelFactor=0.58 to startup commands to make the buttons usable. I've also tried adding the following to xorg.conf, but the settings are ignored. Anyone knows why?
    Code:
    Section "InputDevice"
            Identifier      "Elantech Touchpad"
            Driver          "synaptics"
            Option          "Device"                "/dev/input/mouse0"
            Option          "Protocol"              "auto-dev"
            Option          "AreaBottomEdge"        "700"
            Option          "AreaLeftEdge"          "25"
            Option          "AreaRightEdge"         "1125"
    EndSection
    I've not the slightest idea how to add it as a udev rule.

    Syndaemon can now be used to disable touchpad when typing. The default timeout is 0.5 seconds, and there seems to be no straight forward way to change it, or at least I couldn't find it. You have to kill the daemon and then relaunch with your own timeout, 'syndaemon -i 1 -k' in my case.
    Last edited by mikewhatever; January 10th, 2011 at 09:55 AM.

  2. #172
    Join Date
    Oct 2008
    Beans
    100

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    @mikewhatever try throwing the option lines in /usr/lib/X11/xorg.conf.d/10-synaptics.conf

  3. #173
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    ALLurGroceries, thanks for input, but those settings are ignored too. I also had to create the highlighted part because it didn't exist.
    /usr/lib/X11/xorg.conf.d/10-synaptics.conf

  4. #174
    Join Date
    Sep 2007
    Beans
    Hidden!

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    After reading the last few posts I took a hint and in-place upgraded my ASUS K50ij from 10.04 to latest 10.10. Wow I can't believe it. That alone fixed my touchpad problems without making any adjustments to settings!

    Even though touchpad problems seem like a small issue, I didn't realize how critically important it was until I finally got it fixed! It is fabulous to not have cursor bouncing everywhere when typing.

    Thanks Groceries, you can have mine.

  5. #175
    Join Date
    Oct 2008
    Beans
    100

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    @mikewhatever sorry that was bad info, I don't use Ubuntu, I'm on Debian.. it looks like it may have been changed to /usr/share/X11/xorg.conf.d now since 10.10. Give that a shot, if it still doesn't work, I'll dig into the documentation for 10.10.

    @oregonbob glad you're happy, but I can't take the credit for the final patches... I just made an initial patch and wrote a guide.

  6. #176
    Join Date
    Sep 2007
    Beans
    Hidden!

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    That was a nasty bug that took a long time to get resolved. I have become spoiled from previous versions when bugs were often fixed within days or a week at most. But finally 10.10 fixed it. It also fixed my upside video cam. I'm on a roll. In both of those bugs I tried almost all of the fixes without success, to the point I gave up.

  7. #177
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Quote Originally Posted by ALLurGroceries View Post
    @mikewhatever sorry that was bad info, I don't use Ubuntu, I'm on Debian.. it looks like it may have been changed to /usr/share/X11/xorg.conf.d now since 10.10. Give that a shot, if it still doesn't work, I'll dig into the documentation for 10.10.
    You are quite right, that's probably the right place, but when I've added 10-synaptics.conf and rebooted, the keyboard didn't work so that I couldn't check if the settings were applied. Promptly used the recovery mode to delete it. This was the content:
    Code:
    Section "InputClass"
            Identifier      "Elantech Touchpad"
            Driver          "synaptics"
            Option          "Device"                "/dev/input/mouse0"
            Option          "Protocol"              "auto-dev"
            Option          "AreaBottomEdge"        "700"
            Option          "AreaLeftEdge"          "25"
            Option          "AreaRightEdge"         "1125"
    EndSection
    I've also noticed that the Min/Max Speed and AccelFactor I've set with GpointingDeviceSettings are being ignored as well.

  8. #178
    Join Date
    Oct 2008
    Beans
    100

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Oh yeah, you'd need only the option lines, specifically the last 3, nothing else, not even the section markers. That's crazy that the keyboard died, lol! Not sure why... Also, make sure your settings between gnome-mouse-properties and gpointing-device-settings agree, mouse-properties will take precedence.

  9. #179
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    So, I created /usr/shar/X11/xorg.conf.d/10-synaptics.conf with the following content and rebooted ...
    Code:
          Option          "AreaBottomEdge"        "700"
          Option          "AreaLeftEdge"          "25"
          Option          "AreaRightEdge"         "1125"
    ... and it gets stuck at the splash screen. The recovery mode saved the day again.
    Last edited by mikewhatever; January 7th, 2011 at 05:11 PM.

  10. #180
    Join Date
    Mar 2011
    Beans
    3

    Re: Elantech touchpad improperly recognized as “ImPS/2 Logitech Wheel Mouse”

    Hello!

    Are there any progress with this Elantech driver here? The above described methods do not work for me, my touchpad is always detected as PS/2 Logitech Mouse.

    I use a Samsung QX310 laptop with Elantech touchpad. Ubuntu 10.10, kerr 2.6.35-28-generic.

Page 18 of 21 FirstFirst ... 81617181920 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •